При работа с файлове, разположени на файлов сървър, системата спира да отговаря, производителността на файловия сървър спада или възникват забавяния.

Преводи на статии Преводи на статии
ID на статията: 822219 - Преглед на продукти, за които се отнася тази статия.
Разгъване на всички | Сгъване на всички

Симптоми

Докато работите с файлове по мрежата, е възможно да наблюдавате един или повече от следните симптоми:
  • Работещ под Windows файлов сървър, който е конфигуриран като файл и сървър за печат, престава да отговаря и функционирането му като файл и сървър за печат временно се прекратява.
  • Възникват неочаквано продължителни забавяния при отваряне, запис, затваряне, изтриване или отпечатване на файлове, които са разположени върху споделен ресурс.
  • При използване на програма по мрежата се усеща временно влошаване на производителността. Обикновено то трае около 40-45 секунди. В някои случаи обаче може да продължи до 5 минути.
  • Възникват забавяния при копиране или архивиране на файлове.
  • Когато се свържете към споделен ресурс, Windows Explorer престава да отговаря или върху свързания мрежов диск се появява червен знак "Х".
  • Когато влезете във файловия сървър, въвеждайки името и паролата си в диалоговия прозорец Log On to Windows ("Влизане в Windows"), се появява празен екран. Работният плот не се появява.
  • Програма, която използва отдалечено извикване на процедури (RPC) или именовани канали за връзка с файлов сървър, престава да отговаря.
  • Сървърът временно престава да отговаря, а в системния дневник на файловия сървър се появяват едно или повече съобщения за събития от вида:

    Код на събитието: 2022
    Източник: Srv
    Тип: Грешка
    Описание:
    Сървърът не успя да открие свободна връзка <брой> пъти през последните <брой> секунди.

    Код на събитието: 2021
    Източник: Srv
    Тип: Грешка
    Описание:
    Сървърът не успя да създаде работен обект <брой> пъти през последните <брой> секунди.

    Код на събитието: 2020
    Източник: Srv
    Тип: Грешка
    Описание:
    Поради липса на останала памет сървърът не успя да отдели памет от обема, позволяващ прехвърляне във файла за виртуална памет.

    Код на събитието: 2019
    Източник: Srv
    Тип: Грешка
    Описание:
    Поради липса на останала памет сървърът не успя да отдели памет от обема, недопускащ прехвърляне във файла за виртуална памет.

    Код на събитието: 2510
    Източник: Сървър
    Тип на събитието: Грешка
    Описание:
    Услугата на сървъра не можа да установи съответствие за код на грешка 1722.
    1722 = RPC_S_SERVER_UNAVAILABLE = услугата RPC е недостъпна.

    Освен това в системния дневник на клиентския компютър се появява следното събитие:

    Код на събитието: 3013
    Тип на събитието: Грешка
    Източник на събитието: MrxSmb / Rdr
    Описание:
    Програмата за пренасочване е прекратила заявката за име_на_компютъра поради изтичане на разрешеното време.

  • При опит за свързване към споделен ресурс се получава съобщение за грешка от следния тип:Съобщение за грешка 1
    Системна грешка 53. Мрежовият път не беше намерен.
    Съобщение за грешка 2
    Системна грешка 64. Посоченото мрежово име вече не е достъпно.
  • Компютърът периодично се изключва от мрежовите ресурси и не може да се свърже отново към ресурсите на файловия сървър. Сървърът обаче е достъпен за командата ping и можете да се свържете към него чрез сесия на Terminal Services (Терминални услуги).
  • Ако няколко потребители поискат достъп до Microsoft Office документи на сървъра, при отварянето на файла от втория и следващите потребители не винаги се появява диалоговият прозорец File is locked for editing ("Файлът е заключен за редактиране").
  • Мрежово проследяване показва 30 до 40 секунди закъснение между команда на клиент на услугата SMB и отговора от файловия сървър.
  • При опит за отваряне на файл с база данни от Access 2.0 (.mdb файл) в Microsoft Access 97, Microsoft Access 2000 или Microsoft Access 2002 може да се появи съобщение за грешка от типа:
    Дискова или мрежова грешка.
  • При опит за отваряне на файл от Microsoft Word е възможно да получите следното съобщение за грешка:
    Word не успя да прочете файла име_на_файл. Моля възстановете мрежовата връзка или сменете дискетата и опитайте отново.
Освен това в системния дневник на клиентския компютър може да се регистрира следното събитие:

Тип: Предупреждение
Източник: MrxSmb
Код на събитието: 50
Описание: {Lost Delayed-Write-Data} Системата се опитваше да прехвърли данни от буферите към \Device\LanmanRedirector. Записът беше неуспешен и е възможно във файла да са записани само някои от данните.

Причина

Този проблем може да се появи, ако на компютъра е инсталирана програма на други разработчици, която използва остарял филтърен драйвер за режим на ядрото (kernel mode). Това може да се получи в следните случаи:
  • На компютъра е инсталирана една от следните програми:
    • ARCserve Backup Agent for Open Files или ARCserve Open File Agent на Computer Associates International, Inc. с остарял Ofant.sys драйвер.
    • Open Transaction Manager с остарял Otman.sys драйвер.

      Забележка Open Transaction Manager е включен в някои програми на VERITAS Software Corporation, но може да се инсталира и отделно от тях. Така например Open Transaction Manager може да е включен към Open File Option, която от своя страна може да е включена към VERITAS Backup Exec.
    • Програма на VERITAS (като Open File Option), използваща остарели драйвери Otman4.sys или Otman5.sys.
  • Драйверът за програмата е несъвместим с филтърния драйвер, инсталиран на компютъра от антивирусна програма на други разработчици. В резултат на това е възможно филтърният драйвер на сървъра да връща на услугата Server грешен код за състояние. Така например драйверът може да върне код STATUS_SUCCESS вместо STATUS_OPLOCK_BREAK_IN_PROGRESS.

Разрешение

За решаване на проблема се свържете с производителя на програмата и попитайте за актуализиран филтърен драйвер. За повече информация относно начините за свързване с Computer Associates и изискване на последната актуализация на драйвера Ofant.sys посетете следния уеб сайт на компанията:
http://www.ca.com/support/
Ако сте инсталирали самостоятелно Open Transaction Manager, свържете се с Columbia Data Products, Inc. и попитайте за актуализация, която може да реши проблема. За целта посетете следния уеб сайт:
http://www.cdp.com/
За повече информация относно начините за свързване с VERITAS посетете следния уеб сайт на компанията:
http://support.veritas.com/
Microsoft предоставя информация за контакти с външни производители, за да ви помогне да намерите техническа поддръжка. Тази информация за контакти може да се променя без предизвестие. Microsoft не гарантира точността на информацията за контакти с външни производители.

Допълнителна информация

Важно Тази статия, метод или задание съдържа информация за модифициране на системния регистър. Имайте предвид, че при неправилна промяна на регистъра е възможно да възникнат сериозни проблеми. Затова спазвайте внимателно тези стъпки. За допълнителна сигурност направете резервно копие на регистъра, преди да го промените. В случай на възникване на проблем след това ще можете да възстановите регистъра. За допълнителна информация как да направите резервно копие на системния регистър или да възстановите регистъра щракнете върху следния номер на статия от базата знания на Microsoft:
322756 Създаване на резервно копие и възстановяване на системния регистър в Windows


За временно избягване на проблема рестартирайте Server услугите на сървъра. За целта изпълнете следната процедура:
  1. Щракнете върху Start ("Старт") и изберете Run ("Изпълни").
  2. В полето Open ("Отвори") въведете cmd и щракнете върху OK.
  3. В командния ред въведете следните команди, като натискате клавиша Enter след всеки ред:
    net stop server
    net start server
За да отстраните проблема, използвайте някой от следните методи:
  • Използвайте Performance Logs and Alerts ("Дневници и предупреждения за производителността"), за да наблюдавате броячаAvg. Disk Queue Length ("Средна дължина на опашката на диска") за обекта PhysicalDisk ("Физически диск"). При нормални условия броят чакащи входни/изходни (I/O) заявки е не повече от 1.5 до 2 пъти броя на шпинделите в обекта "Физически диск". Повечето дискове имат по един шпиндел, но RAID устройствата обикновено имат повече от един. Когато една програма извършва малки последователни входно-изходни операции, броячът Current Disk Queue Length ("Текуща дължина на опашката на диска") отчита пик при поставянето на тези операции на опашката. Може да се забележи и увеличаване на показанието на брояча Context Switches/sec ("Контекстни превключвания/сек") за обекта System ("Система").
  • Изключете опортюнистичната блокировка на клиентския компютър или на сървъра. За да направите това на клиентския компютър, задайте стойност 1 на следния параметър на системния регистър:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MRXSmb\Parameters\OplocksDisabled
    За да изключите опортюнистичната блокировка на сървъра, задайте стойност 0 на следния параметър на системния регистър:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\EnableOplocks
    За повече информация относно изключването на опортюнистичната блокировка щракнете върху следния номер на статия в базата знания на Microsoft:
    296264 Конфигуриране на опортюнистичната блокировка в Windows
  • Редактирайте системния регистър, за да деактивирате временно филтърния драйвер.

    За повече информация относно временното деактивиране на филтърния драйвер за режим на ядрото щракнете върху следния номер на статия в базата знания на Microsoft:
    816071 Как се деактивира временно филтърният драйвер за режим на ядрото в Windows
    Ключът от системния регистър, който съхранява информация за драйвера Ofant.sys, е следният:
    Ofadriver

Библиография

За повече информация щракнете върху следния номер на статия в базата знания на Microsoft:
814112 Файловете, разположени на мрежови дялове, се отварят бавно, отварят се в режим само за четене или се появява съобщение за грешка.
821246 Файлове на Office се отварят, затварят, записват и отпечатват бавно, когато са разположени на мрежов сървър.
816071 Как се деактивира временно филтърният драйвер за режим на ядрото в Windows
252332 При копиране на файлове върху сървър, подложен на дисково натоварване, възниква събитие с код (Event ID) 3013.
Продуктите на други производители, които се обсъждат в тази статия, са произведени от фирми, независими от Microsoft. Microsoft не дава никакви гаранции, подразбиращи се или от друго естество, за работните характеристики или надеждността на тези продукти.
Забележка Това е статия "БЪРЗА ПУБЛИКАЦИЯ", създадена директно в рамките на организацията за поддръжка на Microsoft. Информацията, съдържаща се тук, се ограничава до съдържащото се в нея и е дадена в отговор на появили се проблеми. В резултат на краткия срок до тяхното предлагане, материалите може да съдържат печатни грешки и могат да бъдат преработвани във всеки момент без предизвестие. Вижте Условия на ползване за други съображения.

Свойства

ID на статията: 822219 - Последна рецензия: 27 юни 2014 г. - Редакция: 1.0
Важи за:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Ключови думи: 
kbresolve kbwinservperf kbprb KB822219

Изпратете обратна информация

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com