Das System reagiert nicht mehr, die Dateiserverleistung wird langsam, oder es kommt zu Verzögerungen, wenn Sie mit Dateien arbeiten, die sich auf einem Dateiserver befinden.

Dieser Artikel bietet eine Lösung für Leistungsprobleme, die auftreten, wenn Sie mit Dateien arbeiten, die sich auf einem Dateiserver befinden.

Gilt für: Windows 10 (alle Editionen), Windows Server 2012 R2
Ursprüngliche KB-Nummer: 822219

Symptome

Wenn Sie mit Dateien über das Netzwerk arbeiten, kann eines oder mehrere der folgenden Symptome auftreten:

  • Ein Windows-basierter Dateiserver, der als Datei- und Druckserver konfiguriert ist, reagiert nicht mehr, und die Datei- und Druckserverfunktionen werden vorübergehend beendet.

  • Beim Öffnen, Speichern, Schließen, Löschen oder Drucken von Dateien, die sich auf einer freigegebenen Ressource befinden, tritt eine unerwartet lange Verzögerung auf.

  • Wenn Sie ein Programm über das Netzwerk verwenden, tritt eine vorübergehende Leistungsminderung auf. Die Leistung verlangsamt sich in der Regel für etwa 40 bis 45 Sekunden. Einige Verzögerungen können jedoch bis zu 5 Minuten dauern.

  • Beim Ausführen von Dateikopier- oder Sicherungsvorgängen tritt eine Verzögerung auf.

  • Windows Explorer reagiert nicht mehr, wenn Sie eine Verbindung mit einer freigegebenen Ressource herstellen oder ein rotes X auf dem verbundenen Netzlaufwerk in Windows Explorer angezeigt wird.

  • Wenn Sie sich beim Dateiserver anmelden, wird ein leerer Bildschirm angezeigt, nachdem Sie Ihren Namen und Ihr Kennwort im Dialogfeld Bei Windows anmelden eingegeben haben. Der Desktop wird nicht angezeigt.

  • Ein Programm, das remote procedure call (RPC) oder Named Pipes verwendet, um eine Verbindung mit einem Dateiserver herzustellen, reagiert nicht mehr.

  • Der Server reagiert vorübergehend nicht mehr, und eine oder mehrere Ereignis-ID-Meldungen ähnlich den folgenden Meldungen werden im Systemprotokoll auf dem Dateiserver angezeigt.

  • Wenn Sie versuchen, eine Verbindung mit einer freigegebenen Ressource herzustellen, erhalten Sie eine Fehlermeldung, die einer der folgenden Meldungen ähnelt:

    • Fehlermeldung 1

      Systemfehler 53. Der Netzwerkpfad wurde nicht gefunden.

    • Fehlermeldung 2

      Systemfehler 64. Der angegebene Netzwerkname ist nicht mehr verfügbar.

  • Sie sind zeitweilig von Netzwerkressourcen getrennt, und Sie können keine erneute Verbindung mit den Netzwerkressourcen auf dem Dateiserver herstellen. Sie können jedoch den Server pingen, und Sie können eine Remotedesktopdienste-Sitzung verwenden, um eine Verbindung mit dem Server herzustellen.

  • Wenn mehrere Benutzer versuchen, auf Microsoft Office-Dokumente auf dem Server zuzugreifen, wird das Dialogfeld Datei zur Bearbeitung gesperrt nicht immer angezeigt, wenn der zweite Benutzer die Datei öffnet.

  • Eine Netzwerkablaufverfolgung gibt eine Verzögerung von 30 bis 40 Sekunden zwischen einem SMB-Dienstclientbefehl und einer Antwort vom Dateiserver an.

  • Wenn Sie versuchen, eine Access 2.0-Datenbankdatei (.mdb Datei) in Microsoft Access 97, Access 2000 oder Access 2002 zu öffnen, erhalten Sie möglicherweise eine Fehlermeldung, die der folgenden ähnelt:

    Datenträger- oder Netzwerkfehler.

  • Wenn Sie versuchen, eine Microsoft Word-Datei zu öffnen, wird möglicherweise die folgende Fehlermeldung angezeigt:

    Word fehler beim Lesen aus dieser Datei file_name. Stellen Sie die Netzwerkverbindung wieder her, oder ersetzen Sie die Diskette, und versuchen Sie es erneut.

Ursache

Dieses Problem kann auftreten, wenn ein nicht von Microsoft stammendes Programm, das auf Ihrem Computer installiert ist, einen veralteten Kernelmodusfiltertreiber verwendet. Der Kernelmodus-Filtertreiber ist möglicherweise veraltet, wenn die folgenden Bedingungen zutreffen:

  • Eines der folgenden Programme ist auf dem Computer installiert:

    • ARCserve Backup Agent for Open Files oder ARCserve Open File Agent von Computer Associates International, Inc. ist auf Ihrem Computer installiert, und der Ofant.sys Treiber für das Programm ist veraltet.

    • Open Transaction Manager ist auf Ihrem Computer installiert, und der Otman.sys Treiber für das Programm ist veraltet.

      Hinweis

      Open Transaction Manager ist in bestimmten Programmen von VERITAS Software Corporation enthalten, kann aber auch separat vom VERITAS-Programm installiert werden. Beispielsweise kann "Transaktions-Manager öffnen" in der Option "Datei öffnen" enthalten sein. Dieses Programm kann in VERITAS Backup Exec enthalten sein.

    • Auf Ihrem Computer ist ein VERITAS-Programm installiert, das den Otman4.sys- oder Otman5.sys-Treiber verwendet (z. B. Open File Option), und der Otman4.sys- oder Otman5.sys Treiber für das Programm ist veraltet.

  • Der Treiber für das Programm ist nicht mit dem Filtertreiber kompatibel, der von einem nicht von Microsoft stammenden Antivirenprogramm auf dem Computer installiert wird. Daher gibt der Filtertreiber auf dem Server möglicherweise einen falschen status Code an den Serverdienst zurück. Beispielsweise kann der Filtertreiber anstelle eines STATUS_OPLOCK_BREAK_IN_PROGRESS Codes einen STATUS_SUCCESS Code zurückgeben.

Lösung

Um dieses Problem zu beheben, wenden Sie sich an den Hersteller des Programms, um sich nach der Verfügbarkeit eines Filtertreiberupdates zu erkundigen. Weitere Informationen dazu, wie Sie Computer Associates kontaktieren, um das neueste Update für den Ofant.sys Treiber zu erhalten, finden Sie unter Computer Associates.

Wenn Sie Open Transaction Manager separat installiert haben, wenden Sie sich an Columbia Data Products, Inc., um sich über die Verfügbarkeit eines Updates zu informieren, das dieses Problem beheben kann. Um Columbia Data Products zu kontaktieren, besuchen Sie Columbia Data Products.

Weitere Informationen zur Kontaktaufnahme mit VERITAS finden Sie unter VERITAS-Support.

Weitere Informationen

Wichtig

Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Für zusätzlichen Schutz sichern Sie die Registrierung, bevor Sie sie ändern. Sie können die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie unter Sichern und Wiederherstellen der Registrierung in Windows.

Um dieses Problem vorübergehend zu umgehen, starten Sie die Serverdienste auf dem Server neu. Führen Sie die folgenden Schritte aus, um die Serverdienste neu zu starten:

  1. Klicken Sie auf Start und anschließend auf Ausführen.

  2. Geben Sie im Feld Öffnen die Zeichenfolge cmd ein, und klicken Sie dann auf OK.

  3. Geben Sie an der Eingabeaufforderung die folgenden Zeilen ein, und drücken Sie nach jeder Zeile die EINGABETASTE:

    net stop server
    net start server
    

Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben:

  • Verwenden Sie Leistungsprotokolle und Warnungen, um den Durchschn. Warteschlangenlängenzähler des PhysicalDisk-Leistungsobjekts zu überwachen. Unter normalen Bedingungen ist die Anzahl der wartenden Eingabe-/Ausgabeanforderungen (E/A) in der Regel nicht mehr als das 1,5- bis 2-fache der Anzahl der Spindeln, über die der physische Datenträger verfügt. Die meisten Datenträger verfügen über eine Spindel, obwohl RAID-Geräte (Redundant Array of Independent Disks) in der Regel mehr als eine Spindel haben. Wenn ein Programm kleine aufeinanderfolgende E/A-Vorgänge ausführt, wird eine Spitze im Leistungsindikator Current Disk Queue Length (Aktuelle Datenträgerwarteschlangenlänge ) angezeigt, wenn E/A-gebundene Vorgänge in die Warteschlange eingereiht werden. Möglicherweise wird auch eine Erhöhung des Zählers Kontextwechsel/Sekunde des Systemleistungsobjekts angezeigt.

  • Deaktivieren Sie opportunistische Sperren entweder auf dem Client oder auf dem Server. Um opportunistische Sperren auf dem Client zu deaktivieren, legen Sie den folgenden Registrierungswert auf 1 fest:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MRXSmb\Parameters\OplocksDisabled

    Um opportunistische Sperren auf dem Server zu deaktivieren, legen Sie den folgenden Registrierungswert auf 0 fest:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\EnableOplocks

    Weitere Informationen zum Deaktivieren der opportunistischen Sperre finden Sie unter Konfigurieren opportunistischer Sperren in Windows.

  • Bearbeiten Sie die Registrierung, um den Filtertreiber vorübergehend zu deaktivieren.

    Weitere Informationen zum vorübergehenden Deaktivieren des Kernelmodusfiltertreibers finden Sie unter Vorübergehendes Deaktivieren des Kernelmodusfiltertreibers in Windows.

    Der Registrierungsschlüssel, der Informationen für den Ofant.sys Treiber speichert, ist Ofadriver.

References

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