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Artikel-ID: 822219 - Geändert am: Mittwoch, 9. Mai 2007 - Version: 7.2

Geringe Dateiserverleistung und Verzögerungen beim Arbeiten mit Dateien auf einem Dateiserver

Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
822219  (http://support.microsoft.com/kb/822219/EN-US/ ) You experience slow file server performance and delays occur when you work with files that are located on a file server
Wichtig: Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Sie sollten eine Sicherungskopie der Registrierung erstellen, bevor Sie die Registrierung bearbeiten. Sie müssen wissen, wie die Registrierung wiederhergestellt werden kann, wenn ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/DE/ ) Beschreibung der Microsoft Windows-Registrierung
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
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Problembeschreibung

Beim Arbeiten mit Dateien im Netzwerk kann möglicherweise eines oder mehrere der folgenden Symptome auftreten:
  • Ein Windows-Dateiserver, der als Datei- und Druckserver konfiguriert wurde, reagiert nicht mehr, und die Datei- und Druckserverfunktionalität wird vorübergehend beendet.
  • Es treten ungewöhnlich lange Verzögerungen beim Öffnen, Speichern, Schließen, Löschen oder Drucken von Dateien auf, die sich auf einer freigegebenen Ressource befinden.
  • Die Leistung ist vorübergehend vermindert, wenn Sie ein Programm über das Netzwerk verwenden. Die Leistung wird normalerweise für ungefähr 40 bis 45 Sekunden verringert. Einige Verzögerungen dauern jedoch bis zu 5 Minuten an.
  • Es tritt eine Verzögerung bei Kopier- oder Sicherungsvorgängen auf.
  • Windows Explorer reagiert nicht mehr, wenn Sie eine Verbindung zu einer freigegebenen Ressource herstellen, oder das verbundene Netzlaufwerk ist in Windows Explorer mit einem roten X gekennzeichnet.
  • Wenn Sie sich bei dem Dateiserver anmelden, erscheint ein leerer Bildschirm nachdem Sie Ihren Namen und Ihr Kennwort in das Dialogfeld Windows-Anmeldung eingegeben haben. Der Desktop wird nicht angezeigt.
  • Ein Programm, das Remoteprozeduraufrufe (RPC) oder Named Pipes verwendet, um eine Verbindung zu einem Dateiserver herzustellen, reagiert nicht mehr.
  • Der Server reagiert vorübergehend nicht mehr, und es werden sinngemäß eine oder mehrere der folgenden Ereignismeldungen im Systemprotokoll des Dateiservers angezeigt:

    Ereigniskennung: 2022
    Quelle: Srv
    Typ: Fehler
    Beschreibung:
    Der Server konnte in den letzten <Anzahl> Sekunden <Anzahl> Mal keine freie Verbindung finden.

    Ereigniskennung: 2021
    Quelle: Srv
    Typ: Fehler
    Beschreibung:
    Der Server konnte in den letzten <Anzahl> Sekunden <Anzahl> Mal kein Arbeitsobjekt erstellen.

    Ereigniskennung: 2020
    Quelle: Srv
    Typ: Fehler
    Beschreibung:
    Der Server konnte keinen ausgelagerten Poolspeicher reservieren, da der Pool leer war.

    Ereigniskennung: 2019
    Quelle: Srv
    Typ: Fehler
    Beschreibung:
    Der Server konnte keinen nicht ausgelagerten Poolspeicher reservieren, da der Pool leer war.

    Ereigniskennung: 2510
    Quelle: Server
    Typ: Fehler
    Beschreibung:
    Der Serverdienst konnte Fehlercode 1722 nicht zuordnen.
    1722 = RPC_S_SERVER_UNAVAILABLE = RPC-Dienst ist nicht verfügbar.

    Zusätzlich wird das folgende Ereignis im Systemprotokoll des Clientcomputers angezeigt:

    Ereigniskennung: 3013
    Typ: Fehler
    Quelle: MrxSmb / Rdr
    Beschreibung:
    Der Redirectordienst hat eine Anforderung an Computername wegen Zeitüberschreitung aufgegeben.

  • Wenn Sie versuchen, eine Verbindung zu einer freigegebenen Ressource herzustellen, wird eine Fehlermeldung angezeigt, die einer der folgenden Fehlermeldungen ähnelt:Fehlermeldung 1
    Systemfehler 53. Der Netzwerkpfad wurde nicht gefunden.
    Fehlermeldung 2
    Systemfehler 64. Der angegebene Netzwerkname ist nicht mehr verfügbar.
  • Die Verbindung zu der Netzwerkressource wird zeitweise unterbrochen, und Sie können keine Verbindung mehr zu der Netzwerkressource auf dem Dateiserver herstellen. Sie können den Server jedoch mithilfe des Ping-Befehls abfragen, und Sie können mithilfe einer Terminaldienstesitzung eine Verbindung zu dem Server herstellen.
  • Wenn mehrere Benutzer versuchen, auf Microsoft Office-Dokumente auf dem Server zuzugreifen, wird das Dialogfeld Datei ist zur Bearbeitung gesperrt nicht immer angezeigt, wenn der zweite Benutzer die Datei öffnet.
  • Die Netzwerkablaufverfolgung zeigt eine Verzögerung von 30 bis 40 Sekunden zwischen einem SMB-Dienst-Clientbefehl und einer Antwort von dem Dateiserver an.
  • Wenn Sie versuchen, in Microsoft Access 97, Microsoft Access 2000 oder in Microsoft Access 2002 eine Access 2.0-Datenbankdatei (.mdb-Datei) zu öffnen, wird eventuell eine Fehlermeldung wie die folgende angezeigt:
    Datenträger- oder Netzwerkfehler.
  • Bei dem Versuch, eine Microsoft Word-Datei zu öffnen, wird Ihnen möglicherweise die folgende Fehlermeldung angezeigt:
    Word konnte diese Datei Dateiname nicht lesen. Bitte stellen Sie die Netzwerkverbindung wieder her, oder ersetzen Sie die Diskette und versuchen Sie es erneut.
Zusätzlich kann das folgende Ereignis im Systemprotokoll des Clientcomputers protokolliert werden:

Typ: Warnung
Quelle: MrxSmb
Ereignis-ID: 50
Beschreibung: {Datenverlust bei verzögertem Schreiben} Das System hat versucht, Dateidaten vom Puffer in die Datei "\Device\LanmanRedirector" zu schreiben. Der Schreibvorgang ist fehlgeschlagen. Eventuell wurden nicht alle Daten in die Datei geschrieben.

Ursache

Dieses Problem kann auftreten, wenn ein Programm eines Fremdanbieters, das auf Ihrem Computer installiert ist, einen veralteten Kernelmodus-Filtertreiber verwendet. Möglicherweise ist der Kernelmodus-Filtertreiber veraltet, wenn die folgenden Bedingungen erfüllt sind:
  • Eines der folgenden Programme ist auf dem Computer installiert:
    • "ARCserve Backup Agent for Open Files" oder "ARCserve Open File Agent" von Computer Associates International, Inc. ist auf dem Computer installiert, und der Treiber "Ofant.sys" für das Programm ist veraltet.
    • "Open Transaction Manager" ist auf dem Computer installiert, und der Treiber "Otman.sys" für das Programm ist veraltet.

      Hinweis: "Open Transaction Manager" ist in bestimmten Programmen von VERITAS Software Corporation enthalten, kann aber auch getrennt von einem VERITAS-Programm installiert sein. "Open Transaction Manager" kann beispielsweise in "Open File Option" enthalten sein. Dieses Programm kann in "VERITAS Backup Exec" enthalten sein.
    • Ein VERITAS-Programm, das den Treiber "Otman4.sys" oder "Otman5.sys" verwendet (beispielsweise "Open File Option"), ist auf dem Computer installiert, und der Treiber "Otman4.sys" oder "Otman5.sys" für das Programm ist veraltet.
  • Der Treiber für das Programm ist nicht mit dem Filtertreiber kompatibel, der von einem Antivirenprogramm eines Fremdanbieterprogramms auf dem Computer installiert wurde. Infolgedessen gibt der Filtertreiber auf dem Server möglicherweise einen falschen Statuscode an den Serverdienst zurück. Der Filtertreiber gibt unter Umständen einen STATUS_SUCCESS-Code statt des Codes STATUS_OPLOCK_BREAK_IN_PROGRESS zurück.

Lösung

Wenden Sie sich an den Hersteller des Programms und erkundigen Sie sich nach einem Treiberupdate, um dieses Problem zu beheben. Weitere Informationen dazu, wie Sie sich an Computer Associates wenden können, um das neueste Update für den Treiber "Ofant.sys" zu erhalten, finden Sie auf folgender Website von Computer Associates:
http://www.ca.com/support/ (http://www.ca.com/support/)
Wenn Sie "Open Transaction Manager" separat installiert haben, wenden Sie sich an Columbia Data Products, Inc., und erkundigen Sie sich nach der Verfügbarkeit eines Updates, durch das dieses Problem behoben werden kann. Besuchen Sie die folgende Website von Columbia Data Products, um mit Columbia Data Products Kontakt aufzunehmen:
http://www.cdp.com/ (http://www.cdp.com/)
Weitere Informationen darüber, wie Sie mit VERITAS Kontakt aufnehmen, finden Sie auf folgender Website von VERITAS:
http://veritas.com/de/DE/services/support/ (http://veritas.com/de/DE/services/support/)
Die Kontaktinformationen bezüglich der in diesem Artikel erwähnten Fremdanbieter sollen Ihnen helfen, den benötigten technischen Support zu finden. Diese Kontaktinformationen können ohne vorherige Ankündigung geändert werden. Sie werden von Microsoft ohne jede Gewähr weitergegeben.

Weitere Informationen

Warnung: Durch die falsche Bearbeitung der Registrierung mithilfe des Registrierungs-Editors oder einer anderen Methode können schwerwiegende Probleme verursacht werden. Diese Probleme können eine Neuinstallation des Betriebssystems erforderlich machen. Microsoft kann nicht dafür garantieren, dass Probleme, die von einer falschen Verwendung des Registrierung-Editors herrühren, behoben werden können. Änderungen in der Registrierung geschehen auf eigene Verantwortung.

Starten Sie die Serverdienste auf dem Server neu, um dieses Problem vorübergehend zu umgehen. Gehen Sie folgendermaßen vor, um die Serverdienste neu zu starten:
  1. Klicken Sie auf Start und anschließend auf Ausführen.
  2. Geben Sie in das Feld Öffnen die Zeichenfolge cmd ein, und klicken Sie anschließend auf OK.
  3. Geben Sie in die Eingabeaufforderung die folgenden Zeilen ein, und drücken Sie nach jeder Zeile die [EINGABETASTE]:
    net stop server
    net start server
Wenden Sie eine der folgenden Methoden an, um dieses Problem zu beheben:
  • Verwenden Sie Leistungsprotokolle und Warnungen, um den Leistungsindikator Durchschnittl. Warteschlangenlänge des Datenträgers des Leistungsobjekts Physikalischer Datenträger zu überwachen. Unter normalen Bedingungen beträgt die Anzahl wartender Eingabe/Ausgabe(E/A)-Anforderungen nicht mehr als das 1,5- bis 2-fache der Anzahl der Spindels, über die der physikalische Datenträger verfügt. Die meisten Festplatten verfügen nur über einen Spindel, obwohl RAID-Geräte (RAID = Redundant Array of Independent Disks) normalerweise über mehr als einen Spindel verfügen. Wenn ein Programm kleine aufeinander folgende E/A-Operationen ausführt, wird im Leistungsindikator Aktuelle Warteschlangenlänge eine Auslastung angezeigt, wenn sich E/A-Operationen in der Warteschlange befinden. Möglicherweise stellen Sie auch einen Anstieg im Leistungsindikator Kontextwechsel/s des Leistungsobjekts System fest.
  • Deaktivieren Sie die Funktion für opportunistisches Sperren (Opportunistic Locking) entweder auf dem Client oder auf dem Server. Legen Sie den folgenden Registrierungswert auf 1 fest, um die Funktion für opportunistisches Sperren auf dem Client zu deaktivieren:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MRXSmb\Parameters\OplocksDisabled
    Setzen Sie den folgenden Registrierungswert auf 0, um die Funktion für opportunistisches Sperren auf dem Server zu deaktivieren:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\EnableOplocks
    Weitere Informationen zum Deaktivieren des opportunistischen Sperrens finden Sie im folgenden Artikel der Microsoft Knowledge Base:
    296264  (http://support.microsoft.com/kb/296264/DE/ ) Konfigurieren von opportunistischem Sperren in Windows
  • Verwenden Sie das Microsoft-Dienstprogramm zur Konfigurationserfassung (MPS_REPORTS), um die Version des auf Ihrem Computer installierten Filtertreibers zu ermitteln.

    Weitere Informationen über das Microsoft-Dienstprogramm zur Konfigurationserfassung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
    818742  (http://support.microsoft.com/kb/818742/DE/ ) Überblick über das Microsoft-Dienstprogramm zur Konfigurationserfassung (MPS_REPORTS)
  • Bearbeiten Sie die Registrierung, um den Filtertreiber vorübergehend zu deaktivieren.

    Weitere Informationen darüber, wie Sie den Kernelmodus-Filtertreiber vorübergehend deaktivieren, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
    816071  (http://support.microsoft.com/kb/816071/DE/ ) Wie deaktivieren Sie den Kernel-Filtertreiber in Windows für Modus vorübergehend
    In folgendem Registrierungsschlüssel sind Informationen für den Treiber "Ofant.sys" gespeichert: Ofadriver.

Informationsquellen

Weitere Informationen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
814112  (http://support.microsoft.com/kb/814112/DE/ ) Dateien auf Netzwerkfreigaben werden langsam oder schreibgeschützt geöffnet, oder eine Fehlermeldung wird angezeigt
821246  (http://support.microsoft.com/kb/821246/DE/ ) Office-Dateien werden von einem Netzwerk-Server aus nur langsam geöffnet, geschlossen, gespeichert oder gedruckt
816071  (http://support.microsoft.com/kb/816071/DE/ ) Wie deaktivieren Sie den Kernel-Filtertreiber in Windows für Modus vorübergehend
252332  (http://support.microsoft.com/kb/252332/DE/ ) Ereignis-ID 3013 beim Kopieren von Dateien auf einen stark beanspruchten Server
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Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
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