При работе с файлами, расположенными на файловом сервере, система прекращает отвечать на запросы, снижается производительность файлового сервера или возникают задержки

Переводы статьи Переводы статьи
Код статьи: 822219 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

Проблема

При работе с файлами, расположенными на файловом сервере, возможно возникновение следующих проблем.
  • Компьютер под управлением Windows, являющийся файловым сервером или сервером печати, перестает отвечать на запросы.
  • При открытии, закрытии, сохранении, удалении или печати файлов, расположенных на общих ресурсах, возникают большие задержки.
  • При использовании программ, передающих данные по сети, наблюдается временное снижение производительности. Как правило, производительность снижается на 40–45 секунд, хотя в некоторых случаях задержка может составлять до 5 минут.
  • При копировании или архивировании файлов возникают задержки.
  • При подключении к общим ресурсам зависает проводник Windows или на подключенных сетевых дисках отображается красный значок «X».
  • На файловом сервере при входе в систему после ввода имени пользователя и пароля не появляется изображение рабочего стола, а отображается пустой экран.
  • Программа, использующая для подключения к серверу именованные каналы или удаленный вызов процедур (RPC), перестает отвечать на запросы.
  • Сервер временно прекращает отвечать на запросы, а в журнале системных событий сервера регистрируются одно или несколько событий следующего вида.

    Код события: 2022
    Источник: Srv
    Тип: Ошибка
    Описание:
    Сервер не смог найти свободное подключение <количество_попыток> раз(а) за последние <время> с.

    Код события: 2021
    Источник: Srv
    Тип: Ошибка
    Описание:
    Сервер не смог создать рабочий объект <количество_попыток> раз(а) за последние <время> с.

    Код события: 2020
    Источник: Srv
    Тип: Ошибка
    Описание:
    Сервер не смог выделить память из выгружаемого пула памяти, так как выгружаемый пул пуст.

    Код события: 2019
    Источник: Srv
    Тип: Ошибка
    Описание:
    Сервер не смог выделить память из невыгружаемого пула памяти, так как невыгружаемый пул пуст.

    Код события: 2510
    Источник: имя_сервера
    Тип события: Ошибка
    Описание:
    Служба сервера не смогла установить соответствие для кода ошибки 1722.
    1722 = RPC_S_SERVER_UNAVAILABLE = RPC Service недоступен.

    Кроме того, в журнале системных событий клиентского компьютера регистрируется следующее событие.

    Код события: 3013
    Тип события: Ошибка
    Источник события: MrxSmb / Rdr
    Описание:
    Перенаправитель отключил запрос к имя_компьютера.

  • При подключении к общему ресурсу появляется сообщение об ошибке следующего вида: Сообщение об ошибке 1
    Системная ошибка 53. Не найден сетевой путь.
    Сообщение об ошибке 2
    Системная ошибка 64. Указанное сетевое имя более недоступно.
  • Компьютер периодически отключается от сетевых ресурсов на файловом сервере и не может повторно подключиться к ним. Однако файловый сервер доступен по команде ping, и к нему можно подключиться с помощью сеанса служб терминалов.
  • Если несколько пользователей обращаются к документам Microsoft Office, находящимся на сервере, не всегда появляется окно с сообщением о том, что файл заблокирован для изменения другим пользователем.
  • Между отправкой команды клиентом SMB и ответом сервера проходит 30—40 секунд.
  • При попытке открыть файл базы данных Access 2.0 (MDB-файл) в Microsoft Access 97, Microsoft Access 2000 или Microsoft Access 2002 пользователь может получить сообщение об ошибке следующего вида:
    Дисковая или сетевая ошибка.
  • При попытке открыть документ Microsoft Word появляется следующее сообщение об ошибке:
    Произошел сбой при чтении из этого файла имя_файла. Восстановите подключение к сети или замените дискету и повторите попытку.
Кроме того, в журнале системных событий клиентского компьютера регистрируется следующее событие:

Тип: Предупреждение.
Источник: MrxSmb
Код события: 50
Описание: {Lost Delayed-Write Data} Система пыталась передать данные файла из буферов в \Device\LanmanRedirector. Во время записи произошел сбой и в файл могла быть записана только часть данных.

Причина

Данная проблема может возникать, если на компьютере установлена программа независимого разработчика, использующая устаревший драйвер фильтра уровня ядра. Это может происходить в следующих случаях.
  • На компьютере установлена одна из следующих программ.
    • Программы ARCserve Backup Agent for Open Files или ARCserve Open File Agent фирмы Computer Associates International, Inc., использующие устаревший драйвер Ofant.sys.
    • Программа Open Transaction Manager, использующая устаревший драйвер Otman.sys.

      Примечание. Программа Open Transaction Manager может поставляться вместе с некоторыми программами корпорации VERITAS Software Corporation или же отдельно от программ VERITAS. Например, программа Open Transaction Manager может поставляться вместе с программой Open File Option в составе программы VERITAS Backup Exec.
    • Программа VERITAS, использующая устаревшие драйверы Otman4.sys или Otman5.sys (например, программа Open File Option).
  • Драйвер, используемый программой, несовместим с драйвером фильтра, установленным на компьютере антивирусной программой независимого разработчика. В результате драйвер фильтра на сервере может возвращать службе «Сервер» ошибочный код состояния. Например, драйвер фильтра может возвращать значение STATUS_SUCCESS вместо STATUS_OPLOCK_BREAK_IN_PROGRESS.

Решение

Чтобы устранить данную проблему, обратитесь к разработчику программы за обновлением драйвера фильтра. Чтобы получить сведения о том, как связаться с компанией Computer Associates и получить последнюю версию драйвера Ofant.sys, перейдите на веб-сайт Computer Associates:
http://www.ca.com/support/
Если программа Open Transaction Manager устанавливалась отдельно, обратитесь в компанию Columbia Data Products, Inc., чтобы отправить запрос о доступности обновлений, устраняющих описанную проблему. Для этого обратитесь на веб-узел Columbia Data Products по адресу:
http://www.cdp.com/
Для получения контактной информации корпорации VERITAS обратитесь на веб-узел VERITAS по адресу:
http://support.veritas.com/
Контактные данные независимых производителей предоставлены в данной статье с целью помочь пользователям в получении необходимой технической поддержки. Эти данные могут быть изменены без предварительного уведомления. Корпорация Майкрософт не гарантирует точность контактных данных независимых производителей.

Дополнительная информация

Важно! В данный раздел, описание метода или задачи включены сведения об изменении параметров реестра. Однако их неправильное изменение может привести к возникновению серьезных проблем, поэтому при выполнении этих действий строго соблюдайте инструкции. Чтобы обеспечить дополнительную защиту, создайте резервную копию реестра. В этом случае при возникновении неполадок реестр можно будет восстановить. Дополнительные сведения о создании резервной копии и восстановлении реестра см. в следующей статье базы знаний Майкрософт:
322756 Создание резервной копии и восстановление реестра Windows


Для временного решения проблемы остановите и повторно запустите службу «Сервер». Чтобы перезапустить службу «Сервер», выполните следующие действия.
  1. Нажмите кнопку Пуск и выберите пункт Выполнить.
  2. В поле Открыть введите команду cmd и нажмите кнопку ОK.
  3. В командной строке введите следующие команды, нажимая клавишу ВВОД после каждой команды:
    net stop server
    net start server
Для решения проблемы используйте любой из следующих способов:
  • С помощью средства «Журналы и оповещения производительности» проследите изменение значений счетчика Средняя длина очереди диска для объекта Физический диск. В обычных условиях число запросов ввода-вывода, ожидающих обработки, не превышает более чем в 1,5–2 раза число физических дисков в дисковом устройстве. Большинство дисковых устройств содержат один физический диск, а дисковые массивы RAID — обычно более одного диска. При успешном выполнении программой небольших операций ввода-вывода на графике Текущая длина очереди диска наблюдается пик, свидетельствующий о постановке операций ввода-вывода в очередь. Кроме того, увеличивается значение счетчика Контекстных переключений/сек объекта Система.
  • Отключите оппортунистическую блокировку на клиентском компьютере или на сервере. Для отключения оппортунистической блокировки на клиентском компьютере присвойте следующему параметру реестра значение 1:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MRXSmb\Parameters\OplocksDisabled
    Для отключения оппортунистической блокировки на сервере присвойте следующему параметру реестра значение 0:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\EnableOplocks
    Дополнительные сведения об отключении оппортунистической блокировки см. в следующей статье базы знаний Майкрософт:
    296264 Настройка уступающей блокировки в Windows
  • Внесите изменения в реестр для временного отключения драйвера фильтра.

    Дополнительные сведения о временном отключении драйвера фильтра, работающего в режиме ядра, см. в следующей статье базы знаний Майкрософт:
    816071 Временное отключение драйвера фильтра, работающего в режиме ядра, в Windows (эта ссылка может указывать на содержимое полностью или частично на английском языке)
    Информация драйвера Ofant.sys хранится в этом разделе реестра:
    Ofadriver

Ссылки

Дополнительные сведения см. в следующих статьях базы знаний Майкрософт:
814112 Файлы в общих сетевых папках открываются медленно или только для чтения, либо появляется сообщение об ошибке
821246 Большая задержка при открытии, закрытии, сохранении и печати документов Microsoft Office, находящихся на сервере в сети
816071 Временное отключение драйвера фильтра, работающего в режиме ядра, в Windows
252332 При копировании файлов на сервер в моменты значительной нагрузки на дисковую подсистему сервера регистрируется код события 3013
В этой статье упомянуты программные продукты сторонних производителей. Корпорация Майкрософт не дает никаких гарантий и обязательств относительно корректной работы или надежности этих продуктов.
Примечание. Это ЭКСПРЕСС-ПУБЛИКАЦИЯ, подготовленная непосредственно службой технической поддержки Майкрософт . Сведения, содержащиеся в данном документе, предоставлены в качестве отклика на возникшие проблемы. Из-за срочности в материалах могут быть опечатки, и в любое время и без уведомления в них могут быть внесены изменения. Чтобы получить дополнительные сведения, см. Условия использования.

Свойства

Код статьи: 822219 - Последний отзыв: 31 января 2014 г. - Revision: 1.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
  • операционная система Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Ключевые слова: 
kbresolve kbwinservperf kbprb KB822219

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com