Domain Controller Takes a Long Time to Respond to a Logon Request, or It Does Not Respond at All

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Article ID: 822402 - View products that this article applies to.
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SYMPTOMS

When you try to log on to your domain, the domain controller may take a long time to respond to the logon request, or it may not respond at all.

If you view the tracing information on your domain controller, you see that the server does not respond to the C Session Setup and the X SMB commands.

CAUSE

This problem may occur if the NetBIOS name and the DNS name of the domain controller server are different. If the names are different, a request is sent by the browser service to what is recognized as a different server. However, because the name will resolve back to the server that made the browser service request, the browser service is put in a locked state while it tries to resolve this name. While it is in this locked state, the browser service holds a lock that must be returned to the server service before a connection can be made, and therefore the server service stops responding.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Hotfix Replacement Information

This hotfix does not replace any other hotfix.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time    Version        Size     File name
 --------------------------------------------------------
06-Jun-2003  16:54   5.0.2195.6753  69,392   Browser.dll 
06-Jun-2003  16:54   5.0.2195.6601  311,568  Netapi32.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New Naming Schema for Microsoft Windows Hotfix Packages

Properties

Article ID: 822402 - Last Review: October 26, 2006 - Revision: 2.5
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB822402

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