Vous temps de démarrage longue expérience lorsque vous démarrez WinPE au moyen d'un serveur de services d'installation à distance

Traductions disponibles Traductions disponibles
Numéro d'article: 822570 - Voir les produits auxquels s'applique cet article
important Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, veillez à sauvegarder et assurez-vous que vous savez comment restaurer le Registre si un problème se produit. Pour savoir comment sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
256986 Description de du Registre Microsoft Windows
Agrandir tout | Réduire tout

Symptômes

Plusieurs ordinateurs clients peuvent durer longtemps pour démarrer dans un environnement de préinstallation Microsoft Windows (WinPE). Ce temps de démarrage long peut se produire lorsque les clients démarrez à partir d'un serveur Windows 2000 ou à partir d'un serveur qui utilise Windows Server 2003 à distance Installation Services (RIS).

Ce problème se produit lorsque startnet.cmd exécute les commandes Factory.exe et Netcfg.exe sur chaque client. Bien que les processus de démarrage initial exécutent comme prévu, finalement tous les clients ralentir lorsqu'ils s'exécutent les paramètres dans le fichier startnet.cmd. Ce problème produit même lorsque les processus de démarrage client sont échelonnées.

Cause

Ce problème se produit lorsque plusieurs clients tentez d'accéder au fichier Setupapi.log sur le serveur Services d'installation à distance en même temps. Tous les clients qui démarrent en un WinPE utilisent des fichiers sur le serveur Services d'installation à distance. Lorsque plusieurs clients exécutez Factory.exe et Netcfg.exe du, il tente d'écrire des informations dans le même fichier de journal et parce que comporte Setupapi du fichier ouvert, autres clients doivent attendre pour enregistrer les informations avant de continuer.

Contournement

Avertissement : Si vous utilisez l'Éditeur du Registre de façon incorrecte, vous pouvez générer des graves problèmes pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantit que vous pouvez résoudre les problèmes résultant de l'utilisation incorrecte de l'Éditeur du Registre. Utilisez l'Éditeur du Registre à vos risques et périls. Pour contourner ce problème, procédez comme suit pour désactiver la journalisation Setupapi.
  1. Sur le serveur Services d'installation à distance, démarrez l'Éditeur du Registre. Pour ce faire, cliquez sur Démarrer , cliquez sur Exécuter , tapez regedit dans la zone Ouvrir et puis cliquez sur OK .
  2. Cliquez sur la clé de Registre
    HKEY_LOCAL_MACHINE
    .
  3. Dans le menu Fichier , cliquez sur Charger la ruche .
  4. Recherchez le dossier \i386\System32\Config dans l'image WinPE sur le serveur Services d'installation à distance :
  5. Cliquez sur le logiciel , puis cliquez sur Ouvrir .
  6. Donnez un nom temporaire à la ruche.
  7. Recherchez et double-cliquez sur la clé de Registre suivante :
    <Temporary_hive_name>\Microsoft\Windows\Currentversion\Setup
  8. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  9. Nommer la nouvelle valeur « LogLevel » et appuyez sur ENTRÉE.
  10. Double-cliquez sur l'entrée LogLevel , vérifiez que hexadécimal est sélectionnée et tapez 101 dans la zone données de la valeur .
  11. Cliquez sur OK .
  12. Vérifiez que l'entrée LogLevel possède maintenant une valeur de 0x00000101.
  13. Cliquez pour sélectionner Temporary_hive_name.
  14. Dans le menu Fichier , cliquez sur Décharger la ruche .
  15. Cliquez sur Oui , puis quittez l'Éditeur du Registre.
  16. Définir le fichier Setupapi.log en lecture seule. Pour ce faire, procédez comme suit :
    1. Recherchez l'image WinPE sur le serveur Services d'installation à distance.
    2. Ouvrez le dossier I386 dans l'image WinPE, cliquez avec le bouton droit sur Setupapi.log et puis cliquez sur Propriétés .

      note Ce fichier est absent jusqu'à ce que vous démarrez avec succès à partir de l'image WinPE pour la première fois.
    3. Cliquez sur l'onglet Général , puis cliquez sur pour sélectionner le en lecture seule case à cocher.
note Lorsque vous désactivez la journalisation Setupapi, vous pouvez rencontrer des performances lorsque vous démarrez à partir d'une image WinPE par le biais d'un serveur Services d'installation à distance. Gardez à l'esprit que d'autres facteurs finalement affectent les performances lorsque vous démarrez plusieurs clients. Par exemple, dans votre environnement, vous pourrez peut-être démarrer 12 à 15 clients en même temps et terminer tous les processus de démarrage en 2 et 3 minutes. Si vous augmentez le nombre de clients à 25 ou 30, vous pouvez remarquer baisse des performances en raison des autres contraintes de ressources tels que la bande passante réseau, débit du contrôleur de disque ou d'autres facteurs externes. Pour plus d'informations sur la façon d'activer la journalisation, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
243996 Comment faire pour activer enregistrement détaillé dans Paramètres d'interface utilisateur en mode Windows 2000

Propriétés

Numéro d'article: 822570 - Dernière mise à jour: mardi 30 janvier 2007 - Version: 2.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Mots-clés : 
kbmt kbwinservsetup KB822570 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 822570
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com