文書番号: 822800 - 最終更新日: 2005年1月25日 - リビジョン: 2.0

ハード ディスクを NTFS ファイル システムに変換後 Windows XP を再起動したときのエラー メッセージ "次のファイルが存在しないかまたは壊れているため、Windows を起動できませんでした: System32\Drivers\Ntfs.sys"

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。
すべて展開する | すべて折りたたむ

現象

ハード ディスクを FAT 32 ファイル システムから NTFS ファイル システムに変換するために、次のコマンドを使用できます。
convert drive: /fs:ntfs
このコマンドを使用した場合、コンピュータが変換を完了してから Windows XP を再起動すると、次のようなエラー メッセージが表示されることがあります。
次のファイルが存在しないかまたは壊れているため、Windows を
起動できませんでした:
System32\Drivers\Ntfs.sys

原因

Ntfs.sys ファイルが存在しないか、ハード ディスクの NTFS 変換時に破損した場合に、この問題が発生することがあります。

解決方法

この問題を解決するには、存在しないか破損している Ntfs.sys ファイルを置き換えます。
  1. Windows XP の起動ディスクまたは CD-ROM を使用してコンピュータを再起動します。
  2. [セットアップの開始] 画面が表示されたら、R キーを押して [インストール済みの Windows XP を回復コンソールを使って修復するには、R キーを押してください。] を選択します。使用するキーボードを選択し、Y キーを押します。
  3. 回復コンソールでログオンする Windows インストールの番号を入力し、Enter キーを押します。
  4. Administrator のパスワードの入力を要求されたら、パスワードを入力し、Enter キーを押します。Administrator のパスワードが空白の場合は、何も入力せずに Enter キーを押します。
  5. コマンド プロンプトで、次のコマンドを入力します (各コマンドの後で Enter キーを押します)。
    cd \windows\system32\drivers

    ren ntfs.sys ntfs.old
    : この手順で、破損している Ntfs.sys ファイルのファイル名は Ntfs.old に変更されます。Ntfs.sys ファイルが見つからない場合はファイルが存在していません。
  6. コマンド プロンプトで次のコマンドを入力し、Enter キーを押します。
    copy cd:\i386\ntfs.sys drive:\windows\system32\drivers
    cd は Windows XP の CD を挿入した CD-ROM ドライブのドライブ文字、drive は Windows XP をインストールしたドライブです。
  7. Windows XP の CD を CD-ROM ドライブから取り出し、コマンド プロンプトで exit と入力し、Enter キーを押して、回復コンソールを終了します。
  8. コンピュータを再起動します。

詳細

Convert.exe ユーティリティの使用方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
314097? (http://support.microsoft.com/kb/314097/ ) Convert.exe を使用してパーティションを NTFS ファイル システムに変換する方法
Windows 回復コンソールの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
314058? (http://support.microsoft.com/kb/314058/ ) Windows XP 回復コンソールについて

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 822800? (http://support.microsoft.com/kb/822800/EN-US/ ) (最終更新日 2004-06-16) を基に作成したものです。

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
キーワード:?
kbprb KB822800
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"