Message Flow to the Local Delivery Queue Is Very Slow

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Article ID: 822936 - View products that this article applies to.
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SYMPTOMS

E-mail messages back up in the Simple Mail Transfer Protocol (SMTP) queue that is bound for local delivery. Additionally, the server experiences high disk queue lengths on the Exchange Server 2003 computer installation drive. Typically, this installation drive is in the following location:
drive:\Program Files\Exchsrvr\

CAUSE

This issue may occur when the working folder that the information store uses for e-mail message conversion is located on a drive that is slow or busy.

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
To resolve this behavior, change the working folder that the information store uses for e-mail message conversion to point to a faster drive. To do so, follow these steps:
  1. Start Registry Editor.
  2. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
  3. In the right-side pane, double-click Working Directory:REG_SZ:Folder_Path.
  4. In the String Editor box, type the path of a folder on a faster drive, and then click OK.
  5. Close Registry Editor.

Properties

Article ID: 822936 - Last Review: October 25, 2007 - Revision: 1.4
APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
Keywords: 
kbbug KB822936

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