Cannot Read ISA Server Performance Data by Using an SNMP Program

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Article ID: 822970
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Symptoms

When you use a Simple Network Management Protocol (SNMP) program to read performance-related data from the Microsoft Internet Security and Acceleration (ISA) Server 2000 extension DLL files, you are unsuccessful. If you run the Snmputil.exe program to step through (walk) each ISA Server namespace, you receive a result that is similar to the following:
** bwcmib.dll **
MIB definition:
- OID: .15              .1
- NS: .bandwidthControl.bwcStatistics
SNMP Sample Response: SnmpExtensionInit() failed.
"snmputil walk" Response: End of MIB subtree.
The ISA Server SNMP components do not respond correctly. Either the namespace is not correctly resolved, or the DLL returns an "End of MIB" result.

Cause

This problem occurs because the following ISA Server 2000 SNMP management information bases (MIBs) do not load successfully:
Bwcmib.dll
Cachmib.dll
Hfmib.dll
Pfmib.dll
W3pmib.dll
Wspmib.dll

Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version       Size   File name
----------------------------------------------------
10-Jul-2003  19:09  3.0.1200.282  6,928  Cachmib.dll

Status

Microsoft has confirmed that this is a problem in Microsoft Internet Security and Acceleration Server 2000 SP1.

Properties

Article ID: 822970 - Last Review: October 26, 2013 - Revision: 2.0
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbisaserv2000presp2fix kbfix kbbug KB822970

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