A Scheduled Task Does Not Run When You Use Schtasks.exe to Create It and When the Path of the Scheduled Task Contains a Space

Article translations Article translations
Article ID: 823093 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

When you use the Scheduled Tasks Wizard to schedule a task, the task runs as you expect. However, if you use the Schtasks.exe command-line tool to create a schedule for the same task, the task does not run at the time when you scheduled it. Additionally, when you view the task in the Scheduled Tasks dialog box, the following text appears in the Status column:
Could not start

CAUSE

This problem occurs if the path of the scheduled task contains a space. For example, this problem occurs if you create a schedule for the following task by using Schtasks.exe:
"c:\foldername containing spaces\task.bat"
In this example, Schtasks.exe treats everything after the first space in the path as a command-line argument.

WORKAROUND

To work around this problem, enclose the path portion of the task (not including arguments or switches) between backslash (\) and quotation marks (") character combinations, for example \". Enclose the complete path of the task (including arguments or switches) between quotation marks as usual when you create a path or command that contains spaces.

For example, the following example task does not run when you schedule it:
schtasks /create /tn "my task" /tr "c:\foldername containing spaces\script.bat arguments" /sc once /sd 07/29/2003 /st 10:01
However, when you enclose the path of the task between the backslash and quotation marks character combinations as in the following example, the scheduled task runs successfully:
schtasks /create /tn "my task" /tr "\"c:\foldername name containing spaces\script.bat\" arguments" /sc once /sd 07/29/2003 /st 10:01

Properties

Article ID: 823093 - Last Review: October 30, 2006 - Revision: 5.2
APPLIES TO
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Keywords: 
kbprb kbnofix kbbug KB823093

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com