Windows 2000 Clients Do Not Correctly Display Logon Banners That Are Created in a Windows Server 2003 Policy

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Article ID: 823146 - View products that this article applies to.
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SYMPTOMS

When you log on to a computer that has an interactive logon policy defined, the logon banner message may not appear as the administrator intended it to appear.

CAUSE

This issue occurs if the text for the logon banner message (
LegalNoticeText
) was created in a Microsoft Windows Server 2003 Group Policy object (GPO) and is displayed on a Microsoft Windows 2000 client. The text for the logon banner message contains either a comma or multiple lines of text. In Windows 2000, this policy is created or edited as a single string, and it is limited to 512 characters. If the logon banner message text policy is created or edited in Microsoft Windows Server 2003, and the text contains either multiple lines of text or commas, Windows 2000 stores the text in the registry as multiple strings (REG_MULTI_SZ) instead of as a single string (REG_SZ). Commas in the original text are treated as carriage returns, and only the first line of text (up to the first comma) is displayed at logon.

Note The
LegalNoticeText
registry value corresponds to the Interactive Logon: Message text for users trying to log on security option. It is located in the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Policies\System
.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Windows 2000 Service Pack 4.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   28-Aug-2003  14:05  5.0.2195.6748    124,688  Adsldp.dll
   28-Aug-2003  14:05  5.0.2195.6748    132,368  Adsldpc.dll
   28-Aug-2003  14:05  5.0.2195.6748     63,760  Adsmsext.dll
   28-Aug-2003  14:05  5.0.2195.6800    381,712  Advapi32.dll
   28-Aug-2003  14:05  5.0.2195.6753     69,392  Browser.dll
   28-Aug-2003  14:05  5.0.2195.6680    134,928  Dnsapi.dll
   28-Aug-2003  14:05  5.0.2195.6780     96,528  Dnsrslvr.dll
   28-Aug-2003  14:05  5.0.2195.6810     47,376  Eventlog.dll
   28-Aug-2003  14:05  5.0.2195.6759    148,240  Kdcsvc.dll
   18-Jun-2003  06:43  5.0.2195.6758    205,072  Kerberos.dll
   26-Mar-2003  10:37  5.0.2195.6695     71,888  Ksecdd.sys
   01-Aug-2003  06:40  5.0.2195.6797    509,712  Lsasrv.dll
   01-Aug-2003  06:40  5.0.2195.6797     33,552  Lsass.exe
   17-Jul-2003  12:13  5.0.2195.6786    109,840  Msv1_0.dll
   28-Aug-2003  14:05  5.0.2195.6601    311,568  Netapi32.dll
   28-Aug-2003  14:05  5.0.2195.6791    361,232  Netlogon.dll
   28-Aug-2003  14:05  5.0.2195.6810    931,600  Ntdsa.dll
   28-Aug-2003  14:05  5.0.2195.6742    392,464  Samsrv.dll
   28-Aug-2003  14:05  5.0.2195.6813    131,344  Scecli.dll
   28-Aug-2003  14:05  5.0.2195.6813    307,472  Scesrv.dll
   14-Aug-2003  07:58  5.0.2195.6801  5,232,128  Sp3res.dll
   28-Aug-2003  14:05  5.0.2195.6601     51,472  W32time.dll
   16-Aug-2002  02:32  5.0.2195.6601     57,104  W32tm.exe
   28-Aug-2003  14:05  5.0.2195.6741    126,224  Wldap32.dll

WORKAROUND

To work around this issue, use one of the following methods:
  • Do not insert any commas or carriage returns into the logon banner message.
  • Use startup or shutdown scripts instead of Group Policy to write the appropriate text directly to the client registry.
  • Create and maintain separate GPOs for Windows 2000, for Microsoft Windows XP, and for Windows Server 2003 clients.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New File Naming Schema for Microsoft Windows Hotfix Packages
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates
For additional information about is issue on Windows XP machines, click the following article number to view the article in the Microsoft Knowledge Base:
330618 Commas in Interactive Logon Message Are Formatted As Carriage Returns

Properties

Article ID: 823146 - Last Review: February 21, 2007 - Revision: 4.6
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB823146

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