Cómo recuperar o restaurar un solo buzón en Exchange Server 2003

Seleccione idioma Seleccione idioma
Id. de artículo: 823176 - Ver los productos a los que se aplica este artículo
Para obtener una versión de este artículo para Microsoft Exchange 2000 Server, consulte 813337.
Expandir todo | Contraer todo

En esta página

Resumen

En este artículo se describen dos métodos que puede utilizar para recuperar o restaurar un único buzón en Microsoft Exchange Server 2003. Si está configurada la opción de retención de eliminación para los buzones y no ha transcurrido el tiempo que los buzones eliminados pueden permanecer en el servidor, puede recuperar un buzón o varios mediante el Administrador del sistema de Exchange.

Si elimina un buzón y no se ha configurado la opción de retención de los elementos eliminados para los buzones o si ha transcurrido el tiempo que los buzones eliminados pueden permanecer en el servidor, puede recuperar los buzones en un servidor alternativo o en un servidor de recuperación. Puede recuperar los buzones a partir de una copia de seguridad sin producir interrupciones en el entorno de producción.

Método 1: Restaurar un buzón mediante el Administrador del sistema de Exchange

Utilice este método si se ha configurado la opción de retención de elementos eliminados para los buzones y no ha transcurrido el tiempo que los buzones eliminados pueden permanecer en el servidor.

Comprobar o configurar las opciones de eliminación de buzones

Para comprobar o configurar las opciones de eliminación de buzones, siga estos pasos:
  1. Inicie el Administrador del sistema de Exchange.
  2. Si la opción Mostrar los grupos administrativos está habilitada, expanda Grupos administrativos y, a continuación, expanda GrupoAdministrativo (donde GrupoAdministrativo es el nombre de su grupo administrativo).

    Nota
    Para mostrar los grupos administrativos, haga clic con el botón secundario del mouse (ratón) en SuOrganización, haga clic en Propiedades, active la casilla de verificación Mostrar los grupos administrativos, haga clic en Aceptar, haga clic en Aceptary, a continuación, reinicie el Administrador del sistema de Exchange.
  3. Expanda Servidores, expanda SuServidor y, a continuación, expanda SuGrupoDeAlmacenamiento.
  4. Haga clic con el botón secundario del mouse en Almacén del buzón y, a continuación, haga clic en Propiedades.
  5. Haga clic en la ficha Límites.
  6. En el cuadro Guardar los buzones eliminados durante (días), especifique el número de días que los elementos eliminados pueden permanecer en el servidor antes de eliminarse de forma definitiva y, a continuación, haga clic en Aceptar.

Restaurar un buzón mediante el Administrador del sistema de Exchange

Para restaurar un buzón mediante el Administrador del sistema de Exchange:
  1. Inicie el Administrador del sistema de Exchange.
  2. Si la opción Mostrar los grupos administrativos está habilitada, expanda Grupos administrativos y, a continuación, expanda GrupoAdministrativo (donde GrupoAdministrativo es el nombre de su grupo administrativo).

    Nota
    Para mostrar los grupos administrativos, haga clic con el botón secundario del mouse en SuOrganización, haga clic en Propiedades, active la casilla de verificación Mostrar los grupos administrativos, haga clic en Aceptar, haga clic en Aceptary, a continuación, reinicie el Administrador del sistema de Exchange.
  3. Expanda Servidores, expanda SuServidor y, a continuación, expanda SuGrupoDeAlmacenamiento.
  4. Expanda Almacén del buzón, haga clic con el botón secundario del mouse en Buzones y, a continuación, haga clic en Ejecutar agente de limpieza.
  5. Haga clic con el botón secundario del mouse en el buzón que desee recuperar y, a continuación, haga clic en Volver a conectar.
  6. En la lista de cuentas del servicio de directorio Microsoft Active Directory que aparece, haga clic en la cuenta de usuario a la que desea que el buzón se conecte y, a continuación, haga clic en Aceptar.
  7. Salga del Administrador del sistema de Exchange.

Método 2: Utilizar la característica de grupo de almacenamiento de recuperación para recuperar el buzón

El grupo de almacenamiento de recuperación es un grupo especializado de Exchange 2003. Después de restaurar un almacén de buzón en el grupo de almacenamiento de recuperación, utilice la herramienta Exmerge.exe para mover los datos del buzón recuperados del grupo de almacenamiento de recuperación al grupo de almacenamiento normal. Para obtener más información sobre cómo recuperar un buzón mediante la característica de grupo de almacenamiento de recuperación, haga clic en el número de artículo siguiente para ver el artículo en Microsoft Knowledge Base:
824126 Cómo usar los grupos de almacenamiento de recuperación de Exchange Server 2003

Método 3: Restaurar un buzón de copia de seguridad en un servidor de recuperación

Utilice este método si el objeto de buzón en el grupo de almacenamiento de recuperación no coincide con un objeto de usuario en Active Directory que tiene el mismo valor msExchMailboxGUID. Esta situación puede aparecer si la cuenta de usuario se ha eliminado de Active Directory o si los atributos de Exchange se han quitado de la cuenta del usuario y el buzón del almacén de Exchange no se volvió a conectar o se purgó.

Para recuperar un buzón a partir de la copia de seguridad, debe tener un servidor de recuperación con capacidad de memoria suficiente para instalar Exchange Server 2003 y restaurar la base de datos del almacén de información privada. Este servidor puede estar en la misma red física que el equipo de producción de Exchange Server 2003.

Para restaurar un buzón de una copia de seguridad en un servidor de recuperación:
  1. Tome nota de la información siguiente que está en el equipo de producción de Exchange Server 2003:
    • Nombre de la organización
    • Nombre de grupo administrativo
    • Nombre de grupo de almacenamiento
  2. Instale Windows 2000 Server o Windows Server 2003 en el servidor de recuperación y, a continuación, cree un nuevo bosque de Active Directory.
  3. Ejecute el programa de instalación de Exchange Server 2003 y, a continuación, cree una nueva organización con el mismo nombre que la organización de Exchange existente.
  4. Utilice el procedimiento de los siguientes que mejor se ajuste a su situación:
    • Si el nombre de su grupo administrativo es Primer grupo administrativo, vaya al paso 6.

      O bien
    • Para instalar Exchange Server 2003 en un grupo administrativo distinto del Primer grupo administrativo:
      1. Ejecute el programa de instalación de Exchange Server 2003 y, a continuación, instale las herramientas de administración del sistema de Microsoft Exchange.

        Importante
        En este momento, no instale los Servicios de mensajería y colaboración de Microsoft Exchange. Escriba el nombre de su grupo administrativo (el mismo nombre que el grupo administrativo del servidor de producción).
      2. Inicie el Administrador del sistema de Exchange.
      3. Haga clic con el botón secundario del mouse en la organización y, a continuación, haga clic en Propiedades.
      4. Haga clic en la ficha General, active la casilla de verificación Mostrar los grupos administrativos y, a continuación, haga clic en Aceptar.
      5. Cierre y, a continuación, reinicie el Administrador del sistema de Exchange.
      6. Haga clic con el botón secundario del mouse en Grupos administrativos, seleccione Nuevo y haga clic en Grupo administrativo.
      7. En el cuadro Nombre, escriba el nombre del grupo administrativo y, después, haga clic en Aceptar.

        Importante
        Debe utilizar el mismo nombre que denominaba el grupo administrativo en el equipo de producción de Exchange Server 2003.
      8. Salga del Administrador del sistema de Exchange.
  5. Ejecute el programa de instalación de Exchange Server 2003 y, a continuación, instale el Servicio de mensajería y colaboración de Microsoft Exchange y las herramientas de administración del sistema de Microsoft Exchange (si las herramientas de administración del sistema aún no se han instalado en el servidor).
  6. Configure el nombre del grupo de almacenamiento para utilizar el mismo nombre que el equipo de producción de Exchange Server 2003. Para ello:
    1. Inicie el Administrador del sistema de Exchange.
    2. Expanda Grupos administrativos y, a continuación, expanda GrupoAdministrativo
    3. Expanda Servidores y, a continuación, expanda SuServidor

      Si el nombre del grupo de almacenamiento en el servidor de producción utiliza un nombre distinto de Primer grupo de almacenamiento, configure el nombre del grupo de almacenamiento para utilizar el mismo nombre que el grupo de almacenamiento del equipo de producción de Exchange Server 2003.
  7. Desmonte la base de datos. Para ello:
    1. Haga clic con el botón secundario del mouse en Almacén del buzón y, a continuación, haga clic en Desmontar el almacén.
    2. Haga clic en cuando se le pregunte si desea continuar.
    3. Haga clic con el botón secundario del mouse en Almacén del buzón y, a continuación, haga clic en Propiedades.
    4. Haga clic en la ficha Base de datos y, a continuación, active la casilla de verificación Se puede sobrescribir esta base de datos por una restauración.
    5. Haga clic en Aceptar.
    6. Salga del Administrador del sistema de Exchange.
  8. Elimine los archivos de registro y base de datos existentes que están en el servidor de recuperación. Para ello:
    1. Inicie el Explorador de Windows.
    2. Busque y, a continuación, haga clic en la carpeta C:\Archivos de programa\Exchsrvr\Mdbdata.

      Nota
      La carpeta C:\Archivos de programa\Exchsrvr es la ubicación de instalación predeterminada de Exchange Server 2003. Si instaló Exchange Server 2003 en una carpeta diferente, la ubicación de la carpeta Exchsrvr es diferente en su equipo.
    3. En el menú Edición, haga clic en Seleccionar todo.
    4. Presione la tecla SUPRIMIR.
    5. Cuando se le pregunte si confirma la eliminación, haga clic en .
  9. Restaure los archivos de base de datos a partir de la copia de seguridad.
  10. Monte la base de datos. Para ello:
    1. Inicie el Administrador del sistema de Exchange.
    2. Expanda Grupos administrativos y, a continuación, expanda GrupoAdministrativo
    3. Expanda Servidores, expanda SuServidor y, a continuación, expanda SuGrupoDeAlmacenamiento.
    4. Haga clic con el botón secundario del mouse en Almacén del buzón y, a continuación, haga clic en Montar el almacén.
    5. Haga clic en Aceptar cuando reciba el mensaje que indica que el almacén se ha montado correctamente.
  11. Cree un nuevo usuario en Usuarios y equipos de Active Directory. Asegúrese de no habilitar para buzones la nueva cuenta de usuario. Para crear el nuevo usuario:
    1. Inicie Usuarios y equipos de Active Directory.
    2. Haga clic con el botón secundario del mouse en Usuarios, seleccione Nuevo y, a continuación, haga clic en Usuario.
    3. Especifique el nombre de usuario y el nombre de inicio de sesión del usuario en los cuadros adecuados y, a continuación, haga clic en Siguiente.
    4. Especifique la información de contraseña para el usuario y, a continuación, haga clic en Siguiente.
    5. Desactive la casilla de verificación Crear un buzón de Exchange y, a continuación, haga clic en Siguiente.
    6. Haga clic en Finalizar.
  12. En el Administrador del sistema de Exchange, expanda Almacén del buzón, haga clic con el botón secundario del mouse en Buzones y, a continuación, haga clic en Ejecutar agente de limpieza.
  13. Recupere el buzón. Para ello:
    1. Haga clic con el botón secundario del mouse en el buzón que desee recuperar y, a continuación, haga clic en Volver a conectar.
    2. En la lista de cuentas de Active Directory, haga clic en la cuenta de usuario que creó en el paso 12 y, a continuación, haga clic en Aceptar.
  14. Utilice Microsoft Outlook para exportar los datos del buzón a un archivo .pst o utilice la herramienta Exmerge.exe para extraer los datos de varios buzones.

    Para descargar Exmerge.exe, visite el siguiente sitio Web de Microsoft:
    http://www.microsoft.com/downloads/details.aspx?displaylang=en&familyid=429163EC-DCDF-47DC-96DA-1C12D67327D5

Información adicional

La utilidad ExMerge no admite archivos .pst de Unicode. Si exporta los datos de Outlook 2003, el formato de .pst predeterminado es Unicode. Para evitar este problema, cree un archivo .pst con formato ANSI. Éste es un archivo .pst compatible con Outlook 97 y Outlook 2003. Para ello, siga estos pasos:
  1. En Outlook 2003, haga clic en Nuevo en el menú Archivo y, a continuación, haga clic en Archivo de datos de Outlook.
  2. En el cuadro de diálogo Nuevos archivos de datos de Outlook, haga clic en Outlook 97-2002 Personal Folders File (.pst) y, a continuación, haga clic en Aceptar.
  3. En el cuadro de diálogo Crear o abrir archivo de datos de Outlook, elija una ubicación en el cuadro Guardar como archivo de tipo y, a continuación, escriba un nombre para el archivo, como Exmerge.pst. La opción Guardar como archivo de tipo será Personal Folders Files (*.pst). Haga clic en Aceptar.
  4. En el cuadro de diálogo Crear carpetas personales Microsoft, puede modificar la línea Nombre con un nombre para mostrar que sea único, como "Datos de Exmerge" sin las comillas. Así aparecerá el archivo .pst cuando se muestre en la Lista de carpetas de Outlook. Haga clic en Aceptar. Mantenga la configuración de predeterminada para las otras opciones.
  5. El nuevo archivo aparecerá en la Lista de carpetas en Outlook. Haga clic con el botón secundario del mouse en este archivo y, a continuación, haga clic en Cerrar Carpeta. Carpeta es el nombre para mostrar que estableció en el paso 4.
  6. En el menú Archivo, haga clic en Importar y exportar.
  7. En el Asistente para importar y exportar, haga clic en Exportar a un archivo y, a continuación, haga clic en Siguiente.
  8. En la página Exportar a un archivo, haga clic en Personal Folder File (.pst) y, a continuación, haga clic en Siguiente.
  9. En la página Exportar carpetas personales, seleccione la carpeta que desee exportar. Si desea exportar todo el contenido del buzón, haga clic en el nombre de usuario en la parte superior del árbol Seleccione la carpeta para exportar y, a continuación, haga clic en Siguiente.
  10. En la página Exportar carpetas personales, utilice el botón Examinar para buscar y seleccionar el archivo .pst recién creado. Haga clic en Aceptar cuando lo seleccione, y, a continuación, haga clic en Finalizar. Para ver el contenido del archivo para asegurarse de que se exportaron los datos correctamente, abra el archivo en Outlook. Para ello, haga clic en Abrir en el menú Archivo, haga clic en Archivo de datos de Outlook y, a continuación, haga clic en el archivo.

Referencias

Para obtener más información acerca de Exchange Server 2003, visite el sitio Web de Microsoft siguiente:
http://www.microsoft.com/exchange/library

Propiedades

Id. de artículo: 823176 - Última revisión: lunes, 26 de noviembre de 2007 - Versión: 2.4
La información de este artículo se refiere a:
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
Palabras clave: 
kbhowtomaster KB823176

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com