Klientské programy přestane reagovat při kterým čekání na uzamčení souboru pro vyskytnout

Překlady článku Překlady článku
ID článku: 823272 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

V prostředí klient server, kde více klientských programů provést uzamčení souboru na soubor dat, který je umístěn na souborovém serveru, může všechny klientské programy přestat reagovat (zablokuje se).

Příčina

K těmto potížím dochází, pokud klientský program provádí určité sekvence požadavky lock datový soubor a v důsledku toho klientský program, je uděleno zámek nikdy obdrží uzamčení. K tomuto problému dochází z důvodu problému příležitostné uzamčení přesměrovač.

Řešení

Informace o aktualizaci Service Pack

Tento problém vyřešíte pomocí nejnovější aktualizace service pack pro systém Microsoft Windows XP. Další informace získáte následujícím článku báze Microsoft Knowledge Base:
322389Jak získat nejnovější aktualizaci service pack pro systém Windows XP

Informace o opravě hotfix

Podporovaná oprava hotfix k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze k odstranění problému popsaného v tomto článku. Tuto opravu hotfix použijte pouze v systémech, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud je přísně neohrožuje tento problém, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, je oddíl "K dispozici oprava Hotfix stahování" v horní části tohoto článku znalostní báze Knowledge Base. Pokud v této části se nezobrazí, obraťte se na služby Microsoft a podporu získat opravu hotfix.

Poznámka: Pokud vyskytnout další problémy nebo řešení potíží je vyžadován, pravděpodobně budete muset vytvořit požadavek na samostatnou službu. Výdaje na podporu se obvykle týkají dalších otázek a problémů, které se netýkají této zvláštní opravy hotfix. Úplný seznam telefonních čísel služby Microsoft a podpora nebo vytvořit zvláštní požadavek na službu na následujícím webu společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "K dispozici oprava Hotfix stahování" formulář zobrazí jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, je to, protože oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Neexistují žádné požadavky.

Požadavek na restartování

Po instalaci této opravy hotfix, musíte restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné další opravy hotfix.

Informace o souboru

Anglická verze této opravy hotfix má atributy souborů (nebo novější), jsou uvedeny v následující tabulce. Data a časy těchto souborů jsou uvedeny v čase univerzální koordinovaný (čas UTC). Při zobrazení informací o souboru, bude převedena na na místní čas. Rozdíl mezi místním časem a UTC časem kartě časové pásmo v panelu Datum a čas v Ovládacích panelech.
	Windows 2000
	
	   Date         Time   Version        Size     File name
	   ------------------------------------------------------
	   20-Jun-2003  03:29  5.0.2195.6760  407,792  Mrxsmb.sys
	   20-Jun-2003  03:29  5.0.2195.6760  169,520  Rdbss.sys
	
	Windows XP
	
	   Date         Time    Version       Size     File name
	   ------------------------------------------------------
          26-Jun-2003  12:00  5.1.2600.1239   92,160  Cscdll.dll
	   24-Jun-2003  03:11  5.1.2600.1239  401,920  Mrxsmb.sys
	   24-Jun-2003  03:11  5.1.2600.1239  156,160  Rdbss.sys

Jak potíže obejít

Chcete-li tento problém vyřešit, zakažte příležitostné zamykání, na všechny klientské počítače nebo na serveru soubor. Další informace o tom, jak zakázat příležitostné zamykání naleznete následující článku znalostní báze Microsoft Knowledge Base:
129202Rozšíření PC: Vysvětlení příležitostného zamykání v systému Windows NT

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části „ platí. Tento problém byl poprvé opraven v aktualizaci Service Pack 2 pro systém Windows XP.

Další informace

Další informace o opravu hotfix balíčkům naleznete následující článku znalostní báze Microsoft Knowledge Base:
816915Nové schéma přidělování názvů balíčkům oprav Hotfix systému Windows

Vlastnosti

ID článku: 823272 - Poslední aktualizace: 5. června 2007 - Revize: 3.6
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Klíčová slova: 
kbmt kbautohotfix kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbbug kbfix kbqfe kbwin2000presp5fix KB823272 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:823272

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com