O processo Rpcss.exe consome 60 por cento do tempo da CPU e o desempenho é afetado

Traduções deste artigo Traduções deste artigo
ID do artigo: 823273 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

O processo Rpcss.exe consome 60 por cento ou mais tempo de CPU e o desempenho do sistema e o desempenho da rede são afetados. Esse sintoma ocorre normalmente 49.7 dias depois que o servidor é iniciado.

Causa

Esse problema ocorre porque uma chamada para a função ObterContagemMarcaEscala a timer faz a função estouro 49.7 dias depois que o servidor é iniciado.

Esse problema pode ocorrer se uma das seguintes condições for verdadeira:
  • Você está usando o Microsoft Windows 2000 Server.
  • Você estiver usando o Microsoft Windows NT Server 4.0, e você instalado os hotfixes descritos nos seguintes artigos da Base de dados de Conhecimento:
    305399Pedido de malformado para o mapeador de ponto de extremidade RPC pode causar falha do serviço RPC
    297534Thread ReceiveAny gera erro de "RPC_S_OUT_OF_MEMORY"

Resolução

Atualizar informações

Para resolver esse problema, obtenha o Update Rollup 1 para o Windows 2000 SP4. Para obter mais informações sobre como fazer isso, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
891861Update Rollup 1 para o Windows 2000 SP4 e problemas conhecidos

Informações sobre o hotfix Windows 2000 Server

Um hotfix suportado agora está disponível da Microsoft, mas destina-se somente a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Para resolver esse problema, contate o Atendimento Microsoft para obter o hotfix. Para obter uma lista completa de telefones do Atendimento Microsoft e informações sobre os custos de suporte da, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação Em alguns casos, as taxas cobradas pelas ligações para chamadas de suporte podem ser canceladas se um profissional de suporte da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas que não se qualificam à atualização específica em questão de suporte adicionais.

Pré-requisitos

Não pré-requisitos são necessários

Informações sobre o arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version           Size     File name
   --------------------------------------------------------------
   07-Jan-2004  00:21  5.0.2195.6878     953,104  Ole32.dll        
   07-Jan-2004  00:21  5.0.2195.6888     435,472  Rpcrt4.dll       
   07-Jan-2004  00:21  5.0.2195.6878     211,216  Rpcss.dll        

				

Informações sobre o hotfix Windows NT Server 4.0

Um hotfix suportado agora está disponível da Microsoft, mas destina-se somente a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Para resolver esse problema, contate o Atendimento Microsoft para obter o hotfix. Para obter uma lista completa de telefones do Atendimento Microsoft e informações sobre os custos de suporte da, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação Em alguns casos, as taxas cobradas pelas ligações para chamadas de suporte podem ser canceladas se um profissional de suporte da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas que não se qualificam à atualização específica em questão de suporte adicionais.

Pré-requisitos

Devido às dependências do arquivo, esse hotfix exige o Microsoft Windows NT 4.0 Service Pack 6a.

Informações sobre o arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version           Size     File name
   --------------------------------------------------------------
   22-Aug-2003  09:44  4.0.1381.7232     345,872  Rpcrt4.dll       

				

Mais Informações

Para obter informações adicionais sobre como os pacotes de hotfix são nomeados e sobre outros termos para atualizações de software, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
816915Novo esquema de nomeação de arquivo para pacotes de atualização de software do Microsoft Windows
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Propriedades

ID do artigo: 823273 - Última revisão: sábado, 26 de outubro de 2013 - Revisão: 4.3
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Advanced Server 3.1
Palavras-chave: 
kbnosurvey kbarchive kbmt kbqfe kbwin2000presp5fix kbfix kbbug KB823273 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 823273

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com