OL2000: Forwarded Message Appears Incorrectly When Using the Forward Method

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Article ID: 823406 - View products that this article applies to.
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Symptoms

When you use the forward method in a macro to forward an e-mail message that contains an embedded object, you may find that the forwarded message does not appear correctly. For example, some text may be missing.

Cause

This problem may occur if the following conditions are true:
  • You use the forward method in a macro to forward an e-mail message. For example, the macro may appear similar to the following:
    Public Sub test()
    Set myOlApp = CreateObject("Outlook.Application")
    Set myNameSpace = myOlApp.GetNameSpace("MAPI")
    Set myFolder = myNameSpace.GetDefaultFolder(olFolderInbox)
    Set myForward = myFolder.Items(1).Forward
    myForward.Recipients.Add "TestUser"
    myForward.Display
    End Sub
    
  • The message is in Rich Text format (.rtf). The problem does not occur if you use HTML format or Plain Text format.
  • You do not use Microsoft Word as the default e-mail editor in Outlook. The problem does not occur if you use Word as the default e-mail editor in Outlook.

Resolution

How to Obtain the Hotfix

This issue is fixed in the Outlook 2000 Post-Service Pack 3 Hotfix Package dated July 3, 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
823324 Availability of Outlook 2000 Post-Service Pack 3 Hotfix Package: July 3, 2003

Workaround

To work around this problem, use one of the following methods:
  • Use HTML format or Plain Text format for your messages.

    To do this, on the Tools menu, click Options, click the Mail Format tab, and then select the format that you want to use in the Compose in this message format box.
  • Use Word as the default e-mail editor in Outlook.

    To do this, on the Tools menu, click Options, click the Mail Format tab, and then click to select the Use Microsoft Word to edit e-mail messages check box.
  • Forward the message manually.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Properties

Article ID: 823406 - Last Review: October 26, 2013 - Revision: 3.0
Applies to
  • Microsoft Outlook 2000 Standard Edition
Keywords: 
kbnosurvey kbarchive kbqfe kbhotfixserver kbfix kbbug KB823406

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