スケジュールされたタスクで Windows 2000 Service Pack 4 を削除するときに実行されません。

文書翻訳 文書翻訳
文書番号: 823441 - 対象製品
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
すべて展開する | すべて折りたたむ

現象

Windows 2000 Service Pack 4 (SP4)] に、Windows 2000 ベースのコンピューターをアップグレードする SP4 を削除する、なった作成したタスク実行します。 スケジュールされたタスクの状態を表示すると、次のメッセージが返されます。
状態: 開始できませんでした。
タスク スケジューラ (C:\WINNT \SchedLgU.txt) によって作成されるログ ファイルを表示すると、次のような情報されていること。
Prompt.job] コマンド (cmd.exe) 2003/6/13 11時 10分: 00 ** エラー **
タスクが実行されないため、指定したタスクのアカウント情報の取得に失敗です。 エラーが発生したか、タスクのアカウント情報は存在しません。
特定エラーは。
0x8004130f : タスク スケジューラ セキュリティ データベースに、指定されたタスクのアカウント情報がありません。
SP4 を再インストールするスケジュールされたタスクもは実行されません。

原因

この問題はされる Windows 2000 SP4 をインストールすると、資格情報データベースに格納されているデータに変更されたために発生します。

SP4 をインストールするときに、資格情報データベースに格納されているのデータが、SP4 互換形式に変換されます。 レジストリ キーは、データを SP4 の形式に変換されたことを示すに設定されます。 SP4 を削除するとこのレジストリ キーも削除されます。 この現象は後続の SP4 インストール データを SP4 の形式に変換することを確認する発生します。 ただし、データ自体は変更されずと有効したがってスケジュールされたタスクの実行を使用している資格情報でない旧バージョンの Windows 2000 がアクセスした場合。

タスク スケジューラ サービスも、資格情報データベースを解析するコード含み、既存のタスクに対応していないすべてのデータを削除するこのコード。 したがって、SP4 で格納されたすべての資格情報は、Windows の以前のバージョンで削除します。 このハウスキーピング コード開始 10 分後、タスク スケジューラ サービス開始し、もファイルは、タスクのフォルダーから削除されるたびを開始します。 したがって、Windows 2000 SP4 でスケジュールされたタスクを作成するし、SP4 以前のバージョンの Windows 2000 に戻すには削除をして場合、SP4 を再インストールする前に、少なくとも 10 分をタスク スケジューラ サービスを実行する場合スケジュールされたタスクの資格情報が削除されます。

回避策

この問題を回避するには各タスクの資格情報に再入力します。 SP4 を削除し、スケジュールされたタスクの資格情報を再入力すると、新しい有効な資格情報は、サービス パック レベルを実行している Windows のに対して作成されます。 後から SP4 をインストールすると、これらの新しい資格情報は SP4 と互換性のある資格情報に変換されます。

メモ 削除してから SP4 を再インストールする SP4 を既に削除いない場合は、次の手順に従います。
  1. タスク スケジューラ サービスを停止してから設定、スタートアップの種類 を無効に するします。
  2. Windows 2000 SP4 を削除します。
  3. Windows 2000 SP4 を再インストールします。
  4. タスク スケジューラ サービスを起動し、スタートアップの種類を [ 自動 ] に設定します。
以前にスケジュールされたタスクを実行し続けます。

状況

マイクロソフトとして認識していますこの問題を記載されているいるマイクロソフト製品の問題。

プロパティ

文書番号: 823441 - 最終更新日: 2014年2月27日 - リビジョン: 2.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Professional SP4
キーワード:?
kbnosurvey kbarchive kberrmsg kbbug kbnofix kbmt KB823441 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:823441
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com