在删除 Windows 2000 Service Pack 4 后任务计划不再运行

文章翻译 文章翻译
文章编号: 823441 - 查看本文应用于的产品
本文已归档。它按“原样”提供,并且不再更新。
展开全部 | 关闭全部

症状

将基于 Windows 2000 的计算机升级到 Windows 2000 Service Pack 4 (SP4),然后又删除 SP4 之后,您已创建的任务计划不再运行。在您查看任务计划的状态时,返回以下消息:
Status:Could not start
在您查看用任务计划程序 (C:\WINNT\SchedLgU.txt) 创建的日志文件时,会看到如下的类似信息:
"Command Prompt.job" (cmd.exe) 6/13/2003 11:10:00 AM ** ERROR ** The attempt to retrieve account information for the specified task failed; therefore, the task did not run.Either an error occurred, or no account information existed for the task.The specific error is:0x8004130f:No account information could be found in the Task Scheduler security database for the task indicated.
如果您重新安装 SP4,该任务计划仍不运行。

原因

导致此问题的原因在于您安装 Windows 2000 SP4 时对凭据数据库中存储的数据进行了更改。

在您安装 SP4 时,存储在凭据数据库中的数据被转换为与 SP4 兼容的格式。系统将会配置一个注册表项以指示该数据已被转换为 SP4 格式。如果您删除 SP4,该注册表项也会随之被删除。出现这种行为是为了确保以后的 SP4 安装将数据转换为 SP4 格式。但是,数据本身并未更改,因此,用来运行任务计划的凭据在 Windows 2000 的早期版本访问它们时无效。

Task Scheduler 服务还包含用来对凭据数据库进行分析的代码,并且此代码会删除与现有任务不相符的所有数据。因此,在 SP4 下已存储的所有凭据都会被 Windows 的早期版本删除。此内部管理代码在 Task Scheduler 服务启动 10 分钟后启动,并且只要从“任务”文件夹中删除文件也会启动。因此,如果您在 Windows 2000 SP4 中创建任务计划,然后删除 SP4 以还原到 Windows 2000 的早期版本,并且 Task Scheduler 服务在您重新安装 SP4 前运行了至少 10 分钟,则任务计划的凭据将被删除。

替代方法

若要解决此问题,请为每一任务计划重新输入凭据。如果您删除 SP4,然后为某一任务计划重新输入凭据,则为您正运行的 Windows 的 Service Pack 级别创建新的有效凭据。如果您以后安装 SP4,则这些新凭据将被转换为与 SP4 兼容的凭据。

注意 如果您要删除 SP4 然后重新安装它,并且尚未删除 SP4,则按照下列步骤操作:
  1. 停止 Task Scheduler 服务,然后将其启动类型设置为“禁用”。
  2. 删除 Windows 2000 SP4。
  3. 重新安装 Windows 2000 SP4。
  4. 启动 Task Scheduler 服务,然后将其启动类型设置为“自动”。
以前的任务计划会继续运行。

状态

Microsoft 已经确认这是在本文开头列出的 Microsoft 产品中存在的问题。

属性

文章编号: 823441 - 最后修改: 2014年2月27日 - 修订: 1.0
这篇文章中的信息适用于:
  • Microsoft Windows 2000 Service Pack 4
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
关键字:?
kbnosurvey kbarchive kberrmsg kbbug kbnofix KB823441
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com