The Site Replication Service does not process messages, and Event ID 1091 is logged

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Article ID: 823565 - View products that this article applies to.
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SYMPTOMS

The Site Replication Service (SRS) on your Microsoft Exchange Server 2003 computer does not process messages, and you receive the following event in the application event log:

Event Type: Warning
Event Source: MSExchangeSRS
Event Category: Replication
Event ID: 1091
Description: The directory replication agent (DRA) attempted to open mail with name /o=Your_Organization_Name/ou=Your_OU/cn=Configuration/cn=Servers/cn=Your_Server/cn=Microsoft DSA:Your_Server but received error 2152006410. Messages could not be sent. Make sure that the mail service on this Microsoft Exchange Server computer is running.

CAUSE

This problem occurs because the MAPI DRA does not close down completely until the receive thread closes. If the send thread encounters an error, the DRA is marked as not running, and the receive thread cannot close. The send thread cannot re-initialize the MAPI DRA because the DRA is not completely closed.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   11-Aug-2003  18:31  6.5.6980.17       339,456  Srsmain.exe        
   11-Aug-2003  18:31  6.5.6980.17       339,456  Srsmain.exe                                               

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 823565 - Last Review: October 25, 2007 - Revision: 2.5
APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbbug KB823565

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