Article ID: 823596 - Last Review: December 3, 2007 - Revision: 7.10

IIS Admin Service Quits Unexpectedly Without Generating an Error Message

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SYMPTOMS

On a Windows Server 2003-based computer, the IIS Admin Service (Inetinfo.exe) may quit unexpectedly without generating a Dr. Watson error message. Additionally, a crash dump file is not generated.

CAUSE

This problem occurs because of a flag in the Microsoft Internet Information Services (IIS) Inetinfo.exe process. This flag filters certain exceptions so that Just-in-Time ( JIT) debugging does not occur in a crash scenario.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to install this hotfix.

Restart Requirement

You must restart your computer to apply the changes after you install this hotfix. However, you do not have to restart the computer immediately after you install the hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003
Date         Time   Version            Size    File name
-----------------------------------------------------------
27-Jun-2003  05:40  6.0.3790.67        13,312  Inetinfo.exe
27-Jun-2003  05:40  6.0.3790.67         6,656  W3wp.exe
Windows Server 2003 64-bit
Date         Time   Version            Size    File name
-----------------------------------------------------------
26-Jun-2003  20:09  6.0.3790.67        29,696  Inetinfo.exe   IA64
26-Jun-2003  20:09  6.0.3790.67        12,800  W3wp.exe       IA64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

APPLIES TO
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwinserv2003presp1fix KB823596