You receive the "You are trying to publish a non-enterprise project to Microsoft Project Server" error message when you try to publish to Microsoft Project Server

Article translations Article translations
Article ID: 823618 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

When you try to publish to Microsoft Project Server, you may receive the following error message:
Alert! You are trying to publish a non-enterprise project to Microsoft Project Server.
The administrator settings on the server do not allow you to publish non-enterprise projects.

CAUSE

This behavior may occur for one of the following reasons:
  • You do not have an authorized connection to the Microsoft Project Server computer through the Project Data Service (PDS). You must have this connection to create and to publish enterprise files.
  • The project file that you are trying to publish was created by using Microsoft Project 2000. However, your version of Microsoft Project Server is configured so that only files that were created by using Microsoft Project Professional 2002 or later can be published to Microsoft Project Server.
  • You may not be connected to the Microsoft Project server.

RESOLUTION

To resolve this behavior, use one of the following methods:

Method 1: Save the Project File as a .published File

Save the Project file as a .published file. To do so, follow these steps:

Note This method changes the Microsoft Project 2000 .mpp file to a Microsoft Project Professional .published file.
  1. Start Microsoft Project Professional.
  2. Open the Microsoft Project 2000 .mpp file.
  3. On the File menu, click Save as.
  4. Save the file as a .published file.

Method 2: Import the Project File into Project Server

Import the existing project file into the server. To do so, follow these steps:
  1. Log on to Microsoft Project Server.

    Note You must have at least Project Manager permissions.
  2. On the Tools menu, click Enterprise Options.
  3. Click Import Project to Enterprise.
  4. Follow the steps in the Import Wizard to change your .mpp Microsoft Project 2000 file to a Microsoft Project Professional .published file.

Method 3: Change the Publishing Restrictions

Change the publishing restrictions. To do so, follow these steps:
  1. Log on to Microsoft Project Server as Administrator.
  2. On the Administration menu, click Manage Enterprise features.
  3. Click to clear the Allow only Microsoft Project Professional to publish to the server check box.
  4. Save the changes.

Method 4: Connect to the Project Server

Log on to Microsoft Project Professional, and then connect to the server. To do so, follow these steps:
  1. Start Microsoft Project Professional.
  2. On the Tools menu, click Enterprise Options.
  3. Click Microsoft Project Accounts.
  4. Create a profile for an account that already exists on the server, and make sure that the account has at least Project Manager permissions.
    1. Type the account name.
    2. Type the current URL for the Microsoft Project Server.
    3. Select the authentication type of the account that is to be used. If the account is Microsoft Project server authenticated, then log on to Microsoft Project Server with your Microsoft Project Web Access user account's username and password.
    4. If the Automatically detect connect state check box is selected, then set the new account as the default. Otherwise, the connection state will automatically select the profile when you log on to the server.
When you log on to the server later on, you will have a connection to the server, and then you can publish enterprise projects.

Properties

Article ID: 823618 - Last Review: September 18, 2011 - Revision: 4.0
APPLIES TO
  • Microsoft Project 2002 Professional Edition
  • Microsoft Project Server 2002
  • Microsoft Project 2000 Standard Edition
Keywords: 
kbformat kberrmsg kbprb KB823618

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com