Un servicio que realiza una llamada a la función SetProcessWorkingSetSize falla en Windows Server 2003 y Windows 2000 Server

Seleccione idioma Seleccione idioma
Id. de artículo: 823684 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando un servicio realiza una llamada a la función SetProcessWorkingSetSize para intentar aumentar el tamaño del conjunto de trabajo, la operación no funcione. De manera predeterminada, no hay ninguna notificación visual que se produjo el error a menos que alguna de las siguientes condiciones sean true:
  • Los errores de servicio.
  • El desarrollador ha agregado código para registrar o mostrar el error generado por la función SetProcessWorkingSetSize .

Causa

Este problema se produce si el servicio está configurado para iniciar sesión en una cuenta distinta de la cuenta sistema local. Por ejemplo, este problema puede producirse si el servicio está configurado para iniciar sesión en la cuenta de administrador.

Solución

Información sobre hotfix de Windows Server 2003

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

No es necesario que reinicie el equipo una vez aplicado este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.

Windows Server 2003

   Date         Time   Version      Size        File name
   ---------------------------------------------------------
   24-Jul-2003  20:01  5.2.3790.72  2,407,424   Ntkrnlmp.exe
   24-Jul-2003  19:36  5.2.3790.72  2,064,384   Ntkrnlpa.exe
   24-Jul-2003  19:36  5.2.3790.72  2,106,880   Ntkrpamp.exe
   24-Jul-2003  20:05  5.2.3790.72  2,206,720   Ntoskrnl.exe

Windows Server 2003, 64-Bit Edition

   Date         Time   Version      Size       File name     Platform
   ------------------------------------------------------------------
   01-Aug-2003  12:14  5.2.3790.74  5,345,792  Ntkrnlmp.exe  IA-64

Información sobre hotfix de Windows 2000

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Esta revisión requiere Windows 2000 Service Pack 4 (SP4).

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time    Version        Size        File name
   ------------------------------------------------------------
   26-Jun-2003  16:26   5.0.2195.6762     29,712   Mountmgr.sys
   08-Aug-2003  20:47   5.0.2195.6801  1,697,472   Ntkrnlmp.exe
   08-Aug-2003  20:48   5.0.2195.6801  1,696,640   Ntkrnlpa.exe
   08-Aug-2003  20:48   5.0.2195.6801  1,717,568   Ntkrpamp.exe
   08-Aug-2003  20:47   5.0.2195.6801  1,675,072   Ntoskrnl.exe

Solución

Para evitar este problema, configurar el servicio para iniciar sesión en la cuenta sistema local.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener información adicional acerca de cómo se denominan los paquetes de revisión, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura de archivos para los paquetes de actualización de software de Microsoft Windows
Para obtener información adicional acerca de terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 823684 - Última revisión: martes, 24 de julio de 2007 - Versión: 2.10
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbwin2000presp5fix kbwinserv2003presp1fix kbqfe kbfix kbbug KB823684 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 823684

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com