Windows 2000 Terminal Server stops responding and a black screen appears

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Article ID: 823747 - View products that this article applies to.
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Symptoms

When you try to log on to your Microsoft Windows 2000 Terminal Server, the server may stop responding. You do not receive an error message, and your screen appears black.

Cause

This problem may occur if the Windows redirector (the program that intercepts requests for resources in a computer) stops responding because a transport cannot be deleted (torn down). Transports handle message delivery and routing. The transport cannot be deleted because a Microsoft Exchange request for a copy operation is pending.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must install Windows 2000 Service Pack 3 (SP3) or later before installing this hotfix. To obtain the latest service pack for Windows 2000, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/windowsserver/2000/bb735341.aspx

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   28-Jul-2003  16:37  5.0.2195.6794  407,792  Mrxsmb.sys
   28-Jul-2003  16:37  5.0.2195.6794  169,520  Rdbss.sys

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New Naming Schema for Microsoft Windows Hotfix Packages

Properties

Article ID: 823747 - Last Review: October 26, 2013 - Revision: 5.0
Applies to
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbAutoHotfix kbHotfixServer kbqfe kbbug kbfix kbwin2000presp5fix KB823747

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