Removable Storage May Quit Unexpectedly or a Computer That Is Running Windows 2000 May Stop Responding

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Article ID: 823767 - View products that this article applies to.
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SYMPTOMS

On a computer that is running Windows 2000, you may experience one of the following problems:
  • Removable Storage may quit unexpectedly.

    -or-
  • The computer may stop responding.

CAUSE

Under some conditions, the logical unit number (LUN) queue may stop responding when the class driver requests the small computer system interface (SCSI) port driver to flush the queue. If the queue contains a pending request, the port driver may not flush the queue and Windows 2000 may stop responding.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows 2000 Service Pack 3 (SP3) installed to install this update.

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time    Version        Size     File name
   ---------------------------------------------------------
   01-Jul-2003  21:12   5.0.2195.6766  74,192   Scsiport.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about Remote Storage, click the following article number to view the article in the Microsoft Knowledge Base:
234776 Remote Storage Services Recommended Practices

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New Naming Schema for Microsoft Windows Hotfix Packages

Properties

Article ID: 823767 - Last Review: October 26, 2013 - Revision: 2.6
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB823767

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