以错误顺序删除 Windows 软件更新可能导致操作系统停止工作

文章翻译 文章翻译
文章编号: 823836 - 查看本文应用于的产品
展开全部 | 关闭全部

症状

在使用“控制面板”中的“添加或删除程序”工具或使用 Spuninst.exe 文件删除 Microsoft Windows 软件更新后,操作系统可能无法正常工作或根本就不工作。在删除 Windows 软件更新时,可能会收到类似于以下内容的警告消息:
安装程序在您的计算机上检测到下列程序:
<软件更新和应用程序的列表>
如果删除软件更新,这些程序可能无法正常运行。是否继续?

原因

如果从操作系统中以错误的顺序删除 Windows 软件更新,就会出现此问题。

注意:为了保持操作系统上文件的一致性,请按照与安装更新时相反的顺序删除 Windows 软件更新。首先删除最近安装的 Windows 软件更新,然后再删除次新的软件更新,依此类推。

以下方案可能导致操作系统无法正常工作。

方案 1

  1. 安装 <软件更新 1>。
  2. 安装 <软件更新 1> 之前发布的 Service Pack。
  3. 删除 <软件更新 1>。

方案 2

  1. 安装 <软件更新 1>。
  2. 安装 <软件更新 2>。
  3. 删除 <软件更新 1>。
注意:我们不支持这些方案。我们建议您不要删除软件更新。

解决方案

要解决此问题,请按照与安装更新时相反的顺序删除软件更新。

方案 1

  1. 安装 <软件更新 1>。
  2. 安装 <软件更新 1> 之前发布的 Service Pack。
  3. 删除在步骤 2 中安装的 Service Pack。
  4. 删除 <软件更新 1>。
  5. 重新安装步骤 2 中安装的 Service Pack。

方案 2

  1. 安装 <软件更新 1>。
  2. 安装 <软件更新 2>。
  3. 删除 <软件更新 2>。
  4. 删除 <软件更新 1>。
要确定软件更新的安装顺序,您可以创建 TimeLine.log 文件。为此,请按照下列步骤操作:
  1. 依次单击“开始”和“运行”,键入 cmd,然后单击“确定”。
  2. 在命令提示符处,键入以下命令:
    dir %windir%\*.log /o:d | findstr /i /r /c:q......\.log /c:kb......\.log /c:q......uninst\.log /c:kb......uninst\.log > %systemdrive%\TimeLine.log
  3. 按 Enter
打开 TimeLine.log 文件 (%systemdrive%\TimeLine.log) 时,将按日期顺序列出已安装的软件更新。最近安装的软件更新列在最后。

要删除软件更新,请先删除 TimeLine.log 文件最后列出的软件更新,然后依次向上逐个删除。每次删除一个软件更新,直到删除您最想要删除的软件更新为止。

如果已经由于按错误顺序删除软件更新而遇到了问题,而且使用的是 Windows XP 或 Windows 2000,则可以用 Qfecheck.exe 工具来确定可能受到破坏的软件更新。您可以用 Qfecheck.exe 工具跟踪并确认已安装的 Windows 软件更新。在 Qfecheck.exe 工具报告受到破坏的软件更新后,请重新安装该软件更新,以确保安装正确的文件版本。有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
282784 Qfecheck.exe 验证 Windows 2000 和 Windows XP 修补程序的安装

更多信息

安装软件更新时,会在 %SystemRoot%\$NtUninstall[KBArticleNumber]$\ 位置创建一个卸载文件夹。此卸载文件夹包含该软件更新所替换的原始文件。

在删除软件更新时,其卸载文件夹中的文件将被复制回操作系统目录。此外,注册表项也将被设置回其原始值。

如果要删除并非最近安装的软件更新,则会收到类似于以下内容的警告消息:
安装程序在您的计算机上检测到下列程序:
<软件更新和应用程序的列表。>
如果删除软件更新,这些程序可能无法正常运行。是否继续?
此消息包含一个列表,其中列出了自应用您试图删除的软件更新以来,在计算机上应用的所有软件更新和应用程序。如果使用 /quiet/passive 命令行开关以无人参与模式安装软件更新,则不会收到此警告消息,而且软件更新删除进程将继续进行。

有关在安装 Windows 软件更新时可以使用的命令行开关选项的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
262841 用于 Windows 软件更新程序包的命令行开关
应用程序通常并不依赖软件更新,但可能会依赖 Service Pack 才能正常运行。如果您有关于应用程序与特定软件更新或 Service Pack 之间的依赖关系的问题,请与软件开发人员或相应的新闻组联系。

Windows Service Pack 具有累积性。因此,在一个 Service Pack 中修复的问题在以后的 Service Pack 中也会被修复。要确定软件更新是否包含在 Service Pack 中,请检查“添加或删除程序”列表。安装了 Service Pack 后,最新安装的 Windows Service Pack 中所含的软件更新将不会出现在“添加或删除程序”列表中,因为 Service Pack 安装会从列表中删除这些项。

您还可以查看以下知识库文章,以确定软件更新是否包含在特定的 Windows Service Pack 中:
811113 Windows XP Service Pack 2 中包含的修补程序的列表
324720 Windows XP Service Pack 1 和 Windows XP Service Pack 1a 中的修补程序的列表
327194 Windows 2000 Service Pack 4 中修复的错误的列表
320853 Windows 2000 Service Pack 3 中修复的错误的列表

方案示例

方案 1
  1. 在计算机上安装 Windows 2000 Service Pack 3 (SP3)。
  2. 安装 Service Pack 4 (SP4) 之后的软件更新。
  3. 安装 Windows 2000 SP4。

    注意:Service Pack 安装会对软件更新执行版本检查。不会替换更高版本的软件更新文件。
  4. 后来您删除了 Windows 2000 SP4 之后的软件更新。
软件更新删除进程用软件更新卸载文件夹中的文件替换了操作系统目录中的相应文件。卸载文件夹是在软件更新安装之时创建的。这些文件是 Windows 2000 SP4 之前的版本。此过程可能会导致这些文件与其他操作系统文件之间的不匹配。因此,Windows 可能会停止工作。
方案 2
  1. 在计算机上安装 Windows XP 软件更新 828274。
  2. 安装 Windows XP 软件更新 820128。
  3. 后来您删除了 Windows XP 软件更新 828274。
软件更新 828274 更新内核文件。软件更新 820128 不仅更新内核文件,还更新 Services.exe。软件更新 820128 不更新 Ntdll.dll。在删除软件更新 828274 时,将会用目录的卸载文件夹中的原始文件替换操作系统目录中的内核文件。此过程可能会导致文件不匹配,因为原始的内核文件需要的 Services.exe 和 Ntdll.dll 版本可能不同于当前系统中软件更新 820128 所提供的文件版本。这种不匹配可能会导致 Windows 行为异常或停止工作。

注意:我们不支持这些方案。我们建议您不要删除软件更新。

参考

有关用来描述 Microsoft 软件更新、工具和加载项的标准术语的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
824684 有关用于描述 Microsoft 软件更新的标准术语的介绍
有关 Windows 和 Windows 组件的软件包安装程序 Update.exe 的更多信息,请查看位于以下 Microsoft 网站的“深入了解 Update.exe - Windows 和 Windows 组件的软件包安装程序”白皮书:
http://www.microsoft.com/technet/prodtechnol/windowsserver2003/deployment/winupdte.mspx

属性

文章编号: 823836 - 最后修改: 2007年6月1日 - 修订: 5.5
这篇文章中的信息适用于:
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Professional SP1a
  • Microsoft Windows XP Professional SP2
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Home Edition SP1a
  • Microsoft Windows XP Home Edition SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional SP4
关键字:?
kbsetup kbenv kbtshoot kbprb kberrmsg kbnofix kbbug KB823836
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com