Fehler beim Versuch, über HTTPS auf eine Website zuzugreifen: Seite kann nicht angezeigt werden

In diesem Artikel erfahren Sie, wie Sie den Fehler (Seite kann nicht angezeigt werden) beheben, der auftritt, wenn Sie versuchen, mithilfe von Hypertext Transfer Protocol Secure (HTTPS) auf eine Website zuzugreifen.

Ursprüngliche Produktversion: Internetinformationsdienste
Ursprüngliche KB-Nummer: 824035

Symptome

Wenn Sie versuchen, auf eine Website zuzugreifen, die in Microsoft-Internetinformationsdienste (IIS) gehostet wird und für die Verwendung von Secure Sockets Layer (SSL) mithilfe des HTTPS-Protokolls konfiguriert ist, wird möglicherweise die folgende Fehlermeldung angezeigt:

Seite kann nicht angezeigt werden

Die folgende Fehlermeldung wird in den Webserverereignisprotokollen protokolliert:

Ereignistyp:Fehler

Ereignisquelle:Schannel
Ereigniskategorie:None Ereignis-ID:36869
Datum:12/18/2000
Zeit:9:12:46 AM
Benutzer: n/v
Computer:<ServerName>
Beschreibung: Dem Zertifikat der SSL-Serveranmeldeinformationen ist keine Informationseigenschaft für den privaten Schlüssel angefügt. Dies tritt am häufigsten auf, wenn ein Zertifikat falsch gesichert und später wiederhergestellt wird. Diese Meldung kann auch auf einen Fehler bei der Zertifikatregistrierung hinweisen.

Ursache

Dieses Problem tritt auf, weil die Website an ein Zertifikat gebunden wurde, das nicht über einen übereinstimmenden privaten Schlüssel verfügt. Wenn Sie versuchen, dieses Zertifikat aus der Microsoft Management Console (MMC) zertifikate zu exportieren, können Sie den privaten Schlüssel nicht exportieren. Wenn Sie versuchen, das Zertifikat zu exportieren, erhalten Sie die folgende Warnmeldung:

#You HABEN KEINEN privaten Schlüssel, der diesem Zertifikat entspricht.

Lösung

Um das Problem zu beheben, erstellen Sie ein neues Zertifikat mit einem privaten Schlüssel. Gehen Sie dazu wie folgt vor:

  1. Entfernen Sie das aktuelle Zertifikat, das keinen privaten Schlüssel hat.

  2. Rufen Sie das neue Zertifikat ab, und installieren Sie es mit einem privaten Schlüssel.

Hinweis

Das ursprüngliche Zertifikat kann repariert werden (von dem Server, der das Zertifikat ursprünglich angefordert hat). Weitere Informationen zum Reparieren eines Zertifikats finden Sie unter Zuweisen eines privaten Schlüssels zu einem neuen Zertifikat, nachdem Sie das Zertifikat-Snap-In zum Löschen des ursprünglichen Zertifikats in Internetinformationsdienste verwendet haben.