Change Password Error Occurs When You Unlock a Computer

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Article ID: 824110 - View products that this article applies to.
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SYMPTOMS

When you try to unlock a Windows 2000-based computer, you may receive the following messages if you have the Microsoft NetWare client (CSNW) installed and configured to use a preferred server:
Netware Network
No NetWare NDS trees were detected, unable to perform change password operation.
You may then receive the following error message:
Netware Network
You may need to change your password separately on NetWare 2.X and 3.X servers that are not part of a password synchronization scheme. Use SETPASS (located in the SYS\\PUBLIC directory on NetWare servers) to do this.
If you are connecting to NetWare NDS, you may receive following message:
Change Password on NetWare
Select NetWare NDS tree to change password on for user
You may receive these error messages even when the password has not expired.

CAUSE

This problem occurs because your Windows 2000-based computer has the Microsoft NetWare client (CSNW) installed and the registry contains a ForceUnlockLogon value with a value of 1.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows 2000 Service Pack 3 installed to apply this hotfix.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   22-Jul-2003  17:24  5.0.2195.6789  333,072  Msgina.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
dialogs dialog boxes error errors

Properties

Article ID: 824110 - Last Review: October 26, 2006 - Revision: 1.7
APPLIES TO
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbsecurity kbqfe kbfix kbbug KB824110

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