Article ID: 824139 - Last Review: July 24, 2007 - Revision: 7.10

Domain Controller Loses Its Role as a Global Catalog Server

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SYMPTOMS

A Windows Server 2003 domain controller under a heavy load (stress) may no longer recognize itself as a global catalog server. The Windows locator service returns the domain controller as a global catalog server, but the global catalog component no longer works.

CAUSE

This problem occurs because the TCP/IP driver (Tcpip.sys) leaks a packet during transmission in the firewall-processing fast-path over the loopback interface. This effectively disables loopback over IP, even though remote transmission is still processed correctly.

Under a heavy load, the domain controller may no longer be able to contact DNS. Because of this, the Net Logon service does not register correctly, and the domain controller loses its role as a global catalog server.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer to apply the changes after you install this hotfix. However, you do not have to restart the computer immediately. To restart later, click to select the Do not restart now check box in the Windows Server 2003 Setup Wizard, and then click Finish.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, Standard Edition, and Windows Server 2003, Enterprise Edition

Date         Time   Version            Size    File name
--------------------------------------------------------
01-Aug-2003  17:08  5.2.3790.74       334,336  Tcpip.sys

Windows Server 2003, 64-Bit Enterprise Edition

Date         Time   Version            Size    File name
--------------------------------------------------------
01-Aug-2003  17:07  5.2.3790.74       969,728  Tcpip.sys

WORKAROUND

To work around this problem, restart the server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwinserv2003presp1fix KB824139
 

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