Secuencia de comandos que ejecuta un comando de WMIC se ejecuta lentamente y, al no, es especificar un valor de tiempo de espera personalizado para el modificador WMIC /FAILFAST

Seleccione idioma Seleccione idioma
Id. de artículo: 824223 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

En Microsoft Windows XP, al ejecutar una secuencia de comandos que contiene comandos de línea de comandos de Instrumental de administración de Microsoft Windows (WMIC) que se emiten a los equipos de destino, la secuencia de comandos se ejecuta despacio y puede pausar durante varios minutos si el modificador WMIC /FAILFAST está establecido en ON (/ FAILFAST:ON).

En Microsoft Windows Server 2003, cuando ejecute una secuencia de comandos que contiene comandos WMIC se emiten a los equipos de destino, no cambie el valor de tiempo de espera cinco segundos predeterminado para el nodo de destino para responder a una solicitud de ping. Por ejemplo, desea cambiar el valor de tiempo de espera de ping si tiene equipos que deben responder a través de vínculos (WAN) de red lenta de área extensa. O bien, si tiene una red de alta velocidad, es posible que desee modificar el valor de tiempo de espera de ping porque no desea esperar cinco segundos para el tiempo de espera de ping si el nodo de destino no está disponible.

Causa

Este problema se produce en Windows XP porque, si el /FailFast Cambiar conjunto en ON, los comandos de WMIC no intente hacer ping en el nodo de destino para ver si el destino está disponible. En su lugar, WMIC recupera información de host (mediante el método gethostbyname o el método gethostbyaddr ) acerca del objetivo sólo de un proveedor de servicio de nombre, como Sistema de nombres de dominio (DNS) o el servicio de nombres Internet de Windows (WINS). Si se resuelve el nombre de host, el comando WMIC se intenta incluso si el nodo de destino no está disponible. Este proceso provoca retrasos en la salida del comando.

En Windows Server 2003, cuando cambia de un comando WMIC con el /FailFast cambiar emitido establecido en ON, se envía un ping al nodo de destino. Sin embargo, si no se recibe una respuesta dentro de cinco segundos, se anula el resto del comando.

Solución

Windows XP

Información de Service Pack

Para resolver este problema, obtenga el Service Pack más reciente para Windows XP. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP

Información de revisiones

Requisitos previos

Para aplicar este hotfix, debe tener instalado en el equipo Windows XP Service Pack 1 (SP1).

Requisito de reinicio

No es necesario reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
WMIC.exe5.1.2600.1251329,72824-Jul-200303: 24x 86

Windows Server 2003

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

No es necesario reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows Server 2003, versiones basadas en 86 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
WMIC.exe5.1.3603.0346,62424-Jul-200303: 54x 86
Windows Server 2003, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
WMIC.exe5.1.3603.01,084,41624-Jul-200300: 55IA-64

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Windows XP Este problema se corrigió por primera vez en el Service Pack 2 de Microsoft Windows XP.

Más información

La utilidad WMIC (WMIC.exe), se utiliza para obtener acceso a Instrumental de administración de Windows (WMI). Antes de este hotfix, el modificador WMIC /FAILFAST acepta sólo dos valores: ON y OFF.

Después de instalar esta revisión, también puede especificar un valor de tiempo de espera personalizado (en milisegundos) para utilizar el modificador /FailFast. Si especifica un valor de tiempo de espera más corto, comandos de WMIC no tienen que esperar como long para un nodo de destino al responder al comando ping que emite un comando de WMIC. Por ejemplo, puede utilizar /FAILFAST:1000 para dar el nodo de destino sólo un segundo a responder a la solicitud de ping.

El nuevo formato para este modificador es como sigue:

/ FAILFAST: {ON|OFF| milliseconds}
Ejemplos: / FAILFAST:ON o / FAILFAST: OFF o / FAILFAST:1000 .

Para obtener información adicional acerca de WMIC, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
290216Descripción de la instrumentación de administración de Windows (WMI) utilidad de línea de comandos (WMIC.exe)

Propiedades

Id. de artículo: 824223 - Última revisión: domingo, 04 de noviembre de 2007 - Versión: 8.10
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbbug kbfix kbqfe kbwinserv2003presp1fix KB824223 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 824223

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com