Jak pominąć okno dialogowe Konwertowanie/Otwieranie bazy danych podczas otwierania bazy danych programu Access 97

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 824260 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko
Informacje zawarte w tym artykule dotyczą tylko bazy danych programu Microsoft Access (.mdb).

Poziom średni: wymaga podstawowej znajomość makr, pisania kodu i zagadnień związanych ze współdziałaniem.
Wersja tego artykułu dla programu Microsoft Access 2002 290291.
Wersja tego artykułu dla programu Microsoft Access 2002 275164.

Ważne: Ten artykuł zawiera informacje na temat modyfikowania rejestru. Przed edycją rejestru należy utworzyć jego kopię zapasową i upewnić się, że zna się metodę przywracania rejestru w przypadku pojawienia się problemu. Aby uzyskać informacje dotyczące wykonywania kopii zapasowej, przywracania i edytowania rejestru, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
256986 Opis rejestru systemu Microsoft Windows

Streszczenie

Podczas otwierania bazy danych programu Microsoft Access 97 przy użyciu programu Access 2003 pojawia się okno dialogowe Konwertowanie/Otwieranie bazy danych. Wyświetlanie okna dialogowego Konwertowanie/Otwieranie bazy danych można jednak pominąć. W tym celu trzeba dodać wpis rejestru
NoConvertDialog
do podklucza
Settings
Access w rejestrze. To ustawienie nie zapobiega konwersji. Zapobiega ono tylko początkowemu wyświetlaniu okna dialogowego Konwertowanie/Otwieranie bazy danych podczas otwierania bazy danych.

Uwaga Program Access 2003 nie wyświetla okna dialogowego Konwertowanie/Otwieranie bazy danych podczas otwierania bazy danych w formacie pliku programu Microsoft Access 2000.

Więcej informacji

Podklucz
NoConvertDialog
określa, czy pojawia się okno dialogowe Konwertowanie/Otwieranie bazy danych. Aby dodać podklucz
NoConvertDialog
, wykonaj następujące kroki:

OSTRZEŻENIE: Nieprawidłowe korzystanie z Edytora rejestru może stać się przyczyną poważnych problemów, które spowodują, że konieczna będzie ponowna instalacja systemu operacyjnego. Firma Microsoft nie może zagwarantować, że rozwiązanie problemów spowodowanych niepoprawnym użyciem Edytora rejestru będzie możliwe. Używanie Edytora rejestru odbywa się na własną odpowiedzialność.
  1. Na pasku zadań kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  2. W oknie dialogowym Uruchamianie wpisz polecenie regedit, a następnie kliknij przycisk OK.
  3. W oknie Edytora rejestru zlokalizuj następujący klucz rejestru:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\11.0\Access\Settings\
  4. W menu Edycja wskaż polecenie Nowy, a następnie kliknij polecenie Wartość DWORD. Nadaj nowej wartości DWORD nazwę NoConvertDialog.
  5. W prawym okienku okna Edytora rejestru kliknij dwukrotnie wartość DWORD NoConvertDialog.
  6. W oknie dialogowym Edytowanie wartości DWORD kliknij opcję Dziesiętny w obszarze System.
  7. W polu Dane wartości wpisz 1, a następnie kliknij przycisk OK.

    Uwaga W przypadku ustawienia wartości 0 pojawia się okno dialogowe Konwertowanie/Otwieranie bazy danych.
  8. Zamknij Edytor rejestru.
  9. Uruchom program Microsoft Office Access 2003.
  10. W menu Plik kliknij polecenie Otwórz.
  11. Zlokalizuj bazę danych programu Access 97, a następnie ją otwórz.

    Zauważ, że baza danych otwiera się bez monitowania o jej otwarcie lub przekonwertowanie. Baza danych pozostaje w formacie pliku programu Access 97.
Aby przekonwertować bazę danych, wykonaj następujące kroki:
  1. W menu Narzędzia wskaż polecenie Narzędzia bazy danych, a następnie wskaż polecenie Konwertuj bazę danych.
  2. Kliknij jedną z następujących opcji:
    • Na format pliku programu Access 2002–2003
    • Na format pliku programu Access 2000
Włączenie lub wyłączenie tego podklucza rejestru można wymusić przez ustawienie zasad grupy. Jeśli istnieje odpowiednie ustawienie zasad grupy, wspomniane ustawienie rejestru jest ignorowane.

Włączenie lub wyłączenie zasad grupy można wymusić, używając konsoli zasad grupy. Aby to zrobić, wykonaj następujące czynności:
  1. Zainstaluj zestaw Microsoft Office 2003 Resource Kit.
  2. Na pasku zadań kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  3. W oknie dialogowym Uruchamianie wpisz polecenie gpedit.msc i w polu Otwórz kliknij przycisk OK.
  4. W konsoli Zasady grupy rozwiń gałąź Konfiguracja komputera w obszarze Zasady Komputer lokalny.
  5. Zaznacz węzeł Szablony administracyjne.
  6. W menu Akcja kliknij polecenie Dodaj/Usuń szablon.
  7. W oknie dialogowym Dodawanie/Usuwanie szablonów kliknij przycisk Dodaj.
  8. W oknie dialogowym Szablon zasad zlokalizuj pozycję ACCESS11.ADM na swoim komputerze, a następnie kliknij przycisk Otwórz.
  9. W oknie dialogowym Dodawanie/Usuwanie szablonów kliknij przycisk Zamknij.
  10. W konsoli Zasady grupy rozwiń gałąź Konfiguracja użytkownika w obszarze Zasady Komputer lokalny.
  11. Rozwiń węzeł Szablony administracyjne.
  12. Rozwiń węzeł Microsoft Office Access 2003, a następnie kliknij przycisk Różne.
  13. W prawym okienku kliknij dwukrotnie pozycję Nie monituj o konwertowanie starszych baz danych.
  14. W oknie dialogowym Nie monituj o konwertowanie starszych baz danych: Właściwości kliknij pole Włączone na karcie Zasady. Zaznacz pole wyboru Zaznacz, aby wymusić włączenie ustawienia; usuń zaznaczenie, aby wymusić wyłączenie ustawienia.
  15. Kliknij przycisk Zastosuj, a następnie kliknij przycisk OK.

Uwaga W przypadku użycia konsoli zasad grupy zmiany są dokonywane w ustawieniach zasad przez następujący podklucz rejestru:

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\11.0\Access\Settings


Uwaga Ustawienie NoConvertDialog jest przeznaczone do blokowania tylko okna dialogowego Konwertowanie/Otwieranie bazy danych. Po dodaniu klucza rejestru nadal uzyskuje się następujący komunikat o błędzie:
Nie można dokonać zmian obiektów bazy danych w bazie danych „<nazwa bazy danych>”. Baza danych była utworzona we wcześniejszej wersji programu Microsoft Office Access. Aby dokonać konwersji tej bazy danych do bieżącej wersji programu Microsoft Office Access, zamknij bazę danych, wskaż polecenie Narzędzia bazy danych w menu Narzędzia, a następnie kliknij polecenie Konwertuj bazę danych.
Przed programami Access 2002 z dodatkiem Service Pack 3 oraz Access 2003 z dodatkiem Service Pack 1 poprzedni komunikat o błędzie był wyłączany w niezamierzony sposób. Aby zapobiec pojawianiu się poprzedniego komunikatu, można dodać formularz startowy do bazy danych Access 97.

Materiały referencyjne

Aby uzyskać więcej informacji dotyczących wielu formatów plików w programie Access 2003, kliknij polecenie Microsoft Office Access - Pomoc w menu Pomoc, wpisz frazę informacje dotyczące używania pliku programu Access z wieloma wersjami programu Access w polu Wyszukaj w okienku Asystenta, a następnie kliknij łącze Rozpocznij wyszukiwanie, aby wyświetlić żądany temat.

Aby uzyskać więcej informacji na temat zestawu Microsoft Office 2003 Resource Kit, odwiedź następującą witrynę Microsoft:
http://www.microsoft.com/office/ork/2003/default.htm

Właściwości

Numer ID artykułu: 824260 - Ostatnia weryfikacja: 14 lutego 2006 - Weryfikacja: 3.1
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Access 2003
Słowa kluczowe: 
kbgrppolicyinfo kbdatabase kbconvert kbregistry kbhowto KB824260

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com