La pantalla del equipo no se puede volver a dibujar correctamente si se mueve la ventana secundaria de una ventana primaria translúcida

Seleccione idioma Seleccione idioma
Id. de artículo: 824337 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Si una aplicación contiene una ventana por capas traslúcida y la ventana por capas tiene una ventana movible secundaria, la pantalla no se pinta correctamente si cambia el contenido de la ventana secundaria. Este problema puede producirse cuando utiliza SetLayeredWindowAttributes Windows Graphics Device Interface (GDI) función o cuando se utiliza la propiedad TransparencyKey de Microsoft Windows Forms para establecer la opacidad y para establecer la clave de color de transparencia de la ventana por capas. Por ejemplo, si una ventana por capas contiene una vista de lista, puede aparecer la ventana por capas como si los encabezados de vista de lista o la lista no se desplaza correctamente y que la pantalla no vuelve a dibujarse correctamente.

Causa

El área de ventana secundaria no se ha invalidado correctamente la GDI.

Solución

Windows Server 2003

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
   Date         Time   Version            Size    File name     Platform
   ---------------------------------------------------------------------- 
   14-Jul-2003  18:01  5.2.3790.68     1,811,456  Win32k.sys    x86
   14-Jul-2003  17:56  5.2.3790.68     4,949,504  Win32k.sys    IA-64
   

Windows XP

Información de Service Pack

Para resolver este problema, obtenga el Service Pack más reciente para Windows XP. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP

Información de revisiones

Requisitos previos

Para aplicar este hotfix, debe tener Windows XP Service Pack 1a (SP1a) instalado en el equipo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
   Date         Time   Version         Size       File name    Platform
   ---------------------------------------------------------------------
   23-Jul-2003  21:18  5.1.2600.1251   1,677,056  Win32k.sys   x86   
   23-Jul-2003  21:18  5.1.2600.1251   5,619,968  Win32k.sys   IA-64   

Windows 2000

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener instalado en el equipo Windows 2000 Service Pack 3 (SP3).

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   23-Jul-2003  00:55  5.0.2195.6738      42,256  Basesrv.dll      
   17-Jan-2003  17:06  5.0.2195.6656     236,304  Cmd.exe          
   23-Jul-2003  00:55  5.0.2195.6762     222,992  Gdi32.dll        
   23-Jul-2003  00:55  5.0.2195.6741     711,440  Kernel32.dll     
   23-Jul-2003  00:55  5.0.2195.6789     333,072  Msgina.dll       
   08-Apr-2003  06:54  5.0.2195.6701      90,232  Rdpwd.sys
   15-Jul-2003  23:08  5.0.2195.6776   4,858,368  Sp3res.dll       
   23-Jul-2003  00:55  5.0.2195.6785     380,176  User32.dll       
   23-Jul-2003  00:55  5.0.2195.6788     385,808  Userenv.dll      
   23-Jul-2003  00:32  5.0.2195.6790   1,628,912  Win32k.sys
   17-Jul-2003  18:20  5.0.2195.6785     182,032  Winlogon.exe     
   23-Jul-2003  00:55  5.0.2195.6775     243,984  Winsrv.dll       
   23-Jul-2003  00:55  5.0.2195.6741     711,440  Kernel32.dll     
   23-Jul-2003  00:55  5.0.2195.6790   1,628,912  Win32k.sys
   23-Jul-2003  00:55  5.0.2195.6775     243,984  Winsrv.dll     

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en el Service Pack 2 de Microsoft Windows XP.

Más información

Para obtener información adicional acerca de la GDI SetLayeredWindowAttributes función, visite el siguiente sitio Web de Microsoft Developer Network (MSDN) y, a continuación, busque SetLayeredWindowAttributes :
http://msdn.microsoft.com
Para obtener información adicional acerca de cómo se denominan los paquetes de revisión, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura de archivos para los paquetes de actualización de software de Microsoft Windows
Para obtener información adicional acerca software actualización terminología, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Terminología utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 824337 - Última revisión: domingo, 04 de noviembre de 2007 - Versión: 6.11
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbwinxpsp2fix kbwin2000presp5fix kbwinxppresp2fix kbbug kbfix kbqfe kbwinserv2003presp1fix KB824337 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 824337

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com