Zlepšené hlášení zpráv s ID události 61 umožňující určení tiskové fronty nebo tiskového zařízení

Překlady článku Překlady článku
ID článku: 824339 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Obdržíte-li zprávu s ID události 61 týkající se tisku, je možné, že nebudete moci určit tiskovou frontu nebo tiskové zařízení, kde k dané chybě došlo, takže nebudete moci potíže odstranit. Například můžete v systémovém protokolu v Prohlížeči událostí obdržet zprávu s ID události 61, která se podobá následující:

Typ události: Chyba
Zdroj události: Tisk Kategorie události: Není k dispozici
ID události: 61
Datum: datum
Čas: čas
Uživatel: kód uživatele
Počítač: PRINTSERVER
Popis: Tisk dokumentu Tabulka.xls, který je vlastněn uživatelem USER25, se nezdařil. Kód chyby prostředí Win32 vrácený tiskovým procesorem: 3003 (0xbbb).ERROR_SPL_NO_STARTDOC

Příčina

K tomuto problému dochází proto, že chyba ohlášená zdrojovou součástí byla přepsána. Proto byla ohlášena pouze poslední chyba. Mohly být ohlášeny například následující chybové kódy prostředí Win32:
  • ERROR_SPL_NO_STARTDOC (3003)

    Tento chybový kód znamená, že nebylo vydáno volání StartDocPrinter. Obdržíte jej, pokud zařazovací služba tisku nemůže odeslat data na port. Tisková úloha je označena jako chybný tisk. V této situaci se zařazovací služba tisku opakovaně pokouší odesílat data, dokud uživatel úlohu nezruší. Jakmile uživatel zruší tiskovou úlohu, je chyba vrácená součástí pro sledování portů přepsána.
  • ERROR_SUCCESS (0)

    Tento chybový kód znamená, že operace byla úspěšně dokončena. Obdržíte jej, pokud zdrojová součást, například rozhraní GDI (Graphics Device Interface), vrátí chybu, avšak neuvede poslední chybu.

Řešení

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix dodávaná společností Microsoft. Tato oprava hotfix je však určená pouze k odstranění problému popsaného v tomto článku. Instalujte ji pouze v systémech, ve kterých dochází k tomuto konkrétnímu problému.

Pokud je k dispozici oprava hotfix ke stažení, na začátku tohoto článku znalostní báze Knowledge Base naleznete oddíl Hotfix download available (Oprava hotfix ke stažení). Není-li tato část uvedena, vyžádejte si tuto opravu hotfix od oddělení služeb zákazníkům a podpory společnosti Microsoft.

Poznámka: Máte-li jakékoli další dotazy nebo je-li třeba vyřešit nějaké potíže, je možné, že pro ně bude nutné vytvořit samostatný požadavek na služby. Další dotazy a žádosti o podporu, které se netýkají této konkrétní opravy hotfix, podléhají běžným sazbám za poskytnutí podpory. Úplný seznam telefonních čísel služeb technické podpory a péče o zákazníky společnosti Microsoft a možnost vytvoření samostatného požadavku na služby naleznete na tomto webu společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Ve formuláři Hotfix download available (Oprava hotfix ke stažení) jsou uvedeny jazyky, v nichž je oprava hotfix k dispozici. Pokud seznam neobsahuje váš jazyk, znamená to, že daná oprava hotfix v tomto jazyku není k dispozici.

Požadavky

Chcete-li nainstalovat tuto opravu hotfix, musíte používat systém Microsoft Windows 2000 Service Pack 3 (SP3).

Další informace o získání nejnovější aktualizace Windows 2000 Service Pack naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
260910 Jak získat nejnovější aktualizaci Service Pack pro systém Windows 2000

Požadavek na restartování

Po instalaci této opravy hotfix není nutné restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné další opravy hotfix.

Informace o souborech

Anglická verze této opravy hotfix má následující nebo vyšší atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Při zobrazení informací o souborech jsou data a čas převedeny na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo na panelu Datum a čas v okně Ovládací panely.
Windows 2000
   Datum      Čas     Verze          Velikost  Název souboru
   --------------------------------------------------------------
   17. 2. 2004  02:39   5.0.2195.6824     42 256  Basesrv.dll
   21. 9. 2003  00:45  5.0.2195.6824     236 304  Cmd.exe
   17. 2. 2004  02:39  0.2.0.1           138 000  Faxui.dll
   17. 2. 2004  02:39  5.0.2195.6897     222 992  Gdi32.dll
   17. 2. 2004  02:39  5.0.2195.6897    711 952  Kernel32.dll
   17. 2. 2004  02:39  5.0.2195.6895     252 688  Localspl.dll
   17. 2. 2004  02:39  5.0.2195.6824     54 032  Mpr.dll
   17. 2. 2004  02:39   5.0.2195.6895    334 608  Msgina.dll
   17. 2. 2004  02:39  5.0.2195.6892      90 264  Rdpwd.sys
   5. 2. 2004  20:18  5.0.2195.6896   5 869 056  Sp3res.dll
   17. 2. 2004  02:39  5.0.2195.6876      80 144  Spoolss.dll
   17. 2. 2004  02:39  5.0.2195.6891     380 688  User32.dll
   17. 2. 2004  02:39  5.0.2195.6891     391 952  Userenv.dll
   12. 2. 2004  00:53   5.0.2195.6897  1 630 256  Win32k.sys
   17. 2. 2004  02:39  5.0.2195.6824      87 312  Win32spl.dll
   11. 11. 2003  00:29  5.0.2195.6873     182 032  Winlogon.exe
   17. 2. 2004  02:39  5.0.2195.6884     243 984  Winsrv.dll
   17. 2. 2004  02:39  5.0.2195.6897    711 952  Kernel32.dll
   12. 2. 2004  00:53   5.0.2195.6897  1 630 256  Win32k.sys
   17. 2. 2004  02:39  5.0.2195.6884     243 984  Winsrv.dll       
Windows XP
   Datum      Čas     Verze          Velikost  Název souboru
   --------------------------------------------------------
   20. 2. 2004  07:01  5.1.2600.1346  257 536  Gdi32.dll
   20. 2. 2004  07:01  5.1.2600.1346  297 984  Localspl.dll
   20. 2. 2004  07:01  5.1.2600.1331     36 864  Mf3216.dll
   9. 1. 2004  10:46  5.4.1.0          6 656  Spmsg.dll
   12. 2. 2004  11:43  5.1.2600.1344    586 752  Xpsp2res.dll
   9. 1. 2004  17:11  5.4.1.0        140 800  Spuninst.exe  

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

Po instalaci této opravy hotfix obdržíte následující zprávu s ID události 6161:

Typ události: Chyba
Zdroj události: Tisk
Kategorie události: Není k dispozici
ID události: 6161
Datum: datum
Čas: čas
Uživatel: kód uživatele
Počítač: PRINTSERVER
Popis: Tisk dokumentu PCL5c Metafile Document (vlastník: jméno_uživatele) na tiskárně název_tiskárny se nezdařil. Datový typ: NT EMF 1.008. Velikost zařazeného souboru (bajty): 0. Počet vytištěných bajtů: 0. Celkový počet stran v dokumentu: 0. Počet vytištěných stran: 0. Klientský počítač: název_počítače. Kód chyby Win32, vrácený tiskovým procesorem: 259.

Po instalaci této opravy hotfix zpráva o události přesněji popisuje dané potíže. Zpráva o události může uvádět jednu z následujících chyb:
  • ERROR_NOT_CONNECTED (2250)

    Tento chybový kód znamená, že dané síťové připojení neexistuje. Můžete jej obdržet, pokud zařazovací služba nemůže kontaktovat síťové tiskové zařízení. Je třeba odstranit potíže s připojením.
  • ERROR_NOT_ENOUGH_MEMORY (8)

    Tento chybový kód znamená, že počítač nemohl přidělit paměť. Tyto potíže lze často vyřešit zvětšením stránkovacího souboru.
  • ERROR_NO_MORE_ITEMS (259)

    Tento chybový kód znamená, že nejsou k dispozici žádná další data. Můžete jej obdržet, pokud program nebo součást ovladače tiskárny odešle do zařazovací služby tisku na tiskovém serveru neúplný zařazený soubor. Soubor se proto nevytiskne. Tyto potíže lze často vyřešit instalací ovladače z disku CD-ROM operačního systému.
  • ERROR_INVALID_PARAMETER (87)

    Tento chybový kód znamená, že parametr není platný. Tato chyba se obtížně diagnostikuje, pokud problém nereprodukujete. Tyto potíže lze často vyřešit instalací ovladače z disku CD-ROM operačního systému.
  • ERROR_SUCCESS (0)

    Tento chybový kód znamená, že operace byla úspěšně dokončena. Můžete jej obdržet, pokud zdrojová součást, například rozhraní GDI, vrátí chybu, avšak neuvede poslední chybu. Tato chyba se obtížně diagnostikuje, pokud problém nereprodukujete. Tyto potíže lze často vyřešit instalací ovladače z disku CD-ROM operačního systému.
Další informace o přidělování názvů balíčkům s opravami hotfix naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
816915 Nové schéma názvů souborů pro balíčky aktualizace softwaru pro systém Microsoft Windows
Další informace naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 824339 - Poslední aktualizace: 1. prosince 2008 - Revize: 4.4
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Klíčová slova: 
kbautohotfix kbhotfixserver kbeventlog kbprint kbbug kbfix kbqfe kbwin2000presp5fix KB824339

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com