Segnalazione migliorata dei messaggi relativi all'ID evento 61 per identificare una coda di stampa o una stampante

Traduzione articoli Traduzione articoli
Identificativo articolo: 824339 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando viene visualizzato un messaggio relativo all'ID evento 61, potrebbe risultare impossibile determinare quale coda di stampa, quale stampante o quale errore specifico si sia verificato per consentire la risoluzione del problema. Ad esempio, Ŕ possibile che nel registro degli eventi di sistema nel Visualizzatore eventi venga riportato un messaggio relativo all'ID evento 61 analogo al seguente:

Tipo evento: Errore
Origine evento: Stampa Categoria evento: Nessuno
ID evento: 61
Data: data
Ora: ora
Utente: codice utente
Computer: PRINTSERVER
Descrizione: Impossibile stampare il documento Foglio_di_calcolo.xls di proprietÓ di UTENTE25. Il processore di stampa ha restituito il seguente codice di errore Win32: 3003 (0xbbb).ERROR_SPL_NO_STARTDOC

Cause

Questo problema si verifica poichÚ l'errore segnalato dal componente sottostante Ŕ stato sovrascritto e quindi viene riconosciuto solo l'ultimo errore segnalato. Ad esempio, Ŕ possibile che siano stati segnalati i seguenti codici di errore Win32:
  • ERROR_SPL_NO_STARTDOC (3003)

    Questo codice di errore significa che non Ŕ stata effettuata una chiamata StartDocPrinter e viene visualizzato quando lo spooler di stampa non Ŕ in grado di inviare dati alla porta. Il processo di stampa viene contrassegnato come "errore durante la stampa". In questo caso lo spooler di stampa tenta ripetutamente di inviare i dati finchÚ il processo non viene annullato dall'utente. Quando viene effettuata questa operazione, l'errore restituito dal componente di monitoraggio della porta viene sovrascritto.
  • ERROR_SUCCESS (0)

    Questo codice di errore significa che l'operazione Ŕ stata completata e viene visualizzato quando un componente sottostante, ad esempio un'interfaccia GDI (Graphics Device Interface), restituisce un errore senza impostare l'ultimo errore.

Risoluzione

Informazioni sull'hotfix

╚ disponibile un hotfix supportato da Microsoft, che Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicarlo solo ai sistemi in cui si verifica questo problema specifico. ╚ possibile che su questo hotfix vengano eseguite ulteriori verifiche. Se pertanto questo problema non causa gravi difficoltÓ, si consiglia di attendere la versione successiva del service pack di Windows XP contenente tale hotfix.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'hotfix. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota In casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverÓ il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

Prerequisiti

Per installare questo hotfix Ŕ necessario che nel computer sia installato Microsoft Windows 2000 Service Pack 3 (SP3) o versione successiva.

Per ulteriori informazioni su come ottenere il service pack pi¨ recente per Windows 2000, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
260910 Acquisizione della versione pi¨ recente del service pack di Windows 2000

Richiesta di riavvio

Non Ŕ necessario riavviare il computer una volta applicato l'hotfix.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sui file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
Windows 2000
   Data        Ora    Versione       Dimensione  Nome file
   ----------------------------------------------------------
   17/02/2004  02.39  5.0.2195.6824      42.256  Basesrv.dll      
   21/09/2003  00.45  5.0.2195.6824     236.304  Cmd.exe         
   17/02/2004  02.39  0.2.0.1           138.000  Faxui.dll        
   17/02/2004  02.39  5.0.2195.6824     222.992  Gdi32.dll
   17/02/2004  02.39  5.0.2195.6897     711.952  Kernel32.dll     
   17/02/2004  02.39  5.0.2195.6895     252.688  Localspl.dll
   17/02/2004  02.39  5.0.2195.6824      54.032  Mpr.dll          
   17/02/2004  02.39  5.0.2195.6895     334.608  Msgina.dll       
   17/02/2004  02.39  5.0.2195.6892      90.264  Rdpwd.sys
   05/02/2004  20.18  5.0.2195.6896   5.869.056  Sp3res.dll       
   17/02/2004  02.39  5.0.2195.6876      80.144  Spoolss.dll      
   17/02/2004  02.39  5.0.2195.6891     380.688  User32.dll       
   17/02/2004  02.39  5.0.2195.6891     391.952  Userenv.dll      
   12/02/2004  00.53  5.0.2195.6897   1.630.256  Win32k.sys
   17/02/2004  02.39  5.0.2195.6824      87.312  Win32spl.dll     
   11/11/2003  00.29  5.0.2195.6873     182.032  Winlogon.exe
   17/02/2004  02.39  5.0.2195.6884     243.984  Winsrv.dll       
   17/02/2004  02.39  5.0.2195.6897     711.952  Kernel32.dll     
   12/02/2004  00.53  5.0.2195.6897   1.630.256  Win32k.sys
   17/02/2004  02.39  5.0.2195.6884     243.984  Winsrv.dll
Windows XP
   Data        Ora    Versione       Dimensione  Nome file
   ----------------------------------------------------------
   20/02/2004  07.01  5.1.2600.1346     257.536  Gdi32.dll
   20/02/2004  07.01  5.1.2600.1346     297.984  Localspl.dll
   20/02/2004  07.01  5.1.2600.1331      36.864  Mf3216.dll
   09/01/2004  10.46  5.4.1.0             6.656  Spmsg.dll
   12/02/2004  11.43  5.1.2600.1344     586.752  Xpsp2res.dll
   09/01/2004  17.11  5.4.1.0           140.800  Spuninst.exe

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Le informazioni in questo articolo si applicano a" del presente articolo.

Informazioni

Dopo l'installazione di questo hotfix, viene visualizzato il seguente messaggio relativo all'ID evento 6161:

Tipo evento: Errore
Origine evento: Stampa
Categoria evento: Nessuno
ID evento: 6161
Data: data
Ora: ora
Utente: codice utente
Computer: PRINTSERVER
Descrizione: Impossibile stampare il documento Documento metafile PCL5c di proprietÓ di nomeutente dalla stampante NomeStampante. Tipo dati: NT EMF 1.008. Dimensione del file di spooling in byte: 0. Numero di byte stampati: 0. Numero totale pagine nel documento: 0. Numero pagine stampate: 0. Computer client: nomecomputer. Il processore di stampa ha restituito il seguente codice di errore Win32: 259.

Dopo l'installazione dell'hotfix, il problema effettivo viene specificato con maggiore esattezza nel messaggio dell'evento. ╚ possibile che nel messaggio dell'evento venga indicato uno degli errori analoghi ai seguenti:
  • ERROR_NOT_CONNECTED (2250)

    Questo codice di errore significa che la connessione di rete non Ŕ disponibile e potrebbe essere visualizzato quando lo spooler non Ŕ in grado di contattare la stampante di rete. ╚ necessario risolvere il problema di connettivitÓ.
  • ERROR_NOT_ENOUGH_MEMORY (8)

    Questo codice di errore significa che non Ŕ stato possibile allocare memoria. Spesso il problema pu˛ essere risolto aumentando le dimensioni del file di paging.
  • ERROR_NO_MORE_ITEMS (259)

    Questo codice di errore significa che non vi sono pi¨ dati disponibili. L'invio di un file di spooling incompleto da un programma o da un componente del driver della stampante allo spooler di stampa sul server di stampa pu˛ causare la visualizzazione di questo codice di errore e quindi il file non viene stampato. Spesso Ŕ possibile risolvere questo problema mediante l'installazione del driver dal CD del sistema operativo.
  • ERROR_INVALID_PARAMETER (87)

    Questo codice di errore significa che il parametro non Ŕ valido. Si tratta di un errore difficile da diagnosticare, a meno di riprodurre il problema. Spesso Ŕ possibile risolvere questo problema mediante l'installazione del driver dal CD del sistema operativo.
  • ERROR_SUCCESS (0)

    Questo codice di errore significa che l'operazione Ŕ stata completata e potrebbe essere visualizzato quando un componente sottostante, ad esempio un'interfaccia GDI, restituisce un errore senza impostare l'ultimo errore. Si tratta di un errore difficile da diagnosticare, a meno di riprodurre il problema. Spesso Ŕ possibile risolvere questo problema mediante l'installazione del driver dal CD del sistema operativo.
Per ulteriori informazioni sulla denominazione degli hotfix, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
816915 Nuovo schema di assegnazione dei nomi per i pacchetti di soluzioni rapide di Microsoft Windows
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

ProprietÓ

Identificativo articolo: 824339 - Ultima modifica: venerdý 23 marzo 2007 - Revisione: 4.1
Le informazioni in questo articolo si applicano a
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Chiavi:á
kbhotfixserver kbqfe kbeventlog kbprint kbbug kbfix kbqfe kbwin2000presp5fix KB824339
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com