Relatórios mais detalhados de mensagens de evento sobre a identificação de evento 61 para identificar uma fila de impressão ou dispositivo de impressão

Traduções deste artigo Traduções deste artigo
ID do artigo: 824339 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Ao receber uma mensagem de evento de impressão com identificação de evento 61, você pode não ser capaz de determinar qual fila de impressão, dispositivo de impressão ou erro específico ocorreu para solucionar o problema. Por exemplo, uma mensagem de evento com identificação 61 semelhante à seguinte mensagem de evento no log do sistema em Visualizar eventos:

Tipo de evento: Erro
Origem do evento: Categoria do evento de impressão: Nenhuma
Identificação do evento: 61
Data: data
Hora: hora
Usuário: código do usuário
Computador: PRINTSERVER
Descrição: A impressão do documento Spreadsheet.xls que pertence a USER25 falhou. Código de erro Win32 retornado pelo processador de impressão: 3003 (0xbbb).ERROR_SPL_NO_STARTDOC

Causa

Esse problema ocorre porque o erro que o componente subjacente reportou foi substituído. Por isso, apenas o último erro foi reportado. Por exemplo, os seguintes códigos de erro Win32 podem ter sido reportados:
  • ERROR_SPL_NO_STARTDOC (3003)

    Esse código de erro significa que uma chamada StartDocPrinter não foi emitida. Esse código de erro é exibido quando o spooler de impressão não pode enviar dados para a porta. O trabalho de impressão é marcado como "erro ao imprimir". Nessa situação, o spooler de impressão tenta repetidamente enviar os dados até que o usuário cancele o trabalho. O erro que o componente do monitor de porta retorna é substituído quando o usuário cancela o trabalho de impressão.
  • ERROR_SUCCESS (0)

    Esse código de erro significa que a operação foi concluída com êxito. Esse código de erro é exibido quando um componente subjacente como GDI (interface gráfica de dispositivo) retorna uma falha, mas não define o último erro.

Resolução

Informações sobre o hotfix

Um hotfix suportado foi disponibilizado pela Microsoft, porém destina-se somente a corrigir o problema descrito neste artigo. Aplique-o somente a sistemas que apresentarem esse problema específico. Testes adicionais poderão ser realizados nesse hotfix. Portanto, se esse problema não o afetar diretamente, a Microsoft recomenda que você aguarde o novo service pack do Windows XP que contenha essa correção.

Para resolver esse problema imediatamente, contate o Atendimento Microsoft para obter o hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e informações sobre os custos de suporte, visite o seguinte site da Microsoft:
http://www.microsoft.com/brasil/atendimento/fale_ms.asp
Observação Em alguns casos, as taxas cobradas pelas chamadas de suporte podem ser canceladas se um profissional de suporte da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem à atualização específica em questão.

Pré-requisitos

É necessário estar executando o Microsoft Windows 2000 Service Pack 3 (SP3) ou posterior para instalar esse hotfix.

Para obter informações adicionais sobre como obter o service pack mais recente para o Windows 2000, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
260910 Como obter o service pack mais recente do Windows 2000

Requisitos de reinicialização

Não é necessário reiniciar seu computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes

Informações sobre o arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na seguinte tabela. As datas e os horários desses arquivos estão relacionados em formato UTC (coordenadas de tempo universal). Ao visualizar as informações sobre o arquivo, elas são convertidas para a hora local. Para encontrar a diferença entre UTC e a hora local, use a guia Fuso horário na ferramenta Data e hora do Painel de controle.
Windows 2000
   Data         Hora      Versão       Tamanho    Nome do arquivo
   --------------------------------------------------------------
   17-fev-2004  02:39  5.0.2195.6824      42.256  Basesrv.dll      
   21-set-2003  00:45  5.0.2195.6824     236.304  Cmd.exe          
   17-fev-2004  02:39  0.2.0.1           138.000  Faxui.dll        
   17-fev-2004  02:39  5.0.2195.6897     222.992  Gdi32.dll        
   17-fev-2004  02:39  5.0.2195.6897     711.952  Kernel32.dll     
   17-fev-2004  02:39  5.0.2195.6895     252.688  Localspl.dll     
   17-fev-2004  02:39  5.0.2195.6824      54.032  Mpr.dll          
   17-fev-2004  02:39  5.0.2195.6895     334.608  Msgina.dll       
   17-fev-2004  02:39  5.0.2195.6892      90.264  Rdpwd.sys
   05-fev-2004  20:18  5.0.2195.6896   5.869.056  Sp3res.dll
   17-fev-2004  02:39  5.0.2195.6876      80.144  Spoolss.dll      
   17-fev-2004  02:39  5.0.2195.6891     380.688  User32.dll       
   17-fev-2004  02:39  5.0.2195.6891     391.952  Userenv.dll      
   12-fev-2004  00:53  5.0.2195.6897   1.630.256  Win32k.sys
   17-fev-2004  02:39  5.0.2195.6824      87.312  Win32spl.dll     
   11-nov-2003  00:29  5.0.2195.6873     182.032  Winlogon.exe     
   17-fev-2004  02:39  5.0.2195.6884     243.984  Winsrv.dll       
   17-fev-2004  02:39  5.0.2195.6897     711.952  Kernel32.dll     
   12-fev-2004  00:53  5.0.2195.6897   1.630.256  Win32k.sys
   17-fev-2004  02:39  5.0.2195.6884     243.984  Winsrv.dll       

Situação

A Microsoft confirmou que esse é um problema nos produtos da empresa que estão listados na seção "Aplica-se a".

Mais Informações

Após a instalação desse hotfix, a seguinte mensagem de evento com identificação 6161 é exibida:

Tipo de evento: Erro
Origem do evento: Impressão
Categoria do evento: Nenhuma
Identificação do evento: 6161
Data: data
Hora: hora
Usuário: código do usuário
Computador: PRINTSERVER
Descrição: O documento PCL5c Metafile Document de propriedade de nome de usuário não pôde ser impresso na impressora Nome da impressora. Tipo de dados: NT EMF 1.008. Tamanho do arquivo de spool em bytes: 0. Número de bytes impressos: 0. Número total de páginas do documento: 0. Número de páginas impressas: 0. Computador cliente: nome do computador. Código de erro Win32 retornado pelo processador de impressão: 259.

A mensagem de evento especifica com mais precisão o problema real após a instalação do hotfix. A mensagem de evento pode reportar um dos seguintes erros:
  • ERROR_NOT_CONNECTED (2250)

    Esse código de erro significa que essa conexão de rede não existe. Esse código de erro pode ser exibido quando o spooler não pode contatar o dispositivo da impressora de rede. É necessário solucionar o problema de conectividade.
  • ERROR_NOT_ENOUGH_MEMORY (8)

    Esse código de erro significa que o computador não foi capaz de alocar memória. Com freqüência, é possível resolver esse problema aumentando o tamanho de arquivo de página.
  • ERROR_NO_MORE_ITEMS (259)

    Esse código de erro significa que não existem mais dados disponíveis. Esse código de erro pode ser exibido se um componente de driver de um programa ou impressora envia um arquivo de spool incompleto para o spooler de impressão no servidor de impressão. Por isso, o arquivo não é impresso. Com freqüência, é possível resolver esse problema instalando o driver a partir do CD do sistema operacional.
  • ERROR_INVALID_PARAMETER (87)

    Esse código de erro significa que o parâmetro não é válido. Esse erro é difícil de diagnosticar a menos que você reproduza o problema. Com freqüência, é possível resolver esse problema instalando o driver a partir do CD do sistema operacional.
  • ERROR_SUCCESS (0)

    Esse código de erro significa que a operação foi concluída com êxito. Esse código de erro pode ser exibido se um componente subjacente como GDI retornar uma falha, mas não definir o último erro. Esse erro é difícil de diagnosticar a menos que você reproduza o problema. Com freqüência, é possível resolver esse problema instalando o driver a partir do CD do sistema operacional.
Para obter informações adicionais sobre como os pacotes de hotfix são nomeados, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
816915 Novo esquema para nomeação de arquivos para os pacotes de atualização de software do Microsoft Windows
Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
824684 Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft

Propriedades

ID do artigo: 824339 - Última revisão: quinta-feira, 13 de abril de 2006 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Palavras-chave: 
kbqfe kbhotfixserver kbeventlog kbprint kbbug kbfix kbqfe kbwin2000presp5fix KB824339

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com