REVISIÓN: La archivos temporales no se eliminan después de conectarse a un servidor que ejecuta Windows SharePoint Services o SharePoint Portal Server 2003

Seleccione idioma Seleccione idioma
Id. de artículo: 824629 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Cuando utiliza Microsoft Windows SharePoint Services o Microsoft Office SharePoint Portal Server 2003 y se conectan como un usuario anónimo o como cualquier cuenta con permisos que no son suficientes, puede observar que muchos archivos temporales se crean en la carpeta % temp % y nunca se eliminan. Esto hace que el servidor a quedarse finalmente espacio en disco. Esto puede hacer disminuir el rendimiento.

Causa

Esto está causado por un problema de suplantación en Microsoft .NET Framework 1.1 Code Document Object Model (CodeDOM). SharePoint utiliza el serializador de XML en .NET Framework. El serializador XML utiliza internamente el CodeDOM de .NET Framework y CodeDOM crea archivos temporales en la carpeta % temp %. CodeDOM utiliza suplantación para suplantar una cuenta que tenga acceso suficiente para crear los archivos temporales. Después de la compilación, CodeDOM invierte la suplantación y a continuación, intenta eliminar los archivos temporales. Al iniciar sesión en SharePoint Portal Server como un usuario anónimo, esta cuenta de usuario no tiene acceso para eliminar los archivos temporales.

Solución

Ahora hay disponible un hotfix para el que Microsoft proporciona soporte técnico, pero que sólo se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Este hotfix puede ser sometido a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, Microsoft recomienda que espere a que el siguiente Service Pack de Microsoft .NET Framework 1.1 que contenga este hotfix.

Para resolver este problema inmediatamente, descargue la revisión haciendo clic en el vínculo de descarga más adelante en este artículo o póngase en contacto con los servicios de soporte técnico de Microsoft para obtener la revisión. Para obtener una lista completa de los números de teléfono de servicios de soporte de técnico de Microsoft e información acerca de los costos de soporte, visite el siguiente sitio Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS
Nota en casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.
Los archivos siguientes están disponibles para descargarlos del Centro de descarga de Microsoft:
Contraer esta imagenAmpliar esta imagen
Download
Download the 824629 hotfix for Microsoft Windows Server 2003 package now.

Contraer esta imagenAmpliar esta imagen
Download
Download the 824629 hotfix for all other versions of Microsoft Windows package now.
Fecha de lanzamiento: 3 de septiembre de 2003

Para obtener información adicional acerca de cómo descargar los archivos de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
119591Cómo obtener Archivos de soporte técnico de Microsoft desde los servicios en línea
Microsoft exploró este archivo en busca de virus. con el software de detección de virus más reciente disponible en la fecha de publicación. Asimismo, el archivo se almacenó en servidores seguros que ayudan a impedir la realización de cambios no autorizados.
La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version            Size    File name                    Platform
   ------------------------------------------------------------------------------------
   30-Jul-2003  00:52  1.1.4322.929      253,952  Aspnet_isapi.dll             x86
   30-Jul-2003  00:52  1.1.4322.929       20,480  Aspnet_regiis.exe            x86
   30-Jul-2003  00:52  1.1.4322.929       32,768  Aspnet_wp.exe                x86
   28-Apr-1999  01:12  1.0.0.1            32,768  Installpersistsqlstate.sql
   15-May-2003  23:49                     34,150  Installsqlstate.sql
   30-Jul-2003  00:07  1.1.4322.929       94,208  Perfcounter.dll              x86
   31-Jul-2003  04:33  1.1.4322.929    1,216,512  System.dll                   x86
   31-Jul-2003  04:34  1.1.4322.929      323,584  System.runtime.remoting.dll  x86
   31-Jul-2003  04:31  1.1.4322.929    1,253,376  System.web.dll               x86
   31-Jul-2003  04:33  1.1.4322.929      819,200  System.web.mobile.dll        x86
   31-Jul-2003  04:32  1.1.4322.929      569,344  System.web.services.dll      x86
   31-Jul-2003  04:32  1.1.4322.929    1,335,296  System.xml.dll               x86
   30-Jul-2003  00:47                     14,472  Webuivalidation.js

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo.

Más información

Los síntomas que se describen en este artículo asociados con más frecuencia con Windows SharePoint Services o SharePoint Portal Server 2003. Las otras aplicaciones o servicios que utilizan una cuenta con permisos que no son suficientes y serializador de XML de .NET Framework 1.1 también pueden presentar este comportamiento.

Si instala este hotfix en un equipo que ejecuta Microsoft Windows Server 2003, se iniciará el servicio IISAdmin. No se cambia el comportamiento predeterminado del servicio. Por lo tanto, si el servicio IISAdmin se establece en manual, IISAdmin no se reiniciará cuando se restablece el servidor.

Propiedades

Id. de artículo: 824629 - Última revisión: viernes, 23 de febrero de 2007 - Versión: 4.7
La información de este artículo se refiere a:
  • Microsoft Office SharePoint Portal Server 2003
  • Microsoft .NET Framework 1.1
  • Microsoft Windows SharePoint Services
Palabras clave: 
kbmt kbdownload kbfix KB824629 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 824629

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com