HOW TO: Eseguire una query su due tabelle nello stesso database in FrontPage 2003

Traduzione articoli Traduzione articoli
Identificativo articolo: 825443 - Visualizza i prodotti a cui si riferisce l?articolo.
Per la versione di questo articolo relativa a Microsoft FrontPage 2002, vedere 318281.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo viene descritto un metodo che consente di eseguire una query e recuperare informazioni da due tabelle in un database di FrontPage 2003. Nell'esempio descritto in questo articolo vengono utilizzate istruzioni di Microsoft SQL per la ricerca di dati nelle tabelle Categorie e Prodotti del database di esempio Northwind corrispondenti a un valore specificato per una colonna utilizzata in entrambe le tabelle.

Creazione di una query per recuperare informazioni da due tabelle in un database

Per creare una pagina di ricerca e una pagina dei risultati per cercare e trovare valori particolari in due tabelle di un database, attenersi alla seguente procedura:
  1. Creare due nuove pagine denominate Search.asp e Results.asp. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Avviare FrontPage, se non è già stato avviato.
    2. Scegliere Nuovo dal menu File, quindi nel riquadro attività Nuovo fare clic su Pagina vuota.
    3. Scegliere Salva dal menu File.
    4. Specificare il percorso in cui si desidera salvare il file, digitare Search.asp nella casella Nome file, quindi scegliere Salva.
    5. Scegliere Nuovo dal menu File, quindi nel riquadro attività Nuovo fare clic su Pagina vuota.
    6. Scegliere Salva dal menu File.
    7. Specificare il percorso in cui si desidera salvare il file, digitare Results.asp nella casella Nome file, quindi scegliere Salva.
  2. Creare e configurare il modulo nella pagina di ricerca. A questo scopo, attenersi alla seguente procedura:
    1. In Elenco cartelle fare doppio clic su Search.asp per aprire la pagina.
    2. Scegliere Modulo dal menu Inserisci, quindi fare clic su Casella di testo.
    3. Nella pagina fare clic con il pulsante destro del mouse sulla casella di testo inserita, quindi scegliere Proprietà campo modulo.
    4. Nella casella Nome digitare ID, quindi scegliere OK.
    5. Nella pagina fare clic con il pulsante destro del mouse sulla casella di testo, quindi scegliere Proprietà modulo.
    6. In Utilizzo risultati scegliere Altre destinazioni, quindi fare clic su Script personalizzato ISAPI, NSAPI, CGI o ASP.
    7. Fare clic su Opzioni.
    8. Nella casella Azione digitare results.asp, quindi scegliere OK.
    9. Fare clic su Results.asp, quindi scegliere OK tre volte.
    10. Scegliere Salva dal menu File.
  3. Configurare la query sul database nella pagina dei risultati. A questo scopo, attenersi alla seguente procedura:
    1. In Elenco cartelle fare doppio clic su Results.asp per aprire la pagina.
    2. Scegliere Database dal menu Inserisci, quindi fare clic su Risultati.
    3. Fare clic su Utilizzare una connessione di database di esempio (Northwind), quindi scegliere Avanti.
    4. Fare clic su Query personalizzata, quindi scegliere Modifica.
    5. Digitare oppure copiare e incollare la riga seguente nella casella Istruzione SQL:
      Select * From Categorie,Prodotti Where Categorie.IDCategoria=::ID:: and Categorie.IDCategoria=Prodotti.IDCategoria
      Nota Con questa istruzione SQL vengono restituite tutte le colonne dalle tabelle Categorie e Prodotti in cui l'ID inviato dalla pagina Search.asp corrisponde a IDCategoria nella tabella Categorie e IDCategoria nella tabella Categorie corrisponde a IDCategoria nella tabella Prodotti.
    6. Scegliere OK.
    7. Scegliere Avanti tre volte.
    8. Fare clic su Visualizza tutti i record contemporaneamente, deselezionare la casella di controllo Aggiungi modulo di ricerca, quindi scegliere Fine.
    9. Scegliere Salva dal menu File.
  4. In Elenco cartelle fare doppio clic su Search.asp per aprire la pagina.
  5. Scegliere Visualizza anteprima nel browser dal menu File, quindi selezionare il browser che si desidera utilizzare.
  6. Nella casella di testo digitare 3, quindi scegliere Invia.

    Verranno restituite le colonne dalle tabelle Categorie e Prodotti contenenti il valore IDCategoria 3.

Riferimenti

Per ulteriori informazioni sulla Creazione guidata Area risultati database in FrontPage 2003, vedere la Guida in linea di FrontPage. A questo scopo, scegliere Guida in linea Microsoft Office FrontPage dal menu ?. Nella casella Cerca digitare risultati del database, quindi premere INVIO per visualizzare gli argomenti disponibili.

Per ulteriori informazioni su FrontPage, visitare il seguente sito Web Microsoft:
http://office.microsoft.com/it-it/frontpage/FX100743231040.aspx
Microsoft fornisce esempi di programmazione a scopo puramente illustrativo, senza alcuna garanzia di qualsiasi tipo, sia espressa che implicita, ivi incluse, senza limitazioni, le garanzie implicite di commerciabilità o idoneità per uno scopo particolare. In questo articolo si presume che l'utente conosca il linguaggio di programmazione in questione e gli strumenti utilizzati per creare ed eseguire il debug delle procedure. Gli esperti Microsoft sono autorizzati a fornire spiegazioni in merito alla funzionalità di una particolare procedura, ma in nessun caso a modificare questi esempi per fornire funzionalità aggiuntive o a creare procedure atte a soddisfare specifiche esigenze.

Proprietà

Identificativo articolo: 825443 - Ultima modifica: venerdì 21 settembre 2007 - Revisione: 4.3
Le informazioni in questo articolo si applicano a
  • Microsoft Office FrontPage 2003
Chiavi: 
kbhowto kbdownload KB825443
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com