JAK: Kierowanie kwerendy do dwóch tabel w tej samej bazie danych w programie FrontPage 2003

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 825443 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Wersja tego artykułu dla programu Microsoft FrontPage 2002: 318281.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

W tym artykule opisano metodę, której można użyć w celu utworzenia kwerendy pobierającej dane z dwóch tabel bazy danych w programie FrontPage 2003. W przykładzie omawianym w tym artykule wykorzystano instrukcje Microsoft SQL w celu wyszukania danych w tabelach Kategorie oraz Produkty z przykładowej bazy danych Northwind, pasujących do podanej wartości kolumny używanej w obu tabelach.

Jak utworzyć kwerendę pobierającą informacje z dwóch tabel bazy danych

Aby utworzyć stronę wyszukiwania oraz stronę wyników w celu odnalezienia konkretnych wartości w dwóch tabelach bazy danych, wykonaj następujące kroki:
  1. Utwórz dwie strony o nazwach Szukaj.asp oraz Wyniki.asp. W tym celu należy wykonać następujące kroki:
    1. Uruchom program FrontPage, jeżeli nie jest jeszcze uruchomiony.
    2. W menu Plik wskaż polecenie Nowy, a następnie w okienku zadań Nowy kliknij polecenie Pusta strona.
    3. W menu Plik kliknij polecenie Zapisz.
    4. Określ lokalizację, w której plik ma zostać zapisany, wpisz Szukaj.asp w polu Nazwa pliku, a następnie kliknij przycisk Zapisz.
    5. W menu Plik wskaż polecenie Nowy, a następnie w okienku zadań Nowy kliknij polecenie Pusta strona.
    6. W menu Plik kliknij polecenie Zapisz.
    7. Określ lokalizację, w której plik ma zostać zapisany, wpisz Wyniki.asp w polu Nazwa pliku, a następnie kliknij przycisk Zapisz.
  2. Utwórz i skonfiguruj formularz na stronie wyszukiwania. Aby to zrobić, wykonaj następujące kroki:
    1. W obszarze Lista folderów kliknij dwukrotnie plik Szukaj.asp, aby otworzyć stronę.
    2. W menu Wstaw wskaż polecenie Formularz, a następnie kliknij polecenie Pole tekstowe.
    3. Na stronie kliknij prawym przyciskiem myszy wstawione pole tekstowe, a następnie kliknij polecenie Właściwości pola formularza.
    4. W polu Nazwa wpisz ID, a następnie kliknij przycisk OK.
    5. Na stronie kliknij prawym przyciskiem myszy pole tekstowe, a następnie kliknij polecenie Właściwości formularza.
    6. W obszarze Gdzie przechowywać wyniki kliknij polecenie Wyślij do innej lokalizacji, a następnie kliknij polecenie Niestandardowy skrypt ISAPI, NSAPI, CGI lub ASP.
    7. Kliknij przycisk Opcje.
    8. W polu Akcja wpisz Wyniki.asp, a następnie kliknij przycisk OK.
    9. Kliknij pozycję Wyniki.asp, kliknij przycisk OK, kliknij przycisk OK, a następnie kliknij przycisk OK.
    10. W menu Plik kliknij polecenie Zapisz.
  3. Skonfiguruj kwerendę bazy danych na stronie wyszukiwania. Aby to zrobić, wykonaj następujące kroki:
    1. W obszarze Lista folderów kliknij dwukrotnie plik Wyniki.asp, aby otworzyć stronę.
    2. W menu Wstaw wskaż polecenie Baza danych, a następnie kliknij polecenie Wyniki.
    3. Kliknij opcję Użyj połączenia z przykładową bazą danych (Northwind), a następnie kliknij przycisk Dalej.
    4. Kliknij pozycję Kwerenda niestandardowa, a następnie kliknij przycisk Edytuj.
    5. Wpisz lub skopiuj następujący wiersz do pola Instrukcja SQL:
      Select * From Kategorie,Produkty Where Kategorie.IDkategorii=::ID:: and Categories.CategoryID=Products.CategoryID
      Uwaga Ta instrukcja SQL zwraca wszystkie kolumny z tabel Kategorie oraz Produkty, w których wartość ID wysłana ze strony Szukaj.asp pasuje do wartości IDkategorii w tabeli Kategorie, a wartość IDkategorii z tabeli Kategorie pasuje do wartości IDkategorii w tabeli Produkty.
    6. Kliknij przycisk OK.
    7. Trzy razy kliknij przycisk Dalej.
    8. Kliknij pole wyboru Wyświetl wszystkie rekordy razem, kliknij, aby wyczyścić, pole wyboru Dodaj formularz wyszukiwania, a następnie kliknij przycisk Zakończ.
    9. W menu Plik kliknij polecenie Zapisz.
  4. W obszarze Lista folderów kliknij dwukrotnie plik Szukaj.asp, aby otworzyć stronę.
  5. W menu Plik kliknij polecenie Podgląd w przeglądarce, a następnie kliknij przeglądarkę, której chcesz użyć.
  6. W polu tekstowym wpisz wartość 3, a następnie kliknij przycisk Prześlij.

    Z tabel Kategorie oraz Produkty zostaną zwrócone te kolumny, które zawierają wartość IDkategorii równą 3.

Materiały referencyjne

Więcej informacji na temat Kreatora wyników bazy danych w programie FrontPage 2003 można znaleźć w Pomocy programu FrontPage. W tym celu w menu Pomoc kliknij polecenie Microsoft Office FrontPage – Pomoc. W polu Wyszukaj wpisz wyniki bazy danych, a następnie nacisnąć klawisz ENTER, aby wyświetlić zwrócone tematy.

Więcej informacji dotyczących programu FrontPage można znaleźć w następującej witrynie firmy Microsoft w sieci Web:
http://office.microsoft.com/pl-pl/default.aspxen-us/frontpage/FX100743231033.aspx
Firma Microsoft podaje przykłady programowania tylko dla celów ilustracyjnych, nie udzielając żadnej rękojmi, wyrażonej wprost ani dorozumianej, w tym także, bez ograniczeń, ustawowej rękojmi co do przydatności handlowej lub do określonych celów. W tym artykule zakłada się, że czytelnik zna demonstrowany język programowania oraz narzędzia używane do tworzenia i debugowania procedur. Wykwalifikowani pracownicy Pomocy technicznej firmy Microsoft mogą pomóc w wyjaśnieniu, jak działa określona procedura, ale nie będą modyfikować tych przykładów w celu dodania jakichś funkcji ani konstruować nowych procedur w celu dostosowania ich do potrzeb użytkownika.

Właściwości

Numer ID artykułu: 825443 - Ostatnia weryfikacja: 30 marca 2007 - Weryfikacja: 4.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office FrontPage 2003
Słowa kluczowe: 
kbdownload kbhowto KB825443

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com