JAK: Tworzenie niestandardowych hiperłączy za pomocą arkuszy stylów kaskadowych w programie FrontPage 2003

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 825450 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Wersja tego artykułu dla programu Microsoft FrontPage 2002: 287706.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

W tym artykule opisano, jak tworzyć niestandardowe hiperłącza, używając arkuszy stylów kaskadowych (CSS) w programie Microsoft Office FrontPage 2003. Ten artykuł zawiera przykłady, które przedstawiają, jak wykorzystywać funkcje arkuszy stylów kaskadowych do tworzenia niestandardowych łączy.

Uwaga Ten artykuł wykorzystuje funkcje kaskadowego arkusza stylów, które mogą nie być obsługiwane przez przeglądarki. Więcej informacji można znaleźć w Pomocy programu FrontPage. W tym celu w menu Pomoc kliknij polecenie Microsoft FrontPage – Pomoc, wpisz arkusze stylów kaskadowych w polu Wyszukaj, a następnie naciśnij klawisz ENTER, aby obejrzeć zwrócone tematy.

Tworzenie niestandardowych hiperłączy za pomocą kaskadowych arkuszy stylów

Poniżej przedstawiono przykłady tworzenia niestandardowych hiperłączy za pomocą funkcji kaskadowych arkuszy stylów:

Firma Microsoft podaje przykłady programowania tylko dla celów ilustracyjnych, nie udzielając żadnej rękojmi, wyrażonej wprost ani dorozumianej, w tym także, bez ograniczeń, ustawowej rękojmi co do przydatności handlowej lub do określonych celów. W tym artykule zakłada się, że czytelnik zna demonstrowany język programowania oraz narzędzia używane do tworzenia i debugowania procedur. Wykwalifikowani pracownicy Pomocy technicznej firmy Microsoft mogą pomóc w wyjaśnieniu, jak działa określona procedura, ale nie będą modyfikować tych przykładów w celu dodania jakichś funkcji ani konstruować nowych procedur w celu dostosowania ich do potrzeb użytkownika. Uwaga Jeśli przykłady z tego artykułu zostaną skopiowane i bezpośrednio wklejone do programu FrontPage, to się może pojawić komunikat o błędzie albo strona może nie być wyświetlana poprawnie. Nawiasy kątowe (< oraz >) mogą się pojawić jako kod HTML. Aby obejść ten problem, należy najpierw skopiować przykładowy kod do pustego dokumentu w Notatniku, a następnie skopiować przykładowy kod z dokumentu w Notatniku na stronę w programie FrontPage.

Przykład 1. Tworzenie hiperłączy, w których jedynie podkreślenia są wyświetlane w innym kolorze

W tym przykładzie tekst hiperłącza jest formatowany tak, aby był w takim samym kolorze jak tekst w dokumencie. Jedynie podkreślenie hiperłącza jest wyświetlane innym kolorem. Aby utworzyć niestandardowe hiperłącze, wykonaj następujące kroki:
  1. Uruchom program FrontPage i utwórz nową pustą stronę.
  2. W menu Widok kliknij polecenie Strona, a następnie u dołu strony kliknij kartę Kod.
  3. Wstaw następujący kod w sekcji <head></head> strony:
    <style>body      { color: black; background-color: white; font-family: arial }
    
    a         { color: black; text-decoration: none; border-bottom-style: solid; border-bottom-width: 1px }
    a:link    { border-bottom-color: blue }
    a:visited { border-bottom-color: purple }
    a:hover   { border-bottom-color: green }
    a:active  { border-bottom-color: red }
    </style>
    
  4. Wstaw następujący kod w sekcji <body></body> strony:
    <p>Zobacz <a href="http://www.microsoft.com">http://www.microsoft.com</a>, aby uzyskać więcej informacji.</p>
    <p>Zobacz <a href="http://www.msn.com">http://www.msn.com</a>, aby uzyskać więcej informacji.</p>
    
  5. W menu Plik kliknij polecenie Zapisz.
  6. W oknie dialogowym Zapisz jako określ lokalizację, w której chcesz zapisać plik, wpisz Przykład1 w polu Nazwa pliku, a następnie kliknij przycisk Zapisz.
  7. W menu Plik kliknij polecenie Podgląd w przeglądarce, a następnie kliknij przeglądarkę, której chcesz użyć, aby obejrzeć stronę

Przykład 2. Tworzenie hiperłączy mających przyciski aktywowania

W tym przykładzie jest tworzone hiperłącze używające przycisków aktywowania z wypełnionym tłem. Aby utworzyć niestandardowe hiperłącze, wykonaj następujące kroki:
  1. Uruchom program FrontPage i utwórz nową pustą stronę.
  2. W menu Widok kliknij polecenie Strona, a następnie u dołu strony kliknij kartę Kod.
  3. Wstaw następujący kod w sekcji <head></head> strony:
    <style>
    body      { color: black; background-color: white; font-family: arial }
    a         { text-decoration: none; padding: 3px }
    a:link    { color: white; background-color: blue }
    a:visited { color: white; background-color: purple }
    a:hover   { color: white; background-color: green }
    a:active  { color: white; background-color: red }
    </style>
    
  4. Wstaw następujący kod w sekcji <body></body> strony:
    <p>Zobacz <a href="http://www.microsoft.com">http://www.microsoft.com</a>, aby uzyskać więcej informacji.</p>
    <p>Zobacz <a href="http://www.msn.com">http://www.msn.com</a>, aby uzyskać więcej informacji.</p>
    
  5. W menu Plik kliknij polecenie Zapisz.
  6. W oknie dialogowym Zapisz jako określ lokalizację, w której chcesz zapisać plik, wpisz Przykład2 w polu Nazwa pliku, a następnie kliknij przycisk Zapisz.
  7. W menu Plik kliknij polecenie Podgląd w przeglądarce, a następnie kliknij przeglądarkę, której chcesz użyć, aby obejrzeć stronę

Przykład 3. Tworzenie hiperłączy wykorzystujących przyciski krawędziowe

W tym przykładzie są tworzone hiperłącza używające krawędziowych przycisków aktywowania. Wokół tekstu hiperłącza pojawia się kolorowe pole, powodujące efekt konturu. Aby utworzyć niestandardowe hiperłącze, wykonaj następujące kroki:
  1. Uruchom program FrontPage i utwórz nową pustą stronę.
  2. W menu Widok kliknij polecenie Strona, a następnie u dołu strony kliknij kartę Kod.
  3. Wstaw następujący kod w sekcji <head></head> strony:
    <style>
    body      { color: black; background-color: white; font-family: arial }
    a         { color: black; text-decoration: none; border-style: solid; border-width: 2px; padding: 2px }
    a:link    { border-color: blue }
    a:visited { border-color: purple }
    a:hover   { border-color: green }
    a:active  { border-color: red }
    </style>
    
  4. Wstaw następujący kod w sekcji <body></body> strony:
    <p>Zobacz <a href="http://www.microsoft.com">http://www.microsoft.com</a>, aby uzyskać więcej informacji.</p>
    <p>Zobacz <a href="http://www.msn.com">http://www.msn.com</a>, aby uzyskać więcej informacji.</p>
    
  5. W menu Plik kliknij polecenie Zapisz.
  6. W oknie dialogowym Zapisz jako określ lokalizację, w której chcesz zapisać plik, wpisz Przykład3 w polu Nazwa pliku, a następnie kliknij przycisk Zapisz.
  7. W menu Plik kliknij polecenie Podgląd w przeglądarce, a następnie kliknij przeglądarkę, której chcesz użyć, aby obejrzeć stronę

Przykład 4. Tworzenie hiperłączy wykorzystujących różne formatowanie tekstu

W tym przykładzie hiperłącza są formatowane tak, aby używały tekstu niepodkreślonego, zapisanego kursywą i małymi literami. Gdy wskaźnik myszy zostanie ustawiony nad hiperłączem, tekst w hiperłączu zostanie skonwertowany na wielkie litery. Aby utworzyć niestandardowe hiperłącze, wykonaj następujące kroki:
  1. Uruchom program FrontPage i utwórz nową pustą stronę.
  2. W menu Widok kliknij polecenie Strona, a następnie u dołu strony kliknij kartę Kod.
  3. Wstaw następujący kod w sekcji <head></head> strony:
    <style>
    body      { color: black; background-color: white; font-family: arial }
    a         { text-decoration: none; font-style: italic; text-transform: lowercase }
    a:link    { color: blue; font-weight: bold }
    a:visited { color: purple }
    a:hover   { color: green; text-transform: uppercase }
    a:active  { color: red }
    </style>
    
  4. Wstaw następujący kod w sekcji <body></body> strony:
    <p>Zobacz <a href="http://www.microsoft.com">http://WWW.microsoft.COM</a>, aby uzyskać więcej informacji.</p>
    <p>Zobacz <a href="http://www.msn.com">http://WWW.msn.COM</a>, aby uzyskać więcej informacji.</p>
    
  5. W menu Plik kliknij polecenie Zapisz.
  6. W oknie dialogowym Zapisz jako określ lokalizację, w której chcesz zapisać plik, wpisz Przykład4 w polu Nazwa pliku, a następnie kliknij przycisk Zapisz.
  7. W menu Plik kliknij polecenie Podgląd w przeglądarce, a następnie kliknij przeglądarkę, której chcesz użyć, aby obejrzeć stronę

Materiały referencyjne

Więcej informacji na temat arkuszy stylów kaskadowych można znaleźć w Pomocy programu FrontPage. W tym celu w menu Pomoc kliknij polecenie Microsoft Office FrontPage – Pomoc. W polu Wyszukaj wpisz arkusze stylów kaskadowych, a następnie naciśnij klawisz ENTER, aby wyświetlić zwrócone tematy.

Materiały referencyjne

Aby uzyskać dodatkowe informacje, kliknij następujące numery artykułów w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base.
196488 Fs000: What Are Cascading Style Sheets?
205996 HOW TO: Create Cascading Style Sheets in FrontPage 2000
240972 HOW TO: Remove Underlines from Hyperlinks in FrontPage 2000
222949 FP2000: Creating Hover Effects for Form Buttons using DHTML and CSS

Właściwości

Numer ID artykułu: 825450 - Ostatnia weryfikacja: 30 marca 2007 - Weryfikacja: 2.2
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office FrontPage 2003
Słowa kluczowe: 
kbhowto KB825450

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com