COMMENT FAIRE : Envoyer les résultats d'un formulaire à plusieurs adresses de messagerie dans FrontPage 2003

Traductions disponibles Traductions disponibles
Numéro d'article: 825454 - Voir les produits auxquels s'applique cet article
Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).
Pour vous procurer une version Microsoft Office FrontPage 2002 de cet article, reportez-vous à l'article 310789.
Agrandir tout | Réduire tout

Sommaire

Résumé

Cet article explique comment envoyer des résultats recueillis à partir d'un formulaire présent dans un site Web créé à l'aide de FrontPage 2003 à plusieurs adresses de messagerie. La méthode décrite dans cet article consiste à créer deux formulaires et une page de confirmation, puis à lier les formulaires l'un à l'autre de sorte qu'ils puissent partager les résultats du formulaire.

Comment faire pour créer les pages 1 et 2

Pour créer les pages 1 et 2, procédez comme suit :
  1. Créez la page 1. Pour cela, procédez comme suit :
    1. Démarrez FrontPage.
    2. Dans le menu Fichier, pointez sur Nouveau.
    3. Dans le volet Office Nouveau, cliquez sur Page vierge.
    4. Dans le menu Fichier, cliquez sur Enregistrer.
    5. Dans la boîte de dialogue Enregistrer sous, indiquez l?emplacement où vous souhaitez enregistrer la page, tapez Page1 dans la zone Nom de fichier, puis cliquez sur Enregistrer.
  2. Créez la page 2. Pour cela, procédez comme suit :
    1. Dans le menu Fichier, cliquez sur Enregistrer sous.
    2. Dans la boîte de dialogue Enregistrer sous, indiquez l'emplacement où vous souhaitez enregistrer la page, tapez Page2 dans la zone Nom de fichier, puis cliquez sur Enregistrer.

Comment faire pour créer une page de confirmation

Pour créer une page de confirmation, procédez comme suit :
  1. Dans le menu Fichier, pointez sur Nouveau.
  2. Dans le volet Office Nouveau, cliquez sur Page vierge.
  3. Ajoutez le texte et les éléments de votre choix à la page Web.
  4. Dans le menu Fichier, cliquez sur Enregistrer.
  5. Dans la boîte de dialogue Enregistrer sous, indiquez l'emplacement où vous souhaitez enregistrer la page, tapez Confirmation dans la zone Nom de fichier, puis cliquez sur Enregistrer.

Comment faire pour configurer le formulaire sur la page 1

Pour créer le formulaire sur la page 1 et le configurer, procédez comme suit :
  1. Ouvrez le fichier Page1.htm créé précédemment comme indiqué à la section "Comment créer les pages 1 et 2" de cet article.
  2. Dans le menu Insertion, pointez sur Formulaire, puis cliquez sur Formulaire.
  3. Cliquez avec le bouton droit sur le bouton Envoyer du formulaire, puis cliquez sur Propriétés du formulaire.
  4. Dans la boîte de dialogue Propriétés du formulaire, cliquez sur Envoyer à.
  5. Dans la zone Nom de fichier, tapez le chemin d'accès et le nom du fichier auquel envoyer les résultats.
  6. Dans la zone Adresse de messagerie, tapez l'adresse de messagerie du premier destinataire.
  7. Cliquez sur Options.
  8. Dans la boîte de dialogue Enregistrements des résultats, procédez comme suit :
    1. Cliquez sur l'onglet Résultats par courrier électronique.
    2. Dans la zone Format du courrier électronique, cliquez sur le format de courrier qui vous intéresse.
    3. Sous En-tête du message électronique, dans la zone Ligne Objet, tapez l'objet de votre choix.
    4. Dans la zone Ligne Réponse-à, tapez l'adresse de messagerie de réponse.
    5. Cliquez sur l'onglet Page de confirmation.
    6. Dans la boîte de dialogue URL de la page de confirmation (facultatif), cliquez sur Parcourir.
    7. Dans la boîte de dialogue Site Web en cours, recherchez le fichier Page2.htm créé précédemment comme indiqué à la section "Comment faire pour créer les pages 1 et 2" de cet article, cliquez dessus, puis cliquez sur OK.
    8. Cliquez sur OK.
  9. Cliquez sur OK.
  10. Dans le menu Fichier, cliquez sur Enregistrer.

Comment faire pour configurer le formulaire sur la page 2

Pour créer le formulaire sur la page 2 et le configurer, procédez comme suit :
  1. Ouvrez le fichier Page2.htm créé précédemment comme indiqué à la section "Comment créer les pages 1 et 2" de cet article.
  2. Dans le menu Insertion, pointez sur Formulaire, puis cliquez sur Formulaire.
  3. Cliquez avec le bouton droit sur le bouton Envoyer du formulaire, puis cliquez sur Propriétés du formulaire.
  4. Dans la boîte de dialogue Propriétés du formulaire, cliquez sur Envoyer à.
  5. Dans la zone Nom de fichier, tapez le chemin d'accès et le nom du fichier auquel envoyer les résultats.
  6. Dans la zone Adresse de messagerie, tapez l'adresse de messagerie du deuxième destinataire.
  7. Cliquez sur Options.
  8. Dans la boîte de dialogue Enregistrements des résultats, procédez comme suit :
    1. Cliquez sur l'onglet Résultats par courrier électronique.
    2. Dans la zone Format du courrier électronique, cliquez sur le format de courrier qui vous intéresse.
    3. Sous En-tête du message électronique, dans la zone Ligne Objet, tapez l'objet de votre choix.
    4. Dans la zone Ligne Réponse-à, tapez l'adresse de messagerie de réponse.
    5. Cliquez sur l'onglet Page de confirmation.
    6. Dans la boîte de dialogue URL de la page de confirmation (facultatif), cliquez sur Parcourir.
    7. Dans la boîte de dialogue Site Web en cours, recherchez le fichier Confirmation.htm créé précédemment comme indiqué à la section "Comment faire pour créer une page de confirmation" de cet article, cliquez dessus, puis cliquez sur OK.
    8. Cliquez sur OK.
  9. Cliquez sur OK.
  10. Dans le menu Fichier, cliquez sur Enregistrer.

Références

Pour plus d'informations sur la façon d'utiliser les formulaires dans FrontPage 2003, reportez-vous à l'aide de FrontPage 2003. Pour cela, dans le menu ? (Aide), cliquez sur Aide sur Microsoft Office FrontPage. Dans la zone Rechercher, tapez formulaires, puis appuyez sur ENTRÉE pour afficher les rubriques correspondantes.

Propriétés

Numéro d'article: 825454 - Dernière mise à jour: vendredi 9 janvier 2004 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office FrontPage 2003
Mots-clés : 
kbhowtomaster kbhowto KB825454
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com