How to use an existing database with the Database Interface Wizard in FrontPage 2003

Article translations Article translations
Article ID: 825502 - View products that this article applies to.
Expand all | Collapse all

On This Page

SUMMARY

This article describes how to use an existing database with the Database Interface Wizard in Microsoft Office FrontPage 2003.

Note This example uses the Northwind sample database that is included with Microsoft Office 2003. The same steps apply to a database that you can create automatically when you use FrontPage 2003.

Use an Existing Database with the Database Interface Wizard

If you already have a database in your Web, skip the first eight steps. To use an existing database with the Database Interface Wizard, follow these steps:
  1. Open your Web in FrontPage 2003.
  2. On the File menu, click New.
  3. On the New task pane, click Blank page to open a new page.
  4. On the File menu, click Save As, and then save your new page as Sample.asp.
  5. With the insertion point in your Sample.asp page, point to Database on the Insert menu, and then click Results.
  6. In the Database Results Wizard dialog box, click Use a sample database connection (Northwind), and then click Next.
  7. Click Cancel to cancel the Database Results Wizard.

    You now have a folder in your Folder List of your Web that is named FPDB and a database inside that folder that is named Fpnwind.mdb. FrontPage automatically created a connection string to use in step 12.
  8. On the File menu, click Close to close the Sample.asp page.
  9. On the File menu, point to New.
  10. In the New task pane, under New Web site, click More Web site templates.
  11. On the General tab, click Database Interface Wizard, click to select the Add to current Web site check box, and then click OK.

    Note If you do not add this to the current Web, you cannot select the correct database connection name in step 12.
  12. In the Database Interface Wizard, click Use an existing database connection, click Sample in the drop-down list, and then click Next.
  13. Click Next two times.
  14. Under Select the database interface pages you would like the wizard to create for you, click to select the Results Page, the Submission Form, and the Database Editor check boxes, and then click Next.
  15. Under Enter a username and password that you will use to access your database editor, do one of the following and then click Next:
    • Type a username and password that you will use to access your database editor.

      -or-
    • Click to select the Don't protect my submission page or my database editor with a username and password check box if you do not want to use a username and password.
  16. Click Finish to complete the Database Interface Wizard.
You now have a whole Sample_interface folder in your Folder List of your Web. The Folder List includes all the pages that you need to view, to edit, tp delete, and to add to the database.

Properties

Article ID: 825502 - Last Review: October 23, 2006 - Revision: 1.5
APPLIES TO
  • Microsoft Office FrontPage 2003
Keywords: 
kbdatabase kbhowtomaster KB825502

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com