Come visualizzare un'immagine utilizzando un database di Access in FrontPage 2003

Traduzione articoli Traduzione articoli
Identificativo articolo: 825515 - Visualizza i prodotti a cui si riferisce l?articolo.
Per la una versione di Microsoft FrontPage 2002 di questo articolo, vedere 318813.

Per la una versione di Microsoft FrontPage 2000 di questo articolo, vedere 216285.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo descrive come visualizzare immagini nel sito Web utilizzando le informazioni da Microsoft Access database.

Microsoft fornisce esempi di programmazione a scopo puramente illustrativo, senza alcuna garanzia espressa o implicita. Questo include, ma non è limitato a, le garanzie implicite di commerciabilità o idoneità per uno scopo specifico. Questo articolo si presuppone che conosca il linguaggio di programmazione in questione e gli strumenti utilizzati per creare ed eseguire il debug di procedure. Tecnici del supporto Microsoft possono spiegare la funzionalità di una particolare procedura, ma in nessun sono caso a modificare questi esempi per fornire funzionalità aggiuntive o creare procedure per soddisfare specifiche esigenze.

Prerequisites

Installare i componenti prima di utilizzare le funzionalità ASP in FrontPage

Prima di utilizzare Microsoft Active Server Pages (ASP) funzionalità in Microsoft Office FrontPage 2003, è necessario installare i componenti sono elencati nell'articolo di Microsoft Knowledge Base 825487.Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
825487Come eseguire query dei dati di Index Server utilizzando ASP in FrontPage 2003

Installare FrontPage 2003 e Access 2003

La procedura descritta in questo articolo è necessario disporre Microsoft Office FrontPage 2003 e Microsoft Office Access 2003 installata nel computer client. FrontPage 2003 e Access 2003 sono inclusi in Microsoft Office 2003.

Create a new personal Web site

Per creare un nuovo sito Web personale, attenersi alla seguente procedura:
  1. Avviare FrontPage.
  2. Nel menu file , fare clic su Nuovo .
  3. Nel riquadro attività Nuovo , fare clic su altri modelli di sito .
  4. Nella finestra della finestra di dialogo Modelli sito Web , fare clic su sito Web personale .
  5. Nella casella specificare il percorso del nuovo sito Web digitare l'URL di un nuovo sito Web personale in un server Web che supporta Active Server Pages, ad esempio:
    http://MyWebServer/mypersonalweb/
  6. Fare clic su OK per creare il sito Web.

Add the sample database to the Web site

Per aggiungere il database di esempio al sito Web, attenersi alla seguente procedura:
  1. Fare clic su Crea una nuova pagina normale sulla barra degli strumenti.
  2. Scegliere database dal menu Inserisci , quindi risultati .
  3. Nella prima pagina della creazione guidata Area risultati database, fare clic su utilizzare una connessione di database di esempio (Northwind) e scegliere Avanti .
  4. Fare clic su Annulla .

Modify the Employees table in the database

Per modificare la tabella Impiegati del database, attenersi alla seguente procedura:
  1. Nel menu Visualizza , fare clic su cartelle .
  2. Fare doppio clic su nella cartella fpdb e fare doppio clic sul file fpnwind.mdb per aprire il file in Access.
  3. Fare doppio clic sulla tabella dipendenti per aprirlo.
  4. Scegliere dal menu Visualizza , struttura Visualizza .
  5. Alla fine della tabella, fare clic sulla prima riga vuota per aggiungere un nuovo campo alla tabella.
  6. Configurare il nuovo campo come segue:
    1. Nella colonna Nome campo, è necessario digitare FavoriteImage .
    2. Nella colonna tipo di dati, fare clic su testo .
  7. Nel menu file , fare clic su Salva .
  8. Scegliere visualizzazione Foglio dati dal menu Visualizza .
  9. Digitare i seguenti valori nella riga FavoriteImage per ciascuno dei dipendenti:
    Riduci questa tabellaEspandi questa tabella
    DipendenteFavoriteImage
    Nancy DavolioImages/mycat.jpg
    Andrew FullerImages/mount.gif
    Tutti gli altri dipendenti.immagini/parrot1.jpg
  10. Per chiudere il database e per tornare a FrontPage, scegliere Esci dal menu file .
  11. Nel menu Visualizza , fare clic su Aggiorna .

Add a Database Results region

Per aggiungere un'area risultati database, attenersi alla seguente procedura:
  1. Scegliere pagina dal menu Visualizza .
  2. Scegliere database dal menu Inserisci , quindi risultati .
  3. Attenersi alla seguente procedura in Creazione guidata Area risultati database:
    1. Nell'elenco delle connessioni di database esistenti, fare clic su esempio e quindi fare clic su Avanti .
    2. Nell'elenco origine record , fare clic su Impiegati e quindi fare clic su Avanti .
    3. Fare clic su Modifica elenco .
    4. Rimuovere tutti i campi ad eccezione dei seguenti campi:
      • Cognome
      • Nome
      • FavoriteImage
    5. Fare clic su OK .
    6. Fare clic su Avanti due volte e quindi fare clic su Fine .
  4. Nel menu file , fare clic su Salva .
  5. Digitare imagetest.asp nella casella nome file e quindi fare clic su OK .

Add the image links to the database results

Per aggiungere i collegamenti di immagine ai risultati del database, attenersi alla seguente procedura:
  1. Fare clic sul valore <<favoriteimage>> nella colonna FavoriteImage e quindi premere CANC.
  2. Nella cella di tabella in cui appena rimosso il valore <<favoriteimage>>, inserire l'immagine di Mycat.jpg dal sito Web. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Scegliere immagine dal menu Inserisci , quindi da file .
    2. Individuare l'immagine Mycat.jpg nella cartella immagini del sito Web.
    3. Fare clic sull'immagine e quindi fare clic su OK .
  3. Clic con il pulsante destro del mouse sull'immagine e quindi fare clic su immagine proprietà .
  4. Fare clic sulla scheda Generale .
  5. Fare clic su parametri .
  6. Nella casella percorso , rimuovere il percorso corrente.
  7. Fare clic su Inserisci valore campo e quindi fare clic su FavoriteImage .
  8. Rimuovere le virgolette all'inizio e alla fine del valore di campo.
  9. Fare clic su OK due volte. Viene visualizzata un'icona di immagine piccola, interrotti della colonna della tabella.
  10. Salvare la pagina e quindi fare clic su Visualizza anteprima nel Browser sulla barra degli strumenti.

Riferimenti

Per ulteriori informazioni su come lavorare con database in FrontPage, scegliere Guida in linea di Microsoft Office FrontPage dal menu Guida , tipo di database nella ricerca del riquadro risorse e scegliere inizia la ricerca per visualizzare l'argomento.

Proprietà

Identificativo articolo: 825515 - Ultima modifica: venerdì 6 gennaio 2006 - Revisione: 4.5
Le informazioni in questo articolo si applicano a:
  • Microsoft Office FrontPage 2003
  • Microsoft Office Access 2003
Chiavi: 
kbmt kbgraphic kbhowto KB825515 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 825515
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com