כיצד למזער מטה-נתונים ב- Word 2003

תרגומי מאמרים תרגומי מאמרים
Article ID: 825576 - View products that this article applies to.
הרחב הכל | כווץ הכל

On This Page

תקציר

מאמר זה מתאר שיטות שונות שבהן תוכל להשתמש כדי למזער את המטה-נתונים במסמכי Word.

בעת יצירה, פתיחה או שמירה של מסמך ב- Microsoft Office Word 2003, המסמך עשוי להכיל תוכן שאינך מעוניין לשתף עם אחרים בעת הפצת המסמך באופן אלקטרוני. פרטים אלה נקראים מטה-נתונים. מטה-נתונים משמשים למגוון מטרות, ביניהן שיפור העריכה, התצוגה, התיוק והאחזור של מסמכי Office.

אל חלק מהמטה-נתונים ניתן לגשת בקלות מתוך ממשק המשתמש של Word. מטה-נתונים אחרים נגישים רק באמצעות מיוחדים, כגון פתיחה של מסמך בעורך קבצים בינאריים ברמה נמוכה. להלן כמה דוגמאות למטה-נתונים שעשויים להיות מאוחסנים במסמכים שלך:
  • השם שלך
  • ראשי התיבות שלך
  • שם החברה או הארגון
  • שם המחשב
  • שם שרת הרשת או הדיסק הקשיח שבו שמרת את המסמך
  • מאפייני קובץ ופרטי תקציר אחרים
  • אפשרויות מוסתרות של אובייקטי OLE מוטבעים
  • מהדורות מסמכים
  • גירסאות מסמכים
  • פרטי תבנית
  • טקסט מוסתר
  • הערות
מטה-נתונים נוצרים במגוון דרכים במסמכי Word כתוצאה מכך, לא קיימת שיטה יחידה להסרת כל התכנים הללו מהמסמכים. הסעיפים הבאים מתארים את האזורים שבהם ניתן לשמור מטה-נתונים במסמכי Word.

מאמר זה מתאר שיטות שונות שבהן תוכל להשתמש כדי למזער את המטה-נתונים במסמכי Word.

Microsoft מספקת את דוגמאות התכנות שלהלן להמחשה בלבד וללא כל אחריות, בין מפורשת ובין משתמעת, ובכלל זה, אך לא רק, אחריות לגבי סחירות או התאמה למטרה מסוימת. מאמר זה מבוסס על ההנחה שאתה מכיר את שפת התכנות המודגמת ובקי בהפעלת הכלים המשמשים ליצירת פרוצדורות ולניפוי שגיאות. מהנדסי התמיכה של Microsoft יכולים לסייע בהסברת הפונקציונליות של פרוצדורה מסוימת, אך הם לא ישנו את הדוגמאות כדי לספק פונקציונליות נוספת או כדי לבנות פרוצדורות שיענו על צרכיך הספציפיים. לקבלת מידע נוסף אודות אופן השימוש בקוד לדוגמה הכלול במאמר זה, לחץ על מספר המאמר שלהלן כדי להציגו מתוך מאגר הידע Microsoft Knowledge Base:
290140 כיצד להפעיל קוד לדוגמה עבור תוכניות Office XP מתוך מאמרי Knowledge Base (ייתכן שקישור זה מפנה לתוכן שחלק ממנו או כולו מופיע באנגלית)

כיצד להסיר פרטים אישיים באופן אוטומטי במהלך שמירה

כעת באפשרותך להסיר באופן אוטומטי פרטים אישיים ממסך Word בעת שמירת המסמך. כדי להפעיל אפשרות זו, בצע את הפעולות הבאות:
  1. בתפריט כלים, לחץ על אפשרויות.
  2. בכרטיסיה אבטחה, לחץ כדי לבחור בתיבת הסימון הסר מידע אישי ממאפייני הקובץ בעת שמירה תחת אפשרויות פרטיות ולאחר מכן לחץ על אישור.
הערה זוהי השיטה המועדפת להסרת פרטים אישיים בעת שמירת מסמך Word.

כיצד להסיר באופן ידני את שם המשתמש שלך מהמסמכים

כדי להציג או לשנות את שם המשתמש שלך בצע את הפעולות הבאות:
  1. בתפריט כלים, לחץ על אפשרויות ולאחר מכן לחץ על הכרטיסיה פרטי המשתמש.

    תיבות העריכה הבאות מופיעות:
    שם
    ראשי תיבות
    כתובת משלוח
  2. אם אינך מעוניין שפרט כלשהו מפרטים אלה יופיע במסמכים, הזן מחרוזות לא מזהות או רווחים בתיבות ההעריכה המתאימות ולאחר מכן לחץ על אישור כדי לאשר את השינויים.
הערה מסמכים חדשים שתיצור יכילו פרטים אלה במקום את ערכי ברירת המחדל שהוזנו במהלך ההתקנה של Office. עם זאת, מסמכים קיימים כבר מכילים פרטים אלה.

כיצד להסיר באופן ידני פרטי תקציר אישי

בעת יצירה או שמירה של מסמך ב- Word, ייתכן שפרטי תקציר יישמרו במסמך. ישנן כמה שיטות שבהן תוכל להשתמש כדי לגשת לפרטים אלה.
  • פתח את המסמך. בתפריט קובץ, לחץ על מאפיינים. הכרטיסיות תקציר, סטטיסטיקה, תוכן והתאמה אישית עשויות להכיל מאפיינים שונים כגון שמך, שם המנהל שלך ושם החברה.
  • בסייר Microsoft Windows, לחץ באמצעות לחצן העכבר הימני על קובץ המסמך, ולאחר מכן לחץ על מאפיינים. הכרטיסיות בתיבת הדו-שיח מאפיינים עשויות להכיל פרטים.
  • באפשרותך להשתמש במאקרו של Microsoft Visual Basic for Applications (VBA) או בקוד של תוכנית אחרת כדי לקרוא את המאפיינים המוצגים בתיבת הדו-שיח מאפיינים.
כדי לנקות את פרטי התקציר ממסמך או תבנית קיימים, בצע את הפעולות הבאות:
  1. פתח את המסמך או התבנית.
  2. בתפריט קובץ, לחץ על מאפיינים.
  3. בכרטיסיה תקציר, לחץ כדי לנקות את התיבות מחבר, מנהל, חברה וכל תיבת עריכה אחרת שאינך מעוניין להפיץ.
  4. בכרטיסיה התאמה אישית, מחק את המאפיינים שמכילים פרטים שאינך מעוניין להפיץ.
  5. לחץ על אישור

    בתפריט קובץ, לחץ על שמור ולאחר מכן לחץ על סגור.
לאחר שתבצע פעולות אלה, המסמך לא יכיל מאפייני תקציר.

כיצד להסיר באופן ידני פרטי תקציר אישי כאשר קיים חיבור לרשת

אם אתה מחובר לרשת, שם המשתמש שלך ברשת יופיע בתיבה מחבר בכרטיסיה תקציר ובשדה נשמר לאחרונה על-ידי בכרטיסיה סטטיסטיקה כאשר תשמור את המסמך. בעיה זו עלולה להתרחש גם אם הסרת את כל הפרטים האישיים מהמחשב שלך.

כדי להסיר פרטי תקציר ממסמך כאשר אתה מחובר לרשת, בצע את הפעולות הבאות:
  1. אם המסמך מאוחסן בשרת רשת, העתק אותו לדיסק הקשיח המקומי.
  2. הפעל את המחשב, אך אל תיכנס לרשת. כאשר תראה את תיבת הדו-שיח לכניסה לרשת, לחץ על ביטול או הקש ESCAPE.

    הערה אם לא ניתן להפעיל את Windows על-ידי הקשה על ESCAPE (לדוגמה, במחשב פועלת מערכת Microsoft Windows NT), לא תוכל להמשיך לשלבים הבאים.
  3. פתח את המסמך.
  4. בתפריט קובץ, לחץ על מאפיינים.
  5. בכרטיסיה תקציר, לחץ כדי לנקות את התיבות מחבר, מנהל, חברה וכל תיבת עריכה אחרת שמכילה פרים שאינך מעוניין להפיץ.
  6. בכרטיסיה התאמה אישית, מחק את המאפיינים שמכילים פרטים שאינך מעוניין להפיץ.
  7. לחץ על אישור

    בתפריט קובץ, לחץ על שמור ולאחר מכן לחץ על סגור.
כאשר תיכנס לרשת, אל תפתח את הקובץ. אם תפתח, שם המשתמש ברשת יופיע בקובץ. עם זאת, באפשרותך להשתמש בסייר Windows כדי להעתיק את הקובץ לשרת רשת או לתקליטון.

כיצד להסיר באופן ידני הערות ממסמכים

Word מציע אפשרות להוסיף הערות למסמכים. בדרך כלל, הערות מכילות את שם האדם שיצר אותן, כדי שניתן יהיה לדעת מי כתב אותן.

הערות מופיעות בדרך כלל כקטע טקסט מודגש; באפשרותך ללחוץ באמצעות לחצן העכבר הימני ולאחר מכן ללחוץ על מחק הערה.

כל ההערות החדשות שתיצור, לא יכילו את שם המשתמש מאחר שהסרת אותו מתיבת הדו-שיח אפשרויות כמתואר בסעיף "כיצד להסיר באופן ידני את שם המשתמש שלך מהמסמכים" במאמר זה.

כיצד להסיר באופן ידני כותרות עליונות ותחתונות ממסמכים

כותרות עליונות ותחתונות במסמכים עשויות להכיל פרטים מזהים. כדי להסיר פרטים מכותרות עליונות ותחתונות, בצע את הפעולות הבאות:
  1. בתפריט תצוגה, לחץ על כותרת עליונה ותחתונה.
  2. הכותרת העליונה והתחתונה מופיעות בחלק העליון והתחתון של כל עמוד במסמך.

    שנה אותן כרצונך.
  3. לחץ על סגור בסרגל הכלים כותרת עליונה ותחתונה.

כיצד להסיר באופן ידני סימוני תיקון מהדורה

מסמכים עשויים להכיל סימוני תיקון מהדורה. באמצעות סימוני תיקון מהדורה באפשרותך לקבוע מי ביצע שינויים ספציפיים במסמך. כאשר תקבל או תדחה סימוני תיקון מהדורה, הטקסט המתוקן יישמר במסמך וסימוני המהדורה יוסרו.

כדי לקבל או לדחות תיקונים, בצע את הפעולות הבאות:
  1. בתפריט כלים, לחץ על עקוב אחר שינויים כדי להפעיל אפשרות זו.
  2. בסרגל הכלים סקירה, לחץ על הקודם או על הבא כדי לאתר ולבחור שינויים ספציפיים. לאחר מכן, לחץ על קבל שינוי או על דחה שינוי/מחק הערה כדי לקבל או לדחות את השינוי הנבחר.
  3. כאשר תסיים, לחץ על סגור.
הערה אם תשנה את ההגדרות תחת 'הצג' בסרגל הכלים 'סקירה', פרטי השינויים לא יוסרו.

כיצד לבטל שמירה מהירה

התכונה 'שמירה מהירה' מאיצה את תהליך השמירה של מסמך על-ידי שמירת השינויים שבוצעו במסמך בלבד.

בשל התכנון של התכונה 'שמירה מהירה', טקסט שתמחק ממסמך עשוי להישאר במסמך גם לאחר ששמרת את המסמך. אם אתה מוטרד מכך שטקסט שמחקת יישאר במסמכים, בצע את הפעולות הבאות:
  1. בתפריט כלים, לחץ על אפשרויות.
  2. בחר בכרטיסיה שמירה.
  3. לחץ כדי לנקות את תיבת הסימון אפשר שמירה מהירה, ולאחר מכן לחץ על אישור.
לקבלת מידע נוסף על התכונה 'שמירה מהירה', לחץ על מספר המאמר שלהלן כדי להציגו מתוך מאגר הידע Microsoft Knowledge Base:
291181 שאלות נפוצות אודות 'אפשר שמירה מהירה' ב- Word 2002 (ייתכן שקישור זה מפנה לתוכן שחלק ממנו או כולו מופיע באנגלית)

כיצד לחפש ולהסיר טקסט המעוצב כטקסט מוסתר

במסמכי Word, באפשרותך לעצב טקסט כטקסט מוסתר. מאחר שטקסט מוסתר יכול להכיל פרטים שאינך מעוניין להפיץ, מומלץ לבטל את הסתרתו ולהסיר אותו. כדי להסיר את כל הטקסט במסמך המעוצב כמוסתר, בצע את הפעולות הבאות:
  1. בתפריט כלים, לחץ על אפשרויות ולאחר מכן לחץ על הכרטיסיה תצוגה.
  2. לחץ כדי לבחור בתיבת הסימון טקסט מוסתר ולאחר מכן לחץ על אישור.
  3. בתפריט עריכה, לחץ על החלפה.
  4. לחץ על עוד כדי להרחיב את תיבת הדו-שיח.
  5. לחץ במקום כלשהו בתיבה לצד חפש את.
  6. לחץ על לחצן עיצוב ולאחר מכן לחץ על גופן.

    לחץ כדי לבחור בתיבת הסימון מוסתר ולאחר מכן לחץ על אישור.
  7. לחץ על החלף הכל.
כל הטקסט המוסתר יוסר מהמסמך. כדי להשבית את ההצגה של טקסט מוסתר, בצע את הפעולות הבאות:
  1. בתפריט כלים, לחץ על אפשרויות ולאחר מכן לחץ על הכרטיסיה תצוגה.
  2. לחץ כדי לנקות את תיבת הסימון טקסט מוסתר ולאחר מכן לחץ על אישור.

כיצד להסיר היפר-קישורים ממסמכים

מסמכים עשויים להכיל היפר-קישורים למסמכים אחרים או לדפי אינטרנט ברשת אינטרא-נט או באינטרנט. היפר-קישורים מופיעים בדרך כלל כמחרוזות טקסט עם קו תחתון כחול.

כדי למחוק באופן ידני היפר-קישור יחיד ממסמך, לחץ באמצעות לחצן העכבר הימני על ההיפר-קישור, הצבע על היפר-קישור ולאחר מכן לחץ על הסר היפר-קישור.

אם ברצונך למחוק את כל ההיפר-קישורים במסמך, באפשרותך להשתמש במאקרו של VBA כדי לבצע פעולה זו. הדוגמה הבאה למאקרו VBA מסירה את כל ההיפר-קישורים ממסמך.

הערה בדוגמת המאקרו שלהלן, רק הקישור מוסר. הטקסט של ההיפר-קישור נשאר במסמך.

חשוב לפני שתשתמש במאקרו הבא לדוגמה, עיין בכתב הוויתור מוקדם יותר במאמר זה.
	Sub RemoveHyperlinks()
	
	   Dim oDoc As Document
	   Dim oStory As Range
	   Dim oHlink As Hyperlink
	
	   For Each oStory In ActiveDocument.StoryRanges
	      For Each oHlink In oStory.Hyperlinks
	         oHlink.Delete
	      Next
	   Next
	
	End Sub
כדי להסיר מהמסמך את כל העקבות, הן של ההיפר-קישור והן של הטקסט של ההיפר-קישור, באפשרותך להשתמש במקום זאת בדוגמה למאקרו שלהלן:
	Sub RemoveAllHyperlinks()
	
	   Dim oDoc As Document
	   Dim oStory As Range
	   Dim oHlink As Hyperlink
	
	   For Each oStory In ActiveDocument.StoryRanges
	      For Each oHlink In oStory.Hyperlinks
	         oHlink.Range.Delete
	      Next
	   Next
	
	End Sub

כיצד להסיר סגנונות ממסמכים

מסמכים עשויים לכלול סגנונות המכילים מטה-נתונים. באפשרותך להסיר סגנונות אלה או לשנות את שמם. לשם כך, בצע את הפעולות הבאות:
  1. פתח את המסמך שמכיל את הסגנונות.
  2. בתפריט עיצוב, לחץ על סגנון.
  3. בחר את הסגנון שברצונך למחוק או לשנות את שמו.

    לחץ על מחק כדי למחוק את הסגנון או לחץ על שנה כדי לשנות את שמו.

כיצד להסיר גרסאות קובץ ישנות ממסמכים

Word כולל תכונה של גירסת קובץ המאפשרת לך לשמור גירסאות מרובות של אותו מסמך באותו קובץ. מומלץ למחוק גירסאות ישנות יותר של המסמך לפני שתשתף אותו עם אחרים.

כדי למחוק גירסה אחת או יותר של מסמך, בצע את הפעולות הבאות:
  1. בתפריט קובץ, לחץ על גירסאות.
  2. בחר את גירסת המסמך שברצונך למחוק.

    באפשרותך לבחור גירסה אחת או יותר על-ידי הקשה על CTRL בעת בחירת הגירסאות.
  3. לחץ על מחק.
  4. כאשר תסיים למחוק גירסאות ישנות של המסמך, לחץ על שמור בתפריט קובץ.

כיצד להסיר קישורים מקודי שדה

תמונות מקושרות ואובייקטים אחרים במסמכי Word עשויים לכלול פרטי קישור, כגון הנתיב של התמונה או האובייקט המקושרים. באפשרותך להסיר את פרטי הקישור מהמסמך על-ידי עריכת קודי השדה.

כדי להציג את קודי השדה, בצע את הפעולות הבאות:
  1. בתפריט כלים, לחץ על אפשרויות ולאחר מכן לחץ על הכרטיסיה תצוגה.
  2. לחץ כדי לבחור בתיבת הסימון קודי שדה ולאחר מכן לחץ על אישור.
לאחר שקודי השדה יהיו גלויים, באפשרותך לבדוק כדי לראות אם הם מכילים פרטים מזהים.

כדי להסיר את פרטי הקישור מהתמונה המקושרת או מאובייקט אחר, בצע את הפעולות הבאות:
  1. בחר את התמונה או האובייקט המקושרים, או בחר את קוד השדה עבור התמונה או האובייקט עם קודי השדה גלויים.
  2. הקש CTRL+SHIFT+F9.
התמונה או האובייקט אינם מקושרים כעת. כאשר תמונה או אובייקט אינם מקושרים, לא ניתן לערוך אותם.

כיצד להסיר את שם התבנית ומיקומה

כל המסמכים שנוצרים ב- Word מבוססים על תבנית. כברירת מחדל, זהו קובץ התבנית Normal.dot, הממוקם בתיקיה Templates. עם זאת, באפשרותך ליצור מסמך המבוסס על תבנית אחרת שנמצאת במיקום אחר. השם והנתיב של תבנית זו מאוחסנים במאפייני המסמך.

כדי להציג את שם התבנית ומיקומה, לחץ על מאפיינים בתפריט קובץ ולאחר מכן לחץ על הכרטיסיה תקציר.

גם אם לא תשלח את התבנית עם המסמך, המסמך ישמור על שם התבנית ומיקומה. כדי לשנות את שם התבנית והמיקום לערכים שאינם מזהים, בצע את הפעולות הבאות:
  1. בתפריט כלים, לחץ על תבניות ותוספות.
  2. לחץ על צרף.
  3. בחר תבנית בעלת שם ומיקום שאינם רגישים או ייחודיים.

    לדוגמה, מאחר שכל מחשב שבו מותקן Word כולל את התבנית Normal.dot, מומלץ לבחור Normal.dot.
  4. לחץ על פתח ולאחר מכן לחץ על אישור.
הערה התבניות עשויות להכיל פקודות מאקרו, ערכי טקסט אוטומטי, סגנונות מותאמים אישית וסרגלי כלים מותאמים אישית. על-ידי החלפת התבניות, ייתכן שחלק מפריטים אלה לא יהיו זמינים במסמך.

כיצד להסיר פרטי תגית ניתוב

בעת שליחת מסמך בדואר אלקטרוני באמצעות תגית ניתוב, ייתכן שפרטי הניתוב יהיו מצורפים למסמך. כדי להסיר פרטים אלה מהמסמך, עליך לשמור את המסמך בתבנית שאינה שומרת על פרטי תגית הניתוב.

ב- Word, שמור את המסמך בתבנית Rich Text Format (RTF)? או בתבנית HTML. סגור את המסמך ולאחר מכן פתח מחדש את הקובץ החדש. מאחר שפרטי תגית הניתוב כבר אינם קיימים, באפשרותך לשמור את המסמך בתבנית Word.

באפשרותך גם לבצע את הפעולות הבאות:
  1. בטל את האפשרות אפשר שמירה מהירה לפי ההוראות שצוינו מוקדם יותר במאמר זה.
  2. בתפריט קובץ, הצבע על שלח אל ולאחר מכן לחץ על נמען ניתוב אחר.
  3. לחץ על נקה כדי להסיר את תגית הניתוב ולאחר מכן לחץ על אישור.
  4. בתפריט קובץ, לחץ על שמור.
המסמך נשמר כעת ללא פרטי תגית הניתוב.

כיצד להסיר את שמך מקוד Visual Basic

חשוב לפני שתשתמש בדוגמה למאקרו הבא, עיין בכתב הוויתור מוקדם יותר במאמר זה.

בעת הקלטת מאקרו VBA ב- Word, המאקרו המוקלט מתחיל עם כותרת עליונה דומה לכותרת הבאה:
	' Macro1 Macro
	' Macro recorded 3/11/1999 by <User Name>
כדי להסיר את שמך מפקודות מאקרו שהקלטת, בצע את הפעולות הבאות:
  1. פתח את המסמך שמכיל את פקודות המאקרו.
  2. בתפריט כלים, הצבע על מאקרו, ולאחר מכן לחץ על עורך Visual Basic. לחלופין, הקש על ALT+F11.
  3. בחלון הפרויקט, לחץ פעמיים על המודול שמכיל את פקודות המאקרו.
  4. הסר את שמך מקוד המאקרו המוקלט.
כאשר תסיים להסיר את שמך, הקש ALT+Q כדי לחזור לתוכנית ולאחר מכן לחץ על שמור בתפריט קובץ.

כיצד להסיר הפניות של Visual Basic לקבצים אחרים

ב- Visual Basic Editor, באפשרותך ליצור הפניה לקובץ אחר. אם משתמש פותח מסמך שמכיל הפניות לקבצים אחרים, הוא יכול לראות שמות של הקבצים שאליהם בוצעה הפניה.

כדי להסיר הפניות אלה, בצע את הפעולות הבאות:
  1. פתח את המסמך שמכיל הפניות.
  2. בתפריט כלים, הצבע על מאקרו, ולאחר מכן לחץ על עורך Visual Basic או הקש ALT+F11.
  3. בתפריט כלים, לחץ על הפניות.
  4. לחץ כדי לנקות את תיבת הסימון לצד הקובץ או הקבצים שאליהם בוצעה הפניה.

    כאשר תסיים, לחץ על אישור.
  5. הקש ALT+Q.
  6. בתפריט קובץ, לחץ על שמור.
הערה אם תסיר הפניות לקבצים אחרים, עלולה להיות לכך השפעה לרעה על היכולת של פקודות מאקרו במסמך שלך לפעול בצורה תקינה.

כיצד להסיר פרטי רשת או פרטי דיסק קשיח

כאשר תשמור מסמך בדיסק קשיח מקומי או בשרת רשת, פרטים המזהים את הדיסק הקשיח המקומי או את שרת הרשת עשויים להופיע בקובץ.

כדי להסיר פרטים אלה מהמסמך, בצע את הפעולות הבאות:
  1. פתח את המסמך.
  2. בתפריט קובץ, לחץ על שמירה בשם.

    שמור את המסמך בכונן התקליטונים (בדרך כלל כונן A).
  3. בתפריט קובץ, לחץ על סגור.
  4. הוצא את התקליטון מכונן התקליטונים.
כעת באפשרותך להשתמש בסייר Windows כדי להעתיק את המסמך מהתקליטון לכל דיסק קשיח או שרת רשת.

הערה עקב מגבלת הגודל של תקליטון (בדרך כלל 1.44 מגה-בתים[MB]), לא תוכל להשתמש בשיטה זו אם גודל הקובץ של המסמך חורג מהשטח הפנוי בתקליטון.

אובייקטים מוטבעים במסמכים עשויים להכיל מטה-נתונים

אם תטביע אובייקט במסמך, האובייקט עדיין יישמור על המאפיינים שלו, ללא תלות בפעולות שתבצע במסמך. לדוגמה, אם תטביע חוברת עבודה של Microsoft Excel במסמך Word, למסמך ולחוברת העבודה יהיו מאפיינים משלהם.

כדי להסיר מטה-נתונים מאובייקט מוטבע, הפעל את האובייקט, הסר את המטה-נתונים כמתואר בסעיפים הקודמים, הפעל מחדש את המסמך המכיל ולאחר מכן שמור את המסמך המכיל.

הערה בעת הפעלת אובייקט מוטבע במסמך, רק חלק מהאובייקט המוטבע יוצג במסמך, ייתכן שהאובייקט מכיל פרטים נוספים שאינם מופיעים. אם ברצונך שמסמך יכיל רק עיבוד של האובייקט המוטבע ולא את התוכן בפועל, השתמש בפקודה גזור בתפריט עריכה כדי למחוק את האובייקט ולאחר מכן השתמש בפקודה הדבקה מיוחדת כדי להדביק את האובייקט במסמך באמצעות תבנית מטה-קובץ. לאחר שתבצע פעולה זו, לא תוכל עוד לערוך את האובייקט המוטבע; עם זאת, הוא לא יכיל מטה-נתונים.

משתני מסמך עשויים להכיל מטה-נתונים

חשוב לפני שתשתמש בדוגמת המאקרו הבאה, עיין בכתב הוויתור מוקדם יותר במאמר זה.

כדי למחוק את משתני המסמך הכלולים במסמך Word, השתמש בדוגמת המאקרו שלהלן:
	Sub DeleteDocVars()
	
	   Dim Response
	   Dim myVar As Variable
	
	   For Each myVar In ActiveDocument.Variables
	      Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
	         "Value: " & myVar.Value & vbCr & vbCr & _
	         "Do you want to delete the variable from this document?", vbYesNo)
	            
	      If Response = "6" Then
	         ' Delete the variable.
	         myVar.Delete
	      Else
	         End
	      End If
	   Next myVar
	            
	   MsgBox "There are no variables in the document."
	   
	End Sub
לקבלת מידע נוסף אודות משתנים, ב- Visual Basic Editor, לחץ על עזרה של Microsoft Visual Basic בתפריט עזרה, הקלדמאפייני משתמשים במסייע של Office או באשף התשובות, ולאחר מכן לחץ על חיפוש כדי להציג את הנושא.

הצעות כלליות בנוגע לאבטחה

להלן כמה הצעות כלליות שבהן תוכל להשתמש כדי לשפר את רמת האבטחה בסביבת המיחשוב שלך.
  • בכל פעם שאינך יושב מול המחשב, הקפד לאבטח אותו עם שומר מסך המוגן באמצעות סיסמה, סיסמת הפעלה או תכונת הנעילה של Windows NT.
  • אם המחשב שלך כולל תיקיות משותפות, הקפד לספק סיסמאות עבור תיקיות אלה, כך שרק המשתמשים המורשים יוכלו לגשת למיקומים המשותפים. להשגת רמת אבטחה גבוהה יותר, השתמש בבקרת גישה ברמת המשתמש, כך שתוכל לקבוע במדויק מי יכול לגשת למיקומים המשותפים במחשב שלך.
  • כאשר תמחק קובץ, רוקן באופן מיידי את סל המיחזור. מומלץ לשקול שימוש בכלי שירות המוחק לחלוטין או מחליף קבצים כאשר הם נמחקים.
  • כאשר תגבה את הנתונים שלך, אחסן את הגיבויים במיקום מאובטח, כגון כספת, תיבה לפקדונות נייירות ערך או ארון נעול.
  • הקפד להגן על מסמכים חשובים באמצעות סיסמה, כך שרק משתמשים מורשים יוכלו לפתוח אותם. אחסן את הסיסמאות שלך במיקום מאובטח, נפרד. אם אינך מצליח לשחזר סיסמה, אין דרך לשחזר את התוכן של מסמך המוגן באמצעות סיסמה.
  • אל תפיץ מסמכים בצורתם האלקטרונית. במקום זאת, הדפס אותם. אל תשתמש ברכיבים מזהים, כגון גופנים ייחודיים, סימני מים, סמלים או נייר מיוחד, אלא אם כן הדבר הכרחי (לדוגמה, לצורך מצגת).
  • דואר אלקטרוני אינו אנונימי. אל תשלח מסמך בדואר אלקטרוני אם אתה מודאג מכך שזהותך תשויך בדרך כלשהי למסמך.
  • אל תשלח מסמך באמצעות האינטרנט במצאות פרוטוקול HTTP או פרוטוקול העברת קבצים (FTP). מידע הנשלח באמצעות פרוטוקולים אלה נשלח כ"טקסט נקי", כלומר שבאופן טכני ניתן ליירט אותו (אף שהדבר אינו סביר).

מאפיינים

Article ID: 825576 - Last Review: יום שלישי 25 מרץ 2008 - Revision: 5.1
המידע במאמר זה חל על:
  • Microsoft Office Word 2003
מילות מפתח 
kbregistry kbhowtomaster KB825576

ספק משוב

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com