如何恢复已损坏的 OneNote 分区文件中的信息

文章翻译 文章翻译
文章编号: 825779 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

概要

本文介绍如何恢复损坏的 Microsoft Office OneNote 2003 部分文件或 Microsoft Office OneNote 2007 分区文件中的信息。

注意当您尝试下面的错误消息时,本文中列出的方法可能帮助您:
加载此部分出现的一个未知错误

更多信息

方法 1: OneNote 2003 尝试恢复损坏的分区文件

当您启动 OneNote 2003,或当您打开、 优化、 查找,或备份一个 OneNote 部分 OneNote 验证该文件的完整性。如果 OneNote 确定有该文件的问题,它会尝试修复该的文件,并且您收到以下消息:
在验证分区文件的完整性,时 OneNote 检测到以下文件的问题:

filename.one

该问题可能不是严重,但最好修复时首先检测到任何完整性问题。 OneNote 必须重新启动才能修复文件。
单击 确定 后 OneNote 退出并重新启动,然后修复该文件。 部分文件修复后,您会收到以下消息:
OneNote 已经修复以下文件:

filename.one

请检查该文件中丢失了一些笔记,就算真的出现。如果缺少任何内容,单击以查看是否有可用的任何备份的文件帮助菜单上的打开备份。如果缺少的笔记已经备份,您可以将它们添加到修复的文件通过复制和粘贴将笔记从备份文件。
若要尝试手动修复您的损坏的部分,请转到方法 2。

方法 2: 通过使用 ForceRepair 开关恢复信息

若要手动修复您所了解的 OneNote 分区文件已损坏,当您启动 OneNote 时或当您打开一个 OneNote 时导致的问题部分,请按照下列步骤操作:
  1. 单击 开始,然后单击 运行
  2. 运行 框中单击 浏览
  3. 浏览 对话框中更改位置 查找范围 框中所示:
    是 Files\Microsoft Office\ <Office Version>
    备注
    • OneNote 的安装位置可能会在您的计算机上不同。
    • <Office Version>OneNote 2003 是 Office11。<Office Version> OneNote 2007 是 Office12。
  4. 单击 Onenote.exe,然后单击 打开
  5. 打开 框中单击,然后将插入点移动到路径语句结尾。
  6. 在右引号之后键入一个空格,然后键入 / forcerepair"file-path",其中 file-path 是完整的路径和文件名的 OneNote 分区文件所要修复的。

    在路径语句,在 打开 框中的看起来将类似于下面这样:
    "是 Files\Microsoft Office\ <Office Version> \Onenote.exe"/forcerepair"C:\Documents 和 Settings\ username \My Documents\My Notebook\Quick Notes.one"
  7. 单击 确定 以修复 OneNote 分区文件。
    注意在 OneNote 2007 中运行命令后您不会收到任何邮件。此外,您可能必须手动打开修复的文件。
  8. 当您收到以下错误消息,请单击 确定
    在验证分区文件的完整性,时 OneNote 检测到以下文件的问题:

    filename.one

    该问题可能不是严重,但最好修复时首先检测到任何完整性问题。 OneNote 必须重新启动才能修复文件。
  9. 重新启动 OneNote 之后,单击 确定,当您收到以下消息:
    OneNote 已经修复以下文件:

    Filename.one

    请检查该文件中丢失了一些笔记,就算真的出现。如果缺少任何内容,单击以查看是否有可用的任何备份的文件帮助菜单上的打开备份。如果缺少的笔记已经备份,您可以将它们添加到修复的文件通过复制和粘贴将笔记从备份文件。
  10. 如果您已修复的 OneNote 分区文件中信息正确、 完整,您已完成您的 OneNote 分区文件的修复。

    -或者-如果缺少中您已修复的 OneNote 分区文件信息,则使用方法 3 来恢复丢失的部分文件信息。

方法 3: 从部分中的文件备份中恢复信息

若要从部分中的文件备份中恢复您的信息,请执行以下任一操作:
  • 次要损坏您的信息是否复制并粘贴在丢失或损坏信息从备份副本的分区文件修复后的部分文件。若要这样做,请按照下列步骤操作:
    1. 已修复部分中打开的 帮助 菜单上单击 打开备份
    2. 文件打开 对话框中单击一个 pre-repair 的备份文件,然后单击 打开

      注意您可能需要多个 pre-repair 的备份文件。选择该文件与最新的文件日期和时间时您可以尝试恢复您丢失或损坏的信息。如果此文件不赋予您所必需的信息,请尝试一个不同的文件。
    3. 选择备份部分文件您必须具有,然后单击 打开

      注意您现在有两个出现的节具有相同的名称。 但是,如果将鼠标指针停留在打开的分区选项卡,分区选项卡的工具提示将有"(备份)"作为该节的名称的一部分。
    4. 在备份部分中选择您已修复部分中缺少的信息。
    5. 编辑 菜单上单击 复制
    6. 在已修复部分包含已损坏或丢失信息将希望显示,替换信息的位置插入点放,然后单击 编辑 菜单上的 粘贴
    7. 重复步骤 4、 5 和 6,直到您已替换您已修复部分中缺少的信息。
    8. 在打开备份部分单击在 文件 菜单上的 关闭
  • 广泛中您已损坏的部分信息是否删除损坏的部分文件,然后打开备份部分中文件的副本。若要这样做,请按照下列步骤操作:
    1. 具有已修复部分中打开、 用鼠标右键单击该节的选项卡,然后单击 删除
    2. 当使用以下提示时,请单击 $
      是否确实要删除以下文件?
    3. 帮助 菜单上单击 打开备份
    4. 文件打开 对话框中单击一个 pre-repair 的备份文件,然后单击 打开

      注意您可能需要多个 pre-repair 的备份文件。选择具有最新的文件日期和时间,当您尝试恢复您丢失或损坏的信息的文件。如果此文件不赋予您所必需的信息,请尝试一个不同的文件。
    5. 选择备份部分文件您必须具有,然后单击 打开
    6. 退出并重新启动 OneNote。
    7. 当您重新启动 OneNote 时,您从您备份部分中的文件恢复部分将被命名为"Section_Name (备份)"。

      若要更改节的名称回其原始名称,用鼠标右键单击在分区选项卡,然后单击 重命名。键入您节的原始名称,然后单击 确定
  • 若要从在 OneNote 2007 中的部分文件备份中恢复您的信息,请按照下列步骤操作:
    1. 文件 菜单上单击 打开备份
    2. 选择要打开,信息部分,然后单击 打开
    3. 单击和保存在节选项卡,然后拖动到一个现有笔记本的部分。

      注意在 Windows Vista 中下面的文件夹位于笔记本的备份副本:
      C:\Users\<user name> \AppData\Local\Microsoft\OneNote\12.0\Backup

属性

文章编号: 825779 - 最后修改: 2008年2月18日 - 修订: 8.1
这篇文章中的信息适用于:
  • Microsoft Office OneNote 2003
  • Microsoft Office OneNote 2007
关键字:?
kbmt kbinfo kbcorrupt kbhowto KB825779 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 825779
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com