Help and Support

Numéro d'article: 825803 - Dernière mise à jour: mercredi 29 septembre 2004 - Version: 1.3

Impossible d'ouvrir une URL MHTML après l'installation du correctif cumulatif pour Outlook Express daté d'avril 2003

Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).
Agrandir tout | Réduire tout

Symptômes

Si les conditions suivantes sont remplies
  • Vous utilisez l'une des versions de Microsoft Outlook Express répertoriées au début de cet article.

    - et -
  • Vous avez installé le correctif cumulatif pour Outlook Express daté d'avril 2003.
et que vous cliquez sur une URL semblable à l'une des suivantes
mhtml:file://<chemin>\test.eml

- ou -

<chemin>\test.eml

- ou -

http://<chemin>/test.eml
l'URL ne s'ouvre pas comme prévu et un message d'erreur de syntaxe s'affiche indiquant que la page est introuvable.

Cause

Ce problème se produit car le correctif cumulatif pour Outlook Express daté d'avril 2003 bloque le type d'URL MHTML (MIME Encapsulation of Aggregate HTML).

Remarque MHTML est une norme Internet définissant la structure MIME permettant d'envoyer du contenu HTML (Hypertext Markup Language) dans les corps des messages électroniques. Le gestionnaire d'URL MHTML de Microsoft Windows fait partie intégrante d'Outlook Express et offre un type d'URL pouvant être utilisé sur l'ordinateur local. Avec le type d'URL (MHTML://), vous pouvez démarrer des documents en cliquant sur Démarrer, Exécuter, puis en tapant une ligne de commande dans la zone Ouvrir dans l'Explorateur Microsoft Windows ou dans Microsoft Internet Explorer.

Pour plus d'informations sur la façon dont le correctif cumulatif pour Outlook Express daté d'avril 2003 bloque le type d'URL MHTML, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
330994  (http://support.microsoft.com/kb/330994/ ) MS03-014 : Correctif cumulatif pour Outlook Express daté d'avril 2003

Contournement

Pour contourner ce problème, renommez le fichier .EML auquel renvoie l'URL pour lui donner une extension .MHT, puis mettez l'URL à jour pour prendre en compte le changement de nom du fichier. Pour cela, procédez comme suit :
  1. Dans l'Explorateur Windows, recherchez et sélectionnez le fichier .EML auquel renvoie l'URL.
  2. Cliquez avec le bouton droit sur le fichier .EML, puis cliquez sur Renommer.
  3. Changez le nom du fichier .EML pour qu'il utilise une extension .MHT, puis appuyez sur ENTRÉE.
  4. Mettez à jour l'URL qui renvoie au fichier pour prendre en compte la nouvelle extension du fichier.

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés au début de cet article.

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Outlook Express 6.0 sur le système suivant
    • Windows XP Embedded
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 2000 Service Pack 2
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows NT 4.0 Service Pack 6a
    • Microsoft Windows XP Professional
  • Microsoft Outlook Express 5.5
Mots-clés : 
kbnofix kbprb KB825803
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Traductions disponibles

 

Related Support Centers