User of a Disabled Account Is Prompted to Change the Password Before the "Account Has Been Disabled" Message Appears

Article translations Article translations
Article ID: 826133 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

When a user of a disabled user account that is set to require a password change on the next logon tries to log on to the account, the user receives the following message, regardless of whether the password that is provided is correct:
You are required to change your password at first logon.
If the password that is provided is correct and the user changes the password, the user receives the following message:
Your account has been disabled. Please see your system administrator.
Note When a user tries to log on to a disabled account, the expected behavior is that the "account has been disabled" message is displayed immediately.

CAUSE

This problem occurs because Windows uses incorrect priorities when it processes the logon of a disabled account.

RESOLUTION

Windows 2003

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
There are no prerequisites to install this hotfix.
Restart Requirement
You must restart your computer after you apply this hotfix.
Hotfix Replacement Information
This hotfix does not replace any other hotfixes.
File Information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size     File name  Platform
   -------------------------------------------------------------
   12-Aug-2003  22:47  5.2.3790.77  225,792  Kdcsvc.dll X86
   12-Aug-2003  22:47  5.2.3790.77  584,704  Kdcsvc.dll Ia64

Windows 2000

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must install Microsoft Windows 2000 Service Pack 3 (SP3) before installing this hotfix. For additional information about how to obtain the latest service pack, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack
Restart Requirement
You must restart your computer after you apply this hotfix.
Hotfix Replacement Information
This hotfix does not replace any other hotfixes.
File Information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   03-Sep-2003  21:54  5.0.2195.6748     124,688  Adsldp.dll       
   03-Sep-2003  21:54  5.0.2195.6748     132,368  Adsldpc.dll      
   03-Sep-2003  21:54  5.0.2195.6748      63,760  Adsmsext.dll     
   03-Sep-2003  21:54  5.0.2195.6815     381,712  Advapi32.dll
   03-Sep-2003  21:54  5.0.2195.6753      69,392  Browser.dll      
   03-Sep-2003  21:54  5.0.2195.6815     136,464  Dnsapi.dll       
   03-Sep-2003  21:54  5.0.2195.6780      96,528  Dnsrslvr.dll
   03-Sep-2003  21:54  5.0.2195.6810      47,376  Eventlog.dll     
   03-Sep-2003  21:54  5.0.2195.6815     148,240  Kdcsvc.dll       
   18-Jun-2003  17:43  5.0.2195.6758     205,072  Kerberos.dll
   26-Mar-2003  21:37  5.0.2195.6695      71,888  Ksecdd.sys
   01-Aug-2003  17:40  5.0.2195.6797     509,712  Lsasrv.dll
   01-Aug-2003  17:40  5.0.2195.6797      33,552  Lsass.exe
   17-Jul-2003  23:13  5.0.2195.6786     109,840  Msv1_0.dll       
   03-Sep-2003  21:54  5.0.2195.6601     311,568  Netapi32.dll
   03-Sep-2003  21:54  5.0.2195.6791     361,232  Netlogon.dll
   03-Sep-2003  21:54  5.0.2195.6810     931,600  Ntdsa.dll
   03-Sep-2003  21:54  5.0.2195.6815     392,464  Samsrv.dll
   03-Sep-2003  21:54  5.0.2195.6815     113,936  Scecli.dll
   03-Sep-2003  21:54  5.0.2195.6815     259,856  Scesrv.dll       
   03-Sep-2003  21:54  5.0.2195.6601      51,472  W32time.dll
   16-Aug-2002  13:32  5.0.2195.6601      57,104  W32tm.exe
   03-Sep-2003  21:54  5.0.2195.6741     126,224  Wldap32.dll

Note This hotfix is a server-side hotfix that should be applied to all authenticating domain controllers.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New Naming Schema for Microsoft Windows Hotfix Packages

Properties

Article ID: 826133 - Last Review: July 24, 2007 - Revision: 3.10
APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbhotfixserver kbwin2000presp5fix kbbug kbfix kbqfe kbwinserv2003presp1fix KB826133

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com