Jak edytować rejestr systemu Windows w celu wyczyszczenia listy ostatnio używanych plików w pakiecie Office

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 826208 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Ten artykuł jest konsolidacją następującego dostępnego wcześniej artykułu: 312968

Ważne Ten artykuł zawiera informacje dotyczące modyfikowania rejestru. Przed zmodyfikowaniem rejestru wykonaj jego kopię zapasową i upewnij się, że wiesz, jak przywrócić rejestr w przypadku pojawienia się problemu. Aby uzyskać więcej informacji dotyczących wykonywania kopii zapasowej, przywracania i modyfikowania rejestru, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322756 Jak wykonywać kopię zapasową rejestru, edytować go i przywracać w systemach Windows XP i Windows Server 2003
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

Aby wyczyścić listę ostatnio używanych plików wyświetlaną w większości programów pakietu Microsoft Office, wystarczy dokonać edycji jednego wpisu rejestru.

W wielu programach pakietu Office jest prowadzona lista ostatnio używanych plików. Ponadto lista ta jest wyświetlana w menu Plik i w kilku innych miejscach tych programów. Te miejsca obejmują między innymi okna dialogowe Otwieranie, Zapisywanie jako i Wstawianie hiperłącza.

Celem tej funkcji jest zapewnianie szybkiego dostępu do plików, z którymi użytkownik pracuje. Z troski o poufność danych wielu użytkowników i administratorów woli, aby lista ta nie była wyświetlana.

Chociaż można zapobiec wyświetlaniu listy, w menu Plik programów nie ma wbudowanej metody usuwania tej listy ani zapobiegania jej wyświetlaniu w innych miejscach. Można jednak dokonać edycji rejestru systemu Microsoft Windows, aby wyczyścić tę listę.

Uwaga: W tym artykule opisano sposób usuwania plików wyświetlanych na liście, która pojawia się, gdy użytkownik kliknie menu Plik, kliknie polecenie Otwórz lub Zapisz jako, a następnie przegląda pole Nazwa pliku. Gdy zostaną wykonane kroki opisane w tym artykule, w polu Nazwa pliku nie będą wyświetlane żadne pliki.

W tym artykule nie omówiono metody usuwania plików, których lista pojawia się w menu Plik. Aby to zrobić, należy zmienić ustawienia menu Plik w pakiecie Office lub w programie pakietu Office XP. Aby uzyskać więcej informacji dotyczących sposobu zmiany ustawień programu pakietu Office, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
313454 How to clear the Most Recently Used list (MRU) list in Office programs
W tym artykule nie omówiono sposobu zapobiegania zapisywaniu skrótów dla ostatnio używanych plików w lokalizacji określonej przez wpis rejestru
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\General\RecentFiles
. Domyślnie jest to lokalizacja C:\Documents and Settings\<profil użytkownika>\Application Data\Microsoft\Office\Recent.

Usuwanie listy ostatnio używanych plików w pakiecie Office

Uwaga: Jeżeli opcja Ostatnio używane pliki nie jest zaznaczona na karcie Ogólne w oknie dialogowym Opcje w programach pakietu Office 2000, Office XP lub Office 2003, program Word kontynuuje zapisywanie skrótów w lokalizacji domyślnej. Domyślna lokalizacja jest następująca:
C:\Documents and Settings\<profil użytkownika>\Application Data\Microsoft\Office\Recent
Lokalizacja domyślna jest określona przez następujący wpis rejestru:
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\General\RecentFiles
Aby usunąć listę ostatnio używanych plików w pakiecie Microsoft Office XP lub Microsoft Office 2003, wykonaj następujące kroki:
  1. Uruchom program, który chcesz zmodyfikować.
  2. W menu Narzędzia kliknij polecenie Opcje.
  3. Na karcie Ogólne wyczyść pole wyboru Ostatnio używane pliki, a następnie kliknij przycisk OK.
Aby usunąć listę ostatnio używanych plików w pakiecie Microsoft Office 2007, wykonaj następujące kroki:
  1. Uruchom program, który chcesz zmodyfikować.
  2. Kliknij Przycisk Microsoft Office, a następnie kliknij polecenie Opcje programu Nazwa programu.

    Uwaga: Nazwa programu jest nazwą programu, który chcesz zmodyfikować.
  3. Kliknij przycisk Zaawansowane.
  4. Kliknij w obszarze Wyświetlanie, aby wybrać liczbę plików z listy Pokaż tę liczbę niedawno używanych dokumentów.
  5. Podaj liczbę plików, które mają być wyświetlane, a następnie kliknij przycisk OK.
    Jeśli żadne pliki mają nie być wyświetlane, wpisz 0.
Aby zmodyfikować klucz rejestru i wyczyścić listę ostatnio używanych plików w programie pakietu Office, wykonaj następujące kroki.

Ostrzeżenie Niepoprawne zmodyfikowanie rejestru przy użyciu Edytora rejestru lub innej metody może stać się przyczyną poważnych problemów. Mogą one wymagać ponownego zainstalowania systemu operacyjnego. Firma Microsoft nie może zagwarantować, że rozwiązanie tych problemów będzie możliwe. Można modyfikować rejestr na własną odpowiedzialność.
  1. Kliknij przycisk Start, kliknij polecenie Uruchom, wpisz regedit w polu Otwórz, a następnie kliknij przycisk OK.
  2. Zlokalizuj następujący klucz rejestru odpowiadający danej wersji pakietu Office:
    Pakiet Office 2007
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Open Find
    Pakiet Office 2003
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\Open Find
    Pakiet Office XP
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Common\Open Find
  3. W podkluczu Open Find zlokalizuj program, w którym chcesz wyczyścić listę ostatnio używanych plików.

    W każdym podkluczu znajduje się następny podklucz o nazwie Settings. W tym podkluczu znajduje się kilka dodatkowych podkluczy. Każdy z tych podkluczy zawiera listę ostatnio używanych plików.

    Na przykład podklucz Microsoft Office Word\Settings zawiera podklucze (zależnie od czynności wykonanych w programie Microsoft Word), takie jak Wstawianie pliku, Zapisz jako, Otwórz czy Modyfikowanie lokalizacji. Klucze te mogą być różne, w zależności od operacji ostatnio wykonywanych w programie Microsoft Word.

    W każdym podkluczu znajduje się następny podklucz o nazwie File Name MRU.
  4. Aby usunąć określoną listę ostatnio używanych plików, usuń wpis Value w podkluczu File Name MRU.

Rozwiązywanie problemów

Pakiet Office 2003 odtwarza podklucz File Name MRU po usunięciu go i od nowa zaczyna śledzić ostatnio używane pliki. Dlatego należy co pewien czas usuwać te listy.

Można także utworzyć plik rejestru (.reg), eksportując ten podklucz rejestru w Edytorze rejestru. Plik rejestru może służyć do automatycznego stosowania ustawień rejestru (w tym przypadku do usuwania listy ostatnio używanych plików).

Można także usunąć cały podklucz Open Find (lub utworzyć plik rejestru, który robi to automatycznie), aby usunąć wszystkie listy ostatnio używanych plików naraz.

Właściwości

Numer ID artykułu: 826208 - Ostatnia weryfikacja: 12 czerwca 2008 - Weryfikacja: 6.1
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Access 2007
  • Microsoft Office Excel 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Word 2007
  • Microsoft Office Access 2003
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Word 2003
  • Microsoft Access 2002 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Słowa kluczowe: 
kbhowtomaster KB826208

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com