Sie können nicht entfernen oder aktualisieren einen NDIS-intermediate-Treiber, der eine Notify Object DLL in Windows 2000 erfordert

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Artikel-ID: 826219 - Produkte anzeigen, auf die sich dieser Artikel bezieht
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Problembeschreibung

Wenn Sie versuchen, zu entfernen oder um einen Netzwerk Treiber Schnittstelle Spezifikation (NDIS) intermediate Treiber aktualisieren, der eine Notify Object DLL erfordert, können Sie in Microsoft Windows 2000 die folgenden Symptome auftreten:
  • Wenn Sie öffnen das Dialogfeld Eigenschaften des Geräts im Element Netzwerk- und DFÜ-Netzwerkverbindungen der Systemsteuerung, und klicken Sie auf Deinstallieren , um das Gerät zu entfernen, wird der Gerätetreiber erfolgreich entfernt werden. Bleibt jedoch den Gerätetreiber DLL-Datei im Ordner %Windir%\System32.
  • Wenn Sie versuchen, den Treiber DLL-Datei aus dem Ordner %Windir%\System32 löschen, wird sinngemäß folgende Fehlermeldung:
    filename kann nicht gelöscht: Zugriff verweigert. Die Quelldatei möglicherweise verwendet.
  • Wenn Sie versuchen, eine andere Version des Treibers, enthält eine aktualisierte Kopie der Notify Object DLL oder, enthält eine frühere Kopie der Notify Object DLL, zu installieren, wird die neue Datei nicht über die vorherige Datei kopiert.

Ursache

Dieses Problem, wenn der NDIS-intermediate-Treiber für die Installation einer Notify Object DLL erfordert. Die Notify Object DLL wird nicht aus dem Speicher entfernt, wenn Sie die Netzwerkkomponente entfernen, der er gehört. Aus diesem Grund können nicht Sie die DLL-Datei aus Ordner %Windir%\System32 entfernen.

In diesem Szenario wird der Gerätetreiber nicht wurde registriert sich selbst aus der Registrierung und hat gemeldet, dass es entladen werden kann. Allerdings ist die Notify Object DLL noch im Speicher gesperrt.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, senden Sie eine Anfrage an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Für die Installation dieses Hotfixes gelten keine Voraussetzungen.

Neustartanforderung

Sie müssen Ihren Computer nicht neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time () angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools ? Datum und Uhrzeit in der Systemsteuerung.
   Date         Time   Version             Size  File name
   ---------------------------------------------------------
   23-Mar-2004  23:31  5.0.2195.6628    837,120  Netcfgx.dll      
   11-Mar-2004  15:17  5.0.2195.6901  1,072,128  Ole32.dll        
   11-Mar-2004  17:43                    72,090  Ole32.lib
   11-Mar-2004  15:17  5.0.2195.6901    239,104  Rpcss.dll

Status

Microsoft hat bestätigt, dass dies ein Problem in den Microsoft-Produkten ist, die im Abschnitt "Gilt für" dieses Artikels aufgeführt sind.

Weitere Informationen

Weitere Informationen über neue Namensschema für Microsoft Windows-Softwareupdatepakete finden Sie die folgende KB-Artikelnummer:
816915Neues Namensschema für Microsoft Windows-Softwareupdatepakete
Weitere Informationen zur Terminologie, die in diesem Artikel verwendet wird, finden Sie die folgende KB-Artikelnummer:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 826219 - Geändert am: Dienstag, 11. Februar 2014 - Version: 2.4
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB826219 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 826219
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