Τρόπος αντιμετώπισης κατεστραμμένων σχέδια στο Visio

Μεταφράσεις άρθρων Μεταφράσεις άρθρων
Αναγν. άρθρου: 826418 - Δείτε τα προϊόντα στα οποία αναφέρεται το συγκεκριμένο άρθρο.
Ανάπτυξη όλων | Σύμπτυξη όλων

Σε αυτήν τη σελίδα

Περίληψη

Αυτό το άρθρο περιγράφει τον τρόπο αντιμετώπισης κατεστραμμένων σχέδια στο Microsoft Office Visio 2013, Visio 2010, Visio 2007, Microsoft Office Visio 2003 και Microsoft Visio 2002. Αυτό το άρθρο περιγράφει ορισμένα συμπτώματα που μπορεί να υποδηλώνει ότι έχει καταστραφεί το σχέδιο που εργάζεστε στο Visio.

Επιπλέον, αυτό το άρθρο παραθέτει ορισμένες μεθόδους αποκατάστασης που μπορείτε να χρησιμοποιήσετε στο σχέδιο είναι κατεστραμμένο. Περιλαμβάνουν γενικές μεθόδους αντιμετώπισης προβλημάτων, μεθόδους για να δοκιμάσετε εάν μπορεί ή δεν μπορεί να ανοίξει το σχέδιο και μεθόδους για να βοηθήσει στην αποτροπή βλάβης που ενδέχεται να προκύψουν σε σχέδια.

ΕΙΣΑΓΩΓΗ

Επισκόπηση

Εάν αντιμετωπίζετε απροσδόκητη συμπεριφορά όταν εργάζεστε με ένα σχέδιο του Visio, ίσως είναι κατεστραμμένο το σχέδιο του Visio. Εάν έχετε ένα σχέδιο είναι κατεστραμμένο, ενδέχεται να λάβετε τα ακόλουθα μηνύματα λάθους:
  • "Σφάλμα μη έγκυρης σελίδας", "Γενικό σφάλμα προστασίας" ή μηνύματα λάθους "Εσφαλμένη οδηγία"
  • Μηνύματα λάθους που είναι παρόμοιο με το ακόλουθο, όταν ανοίγετε ένα σχέδιο:

    Παρουσιάστηκε το σφάλμα (100) κατά τη διάρκεια της ενέργειας Άνοιγμα

    Το Visio δεν είναι δυνατό να ανοίξει το αρχείο, επειδή δεν είναι αρχείο του Visio ή έχει καταστραφεί.
  • Μηνύματα λάθους "δεν μνήμη" ή μηνύματα λάθους που υποδεικνύουν οι πόροι συστήματος δεν επαρκούν.
Σημείωση Αυτά τα μηνύματα λάθους σημαίνει πάντα ότι το σχέδιό σας είναι κατεστραμμένο. Ωστόσο, εάν επανειλημμένα αντιμετωπίζετε ένα ή περισσότερα από αυτά τα μηνύματα λάθους κατά την εργασία με ένα συγκεκριμένο σχέδιο, το σχέδιο αυτό μπορεί να είναι κατεστραμμένο.

Αυτό το άρθρο παραθέτει ορισμένες μεθόδους που μπορείτε να χρησιμοποιήσετε για να προσπαθήσετε να ανακτήσετε το σχέδιο είναι κατεστραμμένο. Τις μεθόδους που περιγράφονται σε αυτό το άρθρο δεν εγγυώνται την αποκατάσταση με επιτυχία ενός σχεδίου είναι κατεστραμμένο. Μερικές φορές, ανάλογα με τον τύπο της βλάβης, που ενδέχεται να μην μπορείτε να ανακτήσετε τα δεδομένα. Ίσως χρειαστεί να δημιουργήσετε εκ νέου το σχέδιο ή να επαναφέρετε το σχέδιο από τα αρχεία αντιγράφων ασφαλείας.

Γενικές μεθόδους αντιμετώπισης προβλημάτων

Έναρξη Visio χωρίς συμβάντα αυτοματισμού και χωρίς Microsoft Visual Basic for Applications

Ξεκινήστε το Visio χωρίς συμβάντα αυτοματισμού και χωρίς Visual Basic for Applications. Για να γίνει αυτό, χρησιμοποιήστε μία από τις ακόλουθες μεθόδους:

Μέθοδος 1: Το Microsoft Office Visio 2013 και Visio 2010
  1. Εκκίνηση του Visio.
  2. Σχετικά με το αρχείο καρτέλα, κάντε κλικ στο κουμπί Επιλογέςκαι στη συνέχεια κάντε κλικ στην επιλογή Κέντρο αξιοπιστίας.
  3. Κάντε κλικ στην επιλογή ρυθμίσεις του Κέντρου αξιοπιστίαςκαι, στη συνέχεια, κάντε κλικ στο κουμπί Απενεργοποίηση όλων των μακροεντολών χωρίς ειδοποίηση.
  4. Κάντε κλικ στην επιλογή " πρόσθετα".
  5. Κάντε κλικ για να επιλέξετε το απενεργοποιήσετε όλα πρόσθετα εφαρμογής πλαίσιο ελέγχου.
  6. Κάντε κλικ στο κουμπί OK.
  7. Κλείστε το Visio και στη συνέχεια, κάντε επανεκκίνηση του Visio.

Μέθοδος 2: Το Microsoft Office Visio 2007
  1. Κανονική εκκίνηση του Visio.
  2. Στο μενού Εργαλεία , κάντε κλικ στο κουμπί " Κέντρο αξιοπιστίας".
  3. Κάντε κλικ στην επιλογή Ρυθμίσεις μακροεντολώνκαι, στη συνέχεια, κάντε κλικ στο κουμπί Απενεργοποίηση όλων των μακροεντολών χωρίς ειδοποίηση.
  4. Κάντε κλικ στην επιλογή " πρόσθετα".
  5. Κάντε κλικ για να επιλέξετε το πλαίσιο ελέγχου Απενεργοποίηση όλα πρόσθετα εφαρμογής .
  6. Κάντε κλικ στο κουμπί OK.
  7. Κλείστε το Visio και στη συνέχεια, κάντε επανεκκίνηση του Visio.
Μέθοδος 3: Microsoft Office Visio 2003 και παλαιότερες εκδόσεις του Visio
  1. Κανονική εκκίνηση του Visio.
  2. Χρησιμοποιήστε μία από τις ακόλουθες διαδικασίες, ανάλογα με την έκδοση του Visio που εκτελείτε:
    • Εάν εκτελείτε το Visio 2003, κάντε κλικ στο κουμπί " Επιλογές " στο μενού Εργαλεία και στη συνέχεια κάντε κλικ στην καρτέλα ασφάλεια .
    • Εάν εκτελείτε το Visio 2002, κάντε κλικ στο κουμπί " Επιλογές " στο μενού Εργαλεία και στη συνέχεια κάντε κλικ στην καρτέλα για προχωρημένους .
  3. Κάντε τα εξής:
    • Κάντε κλικ για να καταργήσετε το πλαίσιο ελέγχου Ενεργοποίηση της Microsoft Visual Basic for Applications .

      Σημείωση Αφού κάνετε κλικ για να καταργήσετε το πλαίσιο ελέγχου Ενεργοποίηση της Microsoft Visual Basic for Applications , είναι πλέον διαθέσιμο το πλαίσιο ελέγχου Ενεργοποίηση της Microsoft Visual Basic για εφαρμογές δημιουργίας του έργου και την επιλογή του πλαισίου ελέγχου Φόρτωση Microsoft Visual Basic για εφαρμογές έργο από το κείμενο .
    • Κάντε κλικ για να καταργήσετε την επιλογή του πλαισίου ελέγχου προσθέτων COM επιτρέπουν .
    • Κάντε κλικ για να καταργήσετε το πλαίσιο ελέγχου " Ενεργοποίηση συμβάντων αυτοματισμού ".
  4. Κάντε κλικ στο κουμπί OKκαι, στη συνέχεια, κλείστε το Visio.
  5. Κάντε επανεκκίνηση του Visio.
Μέθοδος 4: Χρήση της εντολής "Αντιγραφή σχεδίασης" για να αντιγράψετε κάθε σελίδα σε μια σελίδα σε ένα νέο σχέδιο.
Για το Visio 2013 και Visio 2010:
  1. Βεβαιωθείτε ότι έχει επιλεγεί τίποτα στο σχέδιο.
  2. Σχετικά με το Home καρτέλα, στην περιοχή το Πρόχειρο ομάδα, κάντε κλικ στο κουμπί Αντιγραφή.
  3. Ανοίξτε το έγγραφο στο οποίο θέλετε να ενσωματώσετε το σχέδιο και, στη συνέχεια, στην καρτέλααρχική , στην ομάδα Πρόχειρο , κάντε κλικ στην εντολή Επικόλληση.
Για το Visio 2007 και Visio 2003:
  1. Στο Microsoft Office Visio σχέδιο, βεβαιωθείτε ότι τίποτα δεν είναι επιλεγμένο.
  2. Στο μενού Επεξεργασία , κάντε κλικ στο κουμπί Αντιγραφή σχεδίασης. Σημείωση Αυτή η εντολή αντιγράφει ολόκληρο το σχέδιο, συμπεριλαμβανομένων και σχημάτων σε άλλες σελίδες σχεδίου και σε εικόνες φόντου. Όταν ενσωματώνετε ένα σχέδιο Visio πολλαπλών σελίδων, η ορατή σελίδα θα είναι εκείνη που είναι ενεργή, όταν κάνετε κλικ στο κουμπί Αντιγραφή σχεδίασης.
  3. Ανοίξτε το έγγραφο που θέλετε να ενσωματώσετε το σχέδιο, και στη συνέχεια από το Επεξεργασία μενού, κάντε κλικ στο κουμπί Επικόλληση (ή στην ισοδύναμη εντολή).
    Προέλευση: Visio 2007 Βοήθεια και οδηγίεςhttp://Office.Microsoft.com/en-US/Visio/HP012314701033.aspx

Εκκίνηση των Windows σε ασφαλή λειτουργία

Εκκίνηση των Windows σε ασφαλή λειτουργία. Για να γίνει αυτό:

Σημείωση Επειδή υπάρχουν διάφορες εκδόσεις των Microsoft Windows, τα ακόλουθα βήματα ενδέχεται να διαφέρουν στον υπολογιστή σας. Σε αυτήν την περίπτωση, ανατρέξτε στην τεκμηρίωση του προϊόντος σας για να ολοκληρώσετε αυτά τα βήματα.
  1. Τερματίστε και ξεκινήστε πάλι τον υπολογιστή.
  2. Όταν εμφανιστεί το μήνυμα "Επιλέξτε το λειτουργικό σύστημα για εκκίνηση", πιέστε το πλήκτρο F8.
  3. Σχετικά με το Επιλογές για προχωρημένους των Windows<b00> </b00> μενού, χρησιμοποιήστε τα πλήκτρα ΒΈΛΟΥΣ για να επιλέξετε την Ασφαλή λειτουργίακαι, στη συνέχεια, πιέστε το πλήκτρο ENTER.
  4. Εάν έχετε έναν υπολογιστή διπλής εκκίνησης ή πολλαπλής εκκίνησης, επιλέξτε το κατάλληλο λειτουργικό σύστημα από τη λίστα που εμφανίζεται και, στη συνέχεια, πιέστε το πλήκτρο ENTER.
  5. Ξεκινήστε το Visio και στη συνέχεια προσπαθήστε να ανοίξετε το σχέδιό σας.
Για περισσότερες πληροφορίες σχετικά με την ασφαλή λειτουργία, κάντε κλικ στους αριθμούς των άρθρων παρακάτω, για να προβάλετε τα άρθρα της Γνωσιακής Βάσης της Microsoft:
315222 Περιγραφή των επιλογών εκκίνησης σε ασφαλή λειτουργία στα Windows XP
202485 Περιγραφή της εκκίνησης σε ασφαλή λειτουργία στα Windows 2000
180902 Πώς να ξεκινήσετε έναν υπολογιστή με Windows 98 σε ασφαλή λειτουργία

Μεθόδους για να δοκιμάσετε αν δεν μπορείτε να ανοίξετε ένα σχέδιο

Μέθοδος 1: Σύρετε το αρχείο σχεδίασης με το εικονίδιο του αρχείου Visio.exe

Σύρετε το αρχείο σχεδίασης στο εικονίδιο που αντιπροσωπεύει το αρχείο Visio.exe. Για να γίνει αυτό: Εάν εκτελείτε το Visio 2010, το αρχείο Visio.exe βρίσκεται στον ακόλουθο φάκελο: μονάδα δίσκου: \Program Files\Microsoft Office\Office14, * εάν έχετε εγκαταστήσει το Visio 32-bit σε Windows 64-bit θα πρέπει το φάκελο Program Files α (x 86) πίσω από το όνομα του φακέλου. Τώρα, το Visio 2010 έχει μια εγγενή έκδοση 64-bit.
  1. Κλείστε το Visio.
  2. Ξεκινήστε την Εξερεύνηση των Windows και, στη συνέχεια, εντοπίστε το αρχείο Visio.exe στον σκληρό σας δίσκο. Εάν εγκαταστήσατε το Visio στην προεπιλεγμένη θέση, το αρχείο Visio.exe βρίσκεται σε έναν από τους ακόλουθους φακέλους, ανάλογα με την έκδοση του Visio που εκτελείτε:
    • Εάν εκτελείτε το Visio 2013, το αρχείο Visio.exe βρίσκεται στον ακόλουθο φάκελο:
      Μονάδα δίσκου: \Program Files\Microsoft Office\Office15
      ΣημείωσηΕάν έχετε εγκαταστήσει μια έκδοση 32-bit του Visio σε μια έκδοση 64-bit των Windows, ο φάκελος Program Files θα έχει ένα (x 86) πίσω από το όνομα του φακέλου. Τώρα, το Visio 2013 έχει μια εγγενή έκδοση 64-bit.
    • Εάν εκτελείτε το Visio 2010, το αρχείο Visio.exe βρίσκεται στον ακόλουθο φάκελο: μονάδα δίσκου: \Program Files\Microsoft Office\Office14 Σημείωση , εάν έχετε εγκαταστήσει μια έκδοση 32-bit του Visio σε μια έκδοση 64-bit των Windows, ο φάκελος Program Files θα έχει ένα (x 86) πίσω από το όνομα του φακέλου. Τώρα, το Visio 2010 έχει μια εγγενή έκδοση 64-bit.


      Εάν εκτελείτε το Visio 2007, το αρχείο Visio.exe βρίσκεται στον ακόλουθο φάκελο:
      Μονάδα δίσκου: \Program Files\Microsoft Office\Office12
      Εάν εκτελείτε το Visio 2003, το αρχείο Visio.exe βρίσκεται στον ακόλουθο φάκελο:
      Μονάδα δίσκου: \Program Files\Microsoft Office\Visio11
    • Εάν εκτελείτε το Visio 2002, το αρχείο Visio.exe βρίσκεται στον ακόλουθο φάκελο:
      Μονάδα δίσκου: \Program Files\Microsoft Office\Visio10
      Σημείωση Εάν εγκαταστήσατε το Visio σε ένα φάκελο που είναι διαφορετικός από την προεπιλεγμένη θέση εγκατάστασης, η διαδρομή του αρχείου Visio.exe είναι διαφορετική στον υπολογιστή σας.
  3. Στην Εξερεύνηση των Windows, εντοπίστε το αρχείο σχεδίασης που θέλετε να ανοίξετε.
  4. Σύρετε το αρχείο σχεδίασης στο εικονίδιο που αντιπροσωπεύει το αρχείο Visio.exe.

Μέθοδος 2: Κάντε διπλό κλικ στο αρχείο σχεδίασης στην Εξερεύνηση των Windows

Δοκιμάστε να ανοίξετε το αρχείο σχεδίασης χρησιμοποιώντας την Εξερεύνηση των Windows. Για να γίνει αυτό:
  1. Κλείστε το Visio.
  2. Ξεκινήστε την Εξερεύνηση των Windows και, στη συνέχεια, εντοπίστε το αρχείο σχεδίασης που θέλετε να ανοίξετε.
  3. Κάντε διπλό κλικ στο αρχείο σχεδίασης.

Μέθοδος 3: Ανοίξτε το προσωρινό αντίγραφο του αρχείου σχεδίασης

Όταν τροποποιείτε ένα σχέδιο του Visio, δημιουργείται ένα προσωρινό αντίγραφο του αρχείου σχεδίασης. Το προσωρινό αντίγραφο του αρχείου σχεδίασης που ονομάζεται ~ $$Όνομα αρχείου. ~ vsd. Το προσωρινό αντίγραφο του αρχείου σχεδίασης συνήθως δημιουργείται και αποθηκεύεται στον ίδιο φάκελο ως όπου βρίσκεται το σχέδιό σας.

Για να ανοίξετε το προσωρινό αντίγραφο του αρχείου σχεδίασης, κάντε τα εξής:
  1. Ξεκινήστε το Visio και στη συνέχεια ανοίξτε το σχέδιό σας.
  2. Ξεκινήστε τον Windows Explorer και, στη συνέχεια, εντοπίστε το φάκελο όπου είναι αποθηκευμένο το σχέδιό σας. Αναζήτηση σε αυτόν το φάκελο για το προσωρινό αντίγραφο του αρχείου σχεδίασης. Το προσωρινό αντίγραφο του αρχείου σχεδίασης που ονομάζεται ~ $$Όνομα αρχείου. ~ vsd.

    Σημείωση Εάν το προσωρινό αντίγραφο του αρχείου σχεδίασης δεν βρίσκεται στο φάκελο όπου είναι αποθηκευμένο το σχέδιό σας, αναζητήστε το σκληρό δίσκο για το προσωρινό αντίγραφο του αρχείου σχεδίασης.

    Για να αναζητήσετε το σκληρό δίσκο για το προσωρινό αντίγραφο του αρχείου σχεδίασης, κάντε τα εξής:

    Σημείωση Επειδή υπάρχουν διάφορες εκδόσεις των Microsoft Windows, τα ακόλουθα βήματα ενδέχεται να διαφέρουν στον υπολογιστή σας. Σε αυτήν την περίπτωση, ανατρέξτε στην τεκμηρίωση του προϊόντος σας για να ολοκληρώσετε αυτά τα βήματα.
    1. Κάντε κλικ στο κουμπί Έναρξηκαι, στη συνέχεια, κάντε κλικ στο κουμπί Αναζήτηση.
    2. Κάντε κλικ στην επιλογή όλα τα αρχεία και τους φακέλους.
    3. Στο πλαίσιο ολόκληρο ή μέρος του ονόματος αρχείου , πληκτρολογήστε ~$$Όνομα αρχείου. ~ vsd, και στη συνέχεια κάντε κλικ στο κουμπί Αναζήτηση.
  3. Αλλάξτε την επέκταση από το προσωρινό αντίγραφο του αρχείου σχεδίασης σε .vsd. Για να γίνει αυτό:
    1. Κάντε δεξιό κλικ στο προσωρινό αντίγραφο του αρχείου σχεδίασης και, στη συνέχεια, κάντε κλικ στην εντολή Μετονομασία.
    2. Αλλάξτε την επέκταση από το προσωρινό αντίγραφο του αρχείου σχεδίασης από ~.vsd σε .vsd.
  4. Δοκιμάστε να ανοίξετε το προσωρινό αντίγραφο του αρχείου σχεδίασης που μετονομάσατε.

Μέθοδος 4: Χρησιμοποιήστε το πρόγραμμα προβολής του Microsoft Office Visio για να ανοίξετε το σχέδιο

Εγκατάσταση του Microsoft Office Visio Viewer 2010 και, στη συνέχεια, χρησιμοποιήστε το πρόγραμμα προβολής του Visio για να ανοίξετε και να προβάλετε το σχέδιό σας. Κατά την εγκατάσταση του Visio Viewer 2010, μπορείτε να χρησιμοποιήσετε την Microsoft Internet Explorer 5.0 ή νεότερη έκδοση του Internet Explorer, για να προβάλετε το Visio σχέδια και διαγράμματα που δημιουργούνται στο Visio 2010, Visio 2007, το Visio 2003, το Visio 2002, Microsoft Visio 2000 ή Microsoft Visio 5. Για περισσότερες πληροφορίες σχετικά με το Visio Viewer 2010, επισκεφθείτε την ακόλουθη τοποθεσία της Microsoft στο Web:

http://www.Microsoft.com/en-US/Download/Details.aspx?displaylang=en&ID=21701

Εάν μπορείτε να ανοίξετε το σχέδιό σας στο πρόγραμμα προβολής του Visio, η εγκατάσταση του Visio στον υπολογιστή σας ενδέχεται να είναι κατεστραμμένο ή το σχέδιό σας μπορεί να περιέχει ένα ή περισσότερα αντικείμενα που μπορεί να έχει καταστραφεί.

Μέθοδος 5: Αντιγράψτε το αρχείο σχεδίασης σε άλλον υπολογιστή

Αντιγράψτε το αρχείο σχεδίασης σε άλλον υπολογιστή που έχει εγκατεστημένο το Visio. Εάν μπορείτε να ανοίξετε το σχέδιό σας σε αυτόν τον υπολογιστή, αποθηκεύστε το αρχείο σχεδίασης σε ένα διαφορετικό φάκελο του σκληρού δίσκου του υπολογιστή και, στη συνέχεια, αντιγράψτε το αρχείο σχεδίασης στον αρχικό υπολογιστή.

Μέθοδος 6: Αντιγράψτε το αρχείο σχεδίασης σε άλλον δίσκο στον υπολογιστή σας

Τα Windows ενδέχεται να μην μπορέσετε να διαβάσετε το αρχείο σχεδίασης όπου αποθηκεύεται αυτήν τη στιγμή το αρχείο σχεδίασης. Αντιγράψτε το αρχείο σχεδίασης σε άλλον δίσκο στον υπολογιστή σας. Για παράδειγμα, αντιγράψτε το αρχείο από μια δισκέτα στον σκληρό δίσκο. Αφού αντιγράψετε το αρχείο σχεδίασης σε άλλο δίσκο στον υπολογιστή σας, δοκιμάστε να ανοίξετε το αρχείο σχεδίασης.

Σημείωση Εάν δεν μπορείτε να αντιγράψετε το αρχείο σχεδίασης από το δίσκο όπου είναι αποθηκευμένο το αρχείο σχεδίασης, το αρχείο σχεδίασης μπορεί να επικαλύπτεται με άλλα αρχεία ή φακέλους ή το αρχείο σχεδίασης μπορεί να βρίσκεται σε έναν κατεστραμμένο τομέα του δίσκου. Για να αντιμετωπίσετε αυτό το ζήτημα, ακολουθήστε τα βήματα της μεθόδου 7.

Μέθοδος 7: Εντοπισμός και επιδιόρθωση σφαλμάτων στο σκληρό δίσκο

Εάν εκτελείτε Microsoft Windows Server 2003, Microsoft Windows XP, τα Windows 2000 ή Microsoft Windows NT 4.0, χρησιμοποιήστε το εργαλείο Εξέταση Δίσκων για τον εντοπισμό σφαλμάτων του συστήματος αρχείων ή κατεστραμμένους τομείς στον σκληρό σας δίσκο.

Για περισσότερες πληροφορίες, κάντε κλικ στους αριθμούς των άρθρων παρακάτω, για να προβάλετε τα άρθρα της Γνωσιακής Βάσης της Microsoft:
315265 Τρόπος εκτέλεσης ελέγχου στα Windows XP σφαλμάτων δίσκου
156571 Πώς μπορείτε να εκτελέσετε την εξέταση δίσκων στα Windows

Εάν χρησιμοποιείτε Microsoft Windows Millennium Edition (Me) ή Microsoft Windows 98, χρησιμοποιήστε το εργαλείο Scandisk για τον εντοπισμό σφαλμάτων του συστήματος αρχείων ή κατεστραμμένους τομείς στον σκληρό σας δίσκο.

Για περισσότερες πληροφορίες, κάντε κλικ στον αριθμό του άρθρου παρακάτω για να προβάλετε το άρθρο της Γνωσιακής βάσης της Microsoft:
186365 Περιγραφή της εξέτασης δίσκων για Windows (Scandskw.exe) στα Windows 98 / εμένα

Σημείωση Παρόλο που το εργαλείο Εξέταση Δίσκων ή το εργαλείο ScanDisk, να εντοπίσετε και να επιδιορθώσετε σφάλματα του συστήματος αρχείων ή κατεστραμμένους τομείς στον σκληρό δίσκο, το Visio μπορεί να εξακολουθεί να μην μπορεί να ανοίξει ή να αναγνώσει το αρχείο.

Εάν εκτελείτε τα Windows Vista, επισκεφθείτε την ακόλουθη τοποθεσία της Microsoft στο Web για περισσότερες πληροφορίες:
http://windowshelp.Microsoft.com/Windows/EN-US/Help/bc1393cf-9f9c-79c7-0f91-9337c2c41f811033.mspx
Μέθοδος 8: Άνοιγμα προηγούμενου "σκιώδους αντιγράφου" χρησιμοποιώντας την καρτέλα "προηγούμενες εκδόσεις"


1. Κάντε δεξί κλικ στο αρχείο του Visio
2. Επιλέξτε "Ιδιότητες"
3. Επιλέξτε την καρτέλα "προηγούμενες εκδόσεις", δώστε κάποιο χρόνο για τη λίστα για τη συμπλήρωση
4. Επιλέξτε μια παλαιότερη έκδοση του αρχείου
5. Κάντε κλικ στο κουμπί Άνοιγμα
6. Εάν το αρχείο ανοίξει με επιτυχία, από το μενού "αρχείο" κάντε κλικ στο κουμπί Αποθήκευση ως και αποθηκεύστε ένα αντίγραφο του αρχείου



Μεθόδους για να δοκιμάσετε εάν μπορείτε να ανοίξετε το σχέδιο

Μέθοδος 1: Αποθηκεύστε το αρχείο ως ένα σχέδιο XML

Αποθηκεύστε το σχέδιο με ένα σχέδιο XML (αρχείο .vdx) και στη συνέχεια αποθηκεύστε το XML σχεδίασης ως ένα σχέδιο (αρχείο .vsd). Για να γίνει αυτό:
  1. Ξεκινήστε το Visio και στη συνέχεια ανοίξτε το σχέδιό σας.
  2. Στο μενού αρχείο , κάντε κλικ στο κουμπί Αποθήκευση ως.
  3. Στο πλαίσιο διαλόγου " Αποθήκευση ως ", κάντε κλικ στο κουμπί Σχεδίαση XML (*.vdx)<b00> </b00> στο πλαίσιο Αποθήκευση ως τύπου , και στη συνέχεια πληκτρολογήστε ένα όνομα αρχείου στο πλαίσιο όνομα αρχείου . Καθορίστε μια θέση όπου θέλετε να αποθηκεύσετε το αρχείο σχεδίασης και, στη συνέχεια, κάντε κλικ στο κουμπί Αποθήκευση.
  4. Κλείστε όλα τα σχέδια που είναι ανοιχτό αυτήν τη στιγμή.
  5. Στο μενού Αρχείο , κάντε κλικ στο " Άνοιγμα".
  6. Εντοπίστε το σχέδιο XML (.vdx) που αποθηκεύσατε προηγουμένως στο βήμα 3 και, στη συνέχεια, κάντε κλικ στο κουμπί Άνοιγμα.
  7. Στο μενού αρχείο , κάντε κλικ στο κουμπί Αποθήκευση ως.
  8. Στο πλαίσιο διαλόγου " Αποθήκευση ως ", κάντε κλικ στο κουμπί Σχεδίαση (*.vsd)<b00> </b00> στο πλαίσιο Αποθήκευση ως τύπου , και στη συνέχεια πληκτρολογήστε ένα όνομα αρχείου στο πλαίσιο όνομα αρχείου . Καθορίστε μια θέση όπου θέλετε να αποθηκεύσετε το αρχείο σχεδίασης και, στη συνέχεια, κάντε κλικ στο κουμπί Αποθήκευση.
  9. Κλείστε το σχέδιο.
  10. Στο μενού αρχείο , κάντε κλικ στο κουμπί Άνοιγμα
  11. Εντοπίστε το σχέδιο (αρχείο .vsd) που αποθηκεύσατε προηγουμένως στο βήμα 8 και στη συνέχεια κάντε κλικ στο κουμπί Άνοιγμα.

Μέθοδος 2: Εισαγωγή του σχεδίου σε νέο κενό σχέδιο

Εισαγωγή του σχεδίου σε νέο κενό σχέδιο. Για να γίνει αυτό:

Για το Visio 2013 και Visio 2010:
  1. Εκκίνηση του Visio
  2. Κάτω από το αρχείο καρτέλα, στην περιοχή Δημιουργία, επιλέξτε Κενό σχέδιοκαι στη συνέχεια κάντε κλικ τοΔημιουργία κουμπί.
  3. Σχετικά με το Εισαγωγή καρτέλα, κάντε κλικ στο αντικείμενο.
  4. Κάντε κλικ στην επιλογή Δημιουργία από αρχείοκαι, στη συνέχεια, κάντε κλικ στο κουμπί Αναζήτηση.
  5. Selectthe σχεδίασης, κάντε κλικ στο κουμπίΆνοιγμακαι, στη συνέχεια, κάντε κλικ στο κουμπί OK.
  6. Ανάλογα με την κατάστασή σας, να καθορίσετε εάν είναι κατεστραμμένο το αρχείο σχεδίασης ή αν υπάρχει κάποιο άλλο πρόβλημα.
    • Εάν λάβετε ένα "σφάλμα 3400" μήνυμα λάθους, ενδέχεται να είναι κατεστραμμένο το αρχείο σχεδίασης. Χρησιμοποιήστε τις μεθόδους που περιγράφονται σε αυτό το άρθρο για να προσπαθήσετε να ανακτήσετε το σχέδιο.
    • Εάν δεν εμφανιστεί μια "σφάλμα 3400" μήνυμα λάθους, ενδέχεται να υπάρχει κάποιο άλλο ζήτημα που ενδέχεται να εμποδίζουν το άνοιγμα το σχέδιο Visio. Για παράδειγμα, μια διένεξη μπορεί να υπάρχει μεταξύ ορισμένων στοιχείων του υπολογιστή που αποτρέπουν το άνοιγμα το σχέδιο Visio.
Για το Visio 2007 και Visio 2003:
  1. Εκκίνηση του Visio.
  2. Στο μενού αρχείο , επιλέξτε Δημιουργίακαι, στη συνέχεια, κάντε κλικ στην επιλογή Δημιουργία σχεδίου.
  3. Στο μενού " Εισαγωγή ", κάντε κλικ στο αντικείμενο.
  4. Κάντε κλικ στην επιλογή Δημιουργία από αρχείοκαι, στη συνέχεια, κάντε κλικ στο κουμπί Αναζήτηση.
  5. Κάντε κλικ στο σχέδιο, κάντε κλικ στο κουμπί Άνοιγμακαι, στη συνέχεια, κάντε κλικ στο κουμπί OK.
  6. Ανάλογα με την κατάστασή σας, να καθορίσετε εάν είναι κατεστραμμένο το αρχείο σχεδίασης ή αν υπάρχει κάποιο άλλο πρόβλημα.
    • Εάν λάβετε ένα "σφάλμα 3400" μήνυμα λάθους, ενδέχεται να είναι κατεστραμμένο το αρχείο σχεδίασης. Χρησιμοποιήστε τις μεθόδους που περιγράφονται σε αυτό το άρθρο για να προσπαθήσετε να ανακτήσετε το σχέδιο.
    • Εάν δεν εμφανιστεί μια "σφάλμα 3400" μήνυμα λάθους, ενδέχεται να υπάρχει κάποιο άλλο ζήτημα που ενδέχεται να εμποδίζουν το άνοιγμα το σχέδιο Visio. Για παράδειγμα, μια διένεξη μπορεί να υπάρχει μεταξύ ορισμένων στοιχείων του υπολογιστή που αποτρέπουν το άνοιγμα το σχέδιο Visio.
    S

Μεθόδους για να βοηθήσει στην αποτροπή βλάβης σε σχέδια

Δεν μπορείτε να αποτρέψετε όλες καταστροφή που ενδέχεται να προκύψουν σε αρχεία. Σκληροί δίσκοι μπορεί να φθαρεί, τροφοδοτικά ενδέχεται να αποτύχει και άλλα απρόβλεπτα συμβάντα ενδέχεται να προκύψει που προκαλούν τα αρχεία να καταστραφεί. Οι ακόλουθες συμβουλές και προτάσεις μπορεί να σας βοηθήσει να μειώσετε τον αριθμό των κατεστραμμένων αρχείων που παρουσιάζονται στο Visio και σε άλλα προγράμματα.

Βελτιστοποιήστε τη ρύθμιση αυτόματης ανάκτησης στο Visio

Ορίσετε τη ρύθμιση αυτόματης ανάκτησης σε μια τιμή που είναι καλύτερη για εσάς. Εάν ο υπολογιστής σας σταματά να ανταποκρίνεται ή εάν τροφοδοσία διακοπεί απροειδοποίητα, το Visio ανοίγει το αρχείο αυτόματης ανάκτησης την επόμενη φορά που θα ξεκινήσετε το πρόγραμμα. Το αρχείο αυτόματης ανάκτησης ενδέχεται να περιέχει μη αποθηκευμένες πληροφορίες οι οποίες σε διαφορετική περίπτωση θα είχαν χαθεί από το αρχικό αρχείο σχεδίασης. Εάν το αρχικό σας αρχείο σχεδίασης έχει καταστραφεί, ίσως μπορέσετε να ανακτήσετε πληροφορίες από το αρχείο αυτόματης ανάκτησης.

Για να ορίσετε τη ρύθμιση αυτόματης ανάκτησης στο Visio:
  1. Εκκίνηση του Visio.
  2. Στο μενού Εργαλεία , κάντε κλικ στο κουμπί " Επιλογές".
  3. Κάντε κλικ στην καρτέλα " Αποθήκευση " ή την καρτέλα " Αποθήκευση ".
  4. Επιλέξτε το πληροφοριών αποθήκευση αυτόματης ανάκτησης κάθε πλαίσιο ελέγχου και, στη συνέχεια, καθορίστε το χρόνο σε λεπτά που θέλετε. Από προεπιλογή, η ρύθμιση αυτόματης ανάκτησης έχει οριστεί για 10 λεπτά.
  5. Κάντε κλικ στο κουμπί OK.

Βεβαιωθείτε ότι η παροχή ενέργειας είναι συνεπές

Μια παροχή ενέργειας που δεν είναι συνεπής μπορεί να προκαλέσει ζημιά σε αρχεία, ακόμη και αν δεν χάνετε ενέργειας. Ένα τροφοδοτικό ότι κορυφές ή που δεν είναι επαρκή μπορεί να επηρεάσει τη διαδικασία ανάγνωσης και τις διαδικασίες εγγραφής στον υπολογιστή σας και μπορεί να προκαλέσει βλάβη. Αν η παροχή ενέργειας στην περιοχή σας είναι ασυνεπής, χρησιμοποιήστε ένα καταστολέας υπερτάσεων. Προστατευτικά υπέρτασης μπορούν να σας βοηθήσουν να αποτραπεί βλάβη στον υπολογιστή σας, εάν παρουσιαστεί κορυφές ενέργειας. Μπορείτε, επίσης, μπορεί να χρησιμοποιήσετε αδιάλειπτη παροχή ενέργειας (UPS). Μονάδες UPS παρέχουν τον υπολογιστή σας με την ισχύ του, ακόμη και αν υπάρχει μια διακοπή ρεύματος. Επικοινωνήστε με τον προμηθευτή του υλικού σας για περισσότερες πληροφορίες σχετικά με τον τρόπο απόκτησης κάποια από αυτές τις συσκευές.

Δημιουργήστε αντίγραφα ασφαλείας των δεδομένων σας

Βεβαιωθείτε ότι έχετε δημιουργήσει αντίγραφα ασφαλείας των δεδομένων σας τακτικά. Για παράδειγμα, μπορείτε να αποθηκεύσετε ένα αντίγραφο του σχεδίου σας σε έναν διαφορετικό τόμο στον σκληρό δίσκο. Ή, ανάλογα με τις απαιτήσεις σας και το περιβάλλον, να εφαρμόζουν άλλα αντίγραφα ασφαλείας ή άλλες λύσεις ανοχή στον υπολογιστή σας. Ορισμένες ανοχή λύσεις, όπως των ανεξάρτητων δίσκων RAID (πλεονάζουσας συστοιχίας), συνήθως είναι μόνο πρακτική για μεγάλα δίκτυα. Άλλες επιλογές δημιουργίας αντιγράφων ασφαλείας είναι οι εξής:
  • Λήψη εφεδρικών αντιγράφων
  • Δημιουργία αντιγράφων ασφαλείας του CD
  • Είδωλο τόμου
  • Τόμος RAID-5
  • Εξωτερική μονάδα σκληρού δίσκου
  • Μονάδα USB (Flash)

Εργασία με τοπικά δεδομένα

Εάν εργάζεστε σε περιβάλλον δικτύου και να αντιμετωπίσει καταστροφή συχνά, μπορείτε να αντιγράψετε τα αρχεία σας στον τοπικό υπολογιστή σας, πριν να ανοίξετε το αρχείο ή πριν να τροποποιήσετε το αρχείο. Αντιγράψτε το αρχείο στην επιφάνεια εργασίας σας, χρησιμοποιώντας τον υπολογιστή μου ή από την Εξερεύνηση των Windows. Όταν εργάζεστε με αρχεία που είναι αποθηκευμένα στον τοπικό σας υπολογιστή, Αποτροπή ζητημάτων ανάγνωσης ή εγγραφής ζητήματα που μπορεί να προκαλείται από ζητήματα σύνδεσης δικτύου, όπως οι εξής:
  • Αργές συνδέσεις δικτύου
  • Συνδέσεις δικτύου που απορρίφθηκαν
  • Κορυφές κίνηση στο δίκτυο
Μπορείτε επίσης να λάβετε υπόψη σας την εργασία από τον σκληρό δίσκο και δεν λειτουργεί από αφαιρούμενα μέσα αποθήκευσης, όπως μια δισκέτα ή μια μονάδα δίσκου ZIP. Τα περισσότερα μέσα και τα περισσότερα προγράμματα οδήγησης συσκευών που συμμετέχουν στην αποθήκευση λειτουργία, τις περισσότερες τις αυξημένες πιθανότητες καταστροφή αρχείων.

Αναφορές

Για περισσότερες πληροφορίες σχετικά με το Visio, επισκεφθείτε τις ακόλουθες τοποθεσίες της Microsoft στο Web:

Ιδιότητες

Αναγν. άρθρου: 826418 - Τελευταία αναθεώρηση: Τρίτη, 29 Οκτωβρίου 2013 - Αναθεώρηση: 5.0
Οι πληροφορίες σε αυτό το άρθρο ισχύουν για:
  • Microsoft Visio Professional 2013
  • Microsoft Visio Standard 2013
  • Microsoft Visio Premium 2010
  • Microsoft Visio Professional 2010
  • Microsoft Visio Standard 2010
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
Λέξεις-κλειδιά: 
kbpubtypekc kbopenfile kberrmsg kbdisplay kbhowtomaster kbtshoot kbprb kbmt KB826418 KbMtel
Μηχανικά μεταφρασμένο
ΣΗΜΑΝΤΙΚΟ: Αυτό το άρθρο έχει μεταφραστεί χρησιμοποιώντας λογισμικό μηχανικής μετάφρασης της Microsoft και μπορείτε να το διορθώσετε χρησιμοποιώντας την τεχνολογία Community Translation Framework (CTF) (Πλαίσιο μετάφρασης κοινότητας). Η Microsoft παρέχει μηχανική μετάφραση, επεξεργασία μετά τη μηχανική μετάφραση από την κοινότητα και άρθρα μεταφρασμένα από επαγγελματίες προκειμένου να έχετε πρόσβαση σε όλα τα άρθρα της Γνωσιακής βάσης σε πολλές γλώσσες. Τα άρθρα μηχανικής μετάφρασης και αυτά που επεξεργάζονται ύστερα από μηχανική μετάφραση ενδέχεται να περιέχουν σφάλματα στο λεξιλόγιο, στη σύνταξη ή/και στη γραμματική. Η Microsoft δεν φέρει καμία ευθύνη για τυχόν ανακρίβειες, σφάλματα ή ζημίες που προκύψουν λόγω τυχόν παρερμηνειών στη μετάφραση του περιεχομένου ή χρήσης του από τους πελάτες μας. Για περισσότερες πληροφορίες σχετικά με το CTF, μεταβείτε στην τοποθεσία http://support.microsoft.com/gp/machine-translation-corrections/el.
Η αγγλική έκδοση αυτού του άρθρου είναι η ακόλουθη: 826418

Αποστολή σχολίων

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com