Visio における破損した図面のトラブルシューティング方法

文書翻訳 文書翻訳
文書番号: 826418 - 対象製品
すべて展開する | すべて折りたたむ

目次

概要

この資料では、Microsoft Office Visio 2013、Visio 2010、Visio 2007、Microsoft Office Visio 2003、および Microsoft Visio 2002 における破損した図面のトラブルシューティング方法について説明します。この記事を使用している Visio の図面が破損していることを示すいくつかの現象について説明します。

さらに、破損した図面に対して使用できるいくつかの回復方法についても紹介します。一般的なトラブルシューティングの方法するか、図面および図面で発生する可能性がある破損を防ぐ方法を開くことができない場合に試す方法にはが含まれます。

はじめに

概要

Visio 図面で作業するときに、予期しない動作が発生した場合、Visio 図面が破損している可能性があります。図面が破損している場合は、次のエラー メッセージが表示される可能性があります。
  • 「無効なページ違反、「一般保護エラー、またはエラー メッセージの「無効な命令」
  • 図面を開いたときに、次のいずれかに類似したエラー メッセージ。

    アクションを開く中にエラー (100) が発生しました

    Visio は Visio ファイルではないか壊れているため、ファイルを開くことができません。
  • 「メモリ不足」エラー メッセージまたはシステム リソースの不足を示すエラー メッセージ
メモ これらのエラー メッセージは常にわけではありません、図面が破損しています。ただし、繰り返し発生する場合これらのエラー メッセージのいずれか、特定の図面で作業するときに、その図面が破損してください。

この資料は、破損した図面を修復するのに使用できるいくつかの方法を示します。この資料に記載されている方法では、破損した図面を必ず修復は保証されません。場合によっては、によって、破損の種類する可能性がありますできない任意のデータを回復します。場合によっては、図面を再作成するか、バックアップ ファイルから図面を復元する必要があります。

一般的なトラブルシューティング方法

オートメーション イベントが発生せず、Microsoft Visual Basic for Applications には、Visio を起動します。

オートメーション イベントおよび Visual Basic for Applications を行わず、Visio を起動します。これを行うには、次の方法のいずれかを使用します。

方法 1: Microsoft Office Visio 2013 と Visio 2010
  1. Visio を起動します。
  2. 上のファイル タブ、オプション] をクリックし、[セキュリティ センター] をクリックします。
  3. セキュリティ センターの設定] をクリックし、[警告を表示せずにすべてのマクロを無効にする] をクリックします。
  4. アドインをクリックします。
  5. クリックして選択、すべてのアプリケーション アドインを無効にする チェック ボックスをオンします。
  6. [Ok]をクリックします。
  7. Visio を終了し、Visio を再起動し、します。

方法 2: Microsoft Office Visio 2007
  1. Visio を通常どおりに起動します。
  2. [ツール] メニューの [セキュリティ センター] をクリックします。
  3. マクロの設定] をクリックし、[警告を表示せずにすべてのマクロを無効にする] をクリックします。
  4. アドインをクリックします。
  5. すべてのアプリケーション アドインを無効にする] チェック ボックスをオンをクリックします。
  6. [Ok]をクリックします。
  7. Visio を終了し、Visio を再起動し、します。
方法 3: Microsoft Office Visio 2003 および Visio の以前のバージョン
  1. Visio を通常どおりに起動します。
  2. 実行している Visio のバージョンに応じて、次の手順のいずれかを使用します。
    • Visio 2003 を実行している場合は、[ツール] メニューの [オプション] をクリックし、[セキュリティ] タブをクリックします。
    • Visio 2002 を実行している場合は、[ツール] メニューの [オプション] をクリックし、詳細設定タブをクリックします。
  3. 次の操作を行います。
    • Microsoft Visual Basic for Applications を有効にする] チェック ボックスをオフにする] をクリックします。

      メモ Microsoft Visual Basic for Applications を有効にする] チェック ボックスをオフにするをクリックした後を有効にする Microsoft Visual Basic for Applications のプロジェクトを作成する] チェック ボックスをオンし、負荷の Microsoft Visual Basic for Applications プロジェクトをテキストからチェック ボックスが使用できなくなった。
    • 有効にする COM アドインのチェック ボックスをオフをクリックします。
    • イベントのオートメーションを有効にする] チェック ボックスをオフにする] をクリックします。
  4. [OKを] をクリックし、Visio を終了します。
  5. Visio を再起動します。
方法 4: 新しい図面内のページに各ページをコピーするのにコピー描画 '' のコマンドを使用します。
Visio 2013 と Visio 2010 の: を
  1. 図面で何も選択されているかどうかを確認します。
  2. 上のホーム ] タブの [、クリップボード グループで、[コピー] をクリックします。
  3. 図面を埋め込むと、[ホーム] タブの [クリップボード] グループで、[貼り付け] をクリックします。 対象となるドキュメントを開きます。
Visio 2007 および Visio 2003: の
  1. Microsoft Office Visio 図面上で何も選択されていることを確認します。
  2. [編集] メニューの [図面のコピー] をクリックします。メモ このコマンドは、別の図面ページ上や背景上の図形を含む図面全体をコピーします。複数ページの Visio 図面を埋め込むと、表示されているページはアクティブな図面のコピー] をクリックすると、1 になります。
  3. 図面の埋め込みたいとし、文書を開く、編集 ] メニューの [をクリックして貼り付け (または同等のコマンド)。
    ソース: Visio 2007 のヘルプと使い方http://office.microsoft.com/en-us/visio/HP012314701033.aspx

Windows をセーフ モードで起動します。

Windows をセーフ モードで起動します。これを行うには、以下を実行します。

メモ Microsoft Windows にはバージョンが複数あるため、コンピューターによって次の手順が異なる場合があります。その場合は、製品のマニュアルを参照して次の手順を完了してください。
  1. シャット ダウンし、コンピューターを再起動します。
  2. 「を開始するには、オペレーティング システムの選択」メッセージが表示されたら、F8 キーを押します。
  3. 上の高度なオプションの Windows<b00> </b00> ] メニューの [セーフ モードを選択するには、矢印キーを使用し、ENTER キーを押します。
  4. デュアル ブートまたはマルチ ブート コンピューターの場合は、し、ENTER キーを押して、表示される一覧から該当するオペレーティング システムを選択します。
  5. Visio を起動し、図面を開くしようとして。
セーフ モードの詳細については、次のマイクロソフト サポート技術記事を表示するには、次の資料番号をクリックしてください。
315222 Windows XP のセーフ モード ブート オプションの説明
202485 Windows 2000 のセーフ ブート モードの説明
180902 Windows 98 ベースのコンピューターをセーフ モードで起動する方法

図面を開けない場合に試す方法

方法 1: 図面ファイルを Visio.exe ファイルのアイコンをドラッグします。

図面ファイルを Visio.exe ファイルのアイコンをドラッグします。これを行うに: Visio.exe ファイルが次のフォルダーにある Visio 2010 を実行している場合: ドライブ: \Program Files\Microsoft Office\Office14、* 64 ビット Windows 上で Visio の 32 ビットをインストールする場合は、Program Files フォルダーには、(x 86)、フォルダーの名前の背後にあります。Visio 2010 では、ネイティブの 64 ビット版できるようになりました。
  1. Visio を終了します。
  2. Microsoft Windows エクスプ ローラーを起動し、ハード ディスク上の Visio.exe ファイルを見つけます。既定の場所に Visio をインストールする場合は、Visio.exe ファイルは、実行している Visio のバージョンに応じて、次のフォルダーのいずれかにあります。
    • Visio 2013 を実行している場合、Visio.exe ファイルは、次のフォルダーにあります。
      ドライブ: \Program Files\Microsoft Office\Office15
      注: 64 ビット バージョンの Windows で、32 ビットのバージョンの Visio をインストールした場合、プログラム ファイル フォルダーが、(x 86)、フォルダーの名前の背後にあります。Visio 2013 は、ネイティブの 64 ビット バージョンです。
    • Visio.exe ファイルが次のフォルダーにある Visio 2010 を実行している場合:ドライブ: \Program Files\Microsoft Office\Office1464 ビット バージョンの Windows で、Program Files フォルダーの 32 ビット バージョンの Visio をインストールした場合に、(x 86)、フォルダーの名前の背後にあります。Visio 2010 では、ネイティブの 64 ビット版できるようになりました。


      Visio 2007 を実行している場合、Visio.exe ファイルは、次のフォルダーにあります。
      ドライブ: \Program Files\Microsoft Office\Office12
      Visio 2003 を実行している場合、Visio.exe ファイルは、次のフォルダーにあります。
      ドライブ: \Program Files\Microsoft Office\Visio11
    • Visio 2002 を実行している場合、Visio.exe ファイルは、次のフォルダーにあります。
      ドライブ: \Program Files\Microsoft Office\Visio10
      メモ 既定のインストール場所とは異なるフォルダーに Visio をインストールした場合、Visio.exe ファイルのパスはコンピューターによって異なります。
  3. Windows エクスプ ローラーで図面ファイルを開きたいを見つけます。
  4. 図面ファイルを Visio.exe ファイルのアイコンをドラッグします。

方法 2: エクスプ ローラーで図面ファイルをダブルクリックします。

Windows エクスプ ローラーを使用して、図面ファイルを開くしようとしてください。これを行うには、以下を実行します。
  1. Visio を終了します。
  2. Windows エクスプ ローラーを起動し、図面ファイルを開くし、検索します。
  3. 図面ファイルをダブルクリックします。

方法 3: 図面ファイルの一時コピーを開く

Visio 図面を変更すると、図面ファイルの一時コピーが作成されます。図面ファイルの一時コピーの名前は ~ $$ファイル名。 ~ vsd。通常、図面ファイルの一時コピーが作成され、図面が配置されているのと同じフォルダーに格納されています。

図面ファイルの一時コピーを開くには、次の手順で行います。
  1. Visio を起動し、図面を開きます。
  2. Windows エクスプ ローラーを起動し、図面が保存されているフォルダーを検索します。このフォルダー、図面ファイルの一時コピーを参照してください。図面ファイルの一時コピーの名前は ~ $$ファイル名。 ~ vsd。

    メモ 図面ファイルの一時コピーが図面が保存されているフォルダーにない場合は、図面ファイルの一時コピーについてハード_ディスクを検索します。

    図面ファイルの一時コピーについてハード_ディスクを検索するには、次のように行います。

    メモ Microsoft Windows にはバージョンが複数あるため、コンピューターによって次の手順が異なる場合があります。その場合は、製品のマニュアルを参照して次の手順を完了してください。
    1. 開始] をクリックし、[検索] をクリックします。
    2. ファイルとフォルダーすべて] をクリックします。
    3. ファイル名のすべてまたは一部] ボックスに、次のように入力します。 ~$$ファイル名。 ~ vsd、し、[検索] をクリックします。
  3. 図面ファイルの一時コピーの拡張子を .vsd に変更します。これを行うには、以下を実行します。
    1. 図面ファイルの一時コピーを右クリックし、[名前の変更] をクリックします。
    2. ~.Vsd からの図面ファイルの一時コピーの拡張子を .vsd に変更します。
  4. 名前を変更した図面ファイルの一時コピーを開くしようとしてください。

方法 4: を Microsoft Office Visio Viewer を使用して、図面を開く

Microsoft Office Visio ビューアー 2010年をインストールし、Visio ビューアーを使用して開き、図面を表示します。Visio ビューアー 2010年をインストールするときに、Visio 図面と Visio 2010、Visio 2007、Visio 2003、Visio 2002、Microsoft Visio 2000、または Microsoft Visio 5 で作成した図を表示するのに Microsoft Internet Explorer 5.0 またはそれ以降の Internet Explorer を使用できます。Visio ビューアー 2010年の詳細については、次のマイクロソフト web サイトを参照してください。

http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=21701

Visio Viewer で図面を開ける場合は、コンピューター上の Visio のインストールが破損している可能性があります、または図面が破損している可能性があります 1 つまたは複数のオブジェクトを含むことがあります。

方法 5: 別のコンピューターに図面ファイルをコピーします。

Visio がインストールされている別のコンピューターに図面ファイルをコピーします。そのコンピューターで問題の図面を開くことができますと、そのコンピューターのハード_ディスク上の別のフォルダーに図面ファイルを保存し、元のコンピューターに図面ファイルをコピーします。

方法 6: コンピューター上の別のディスクに図面ファイルをコピーします。

Windows から現在の図面ファイルが保存されている図面ファイルを参照することはできません。コンピューター上の別のディスクに図面ファイルをコピーします。たとえば、フロッピー ディスクからファイルをハード ディスクにコピーします。別のディスクに図面ファイルをコピーするには、コンピューター上で、後に図面ファイルを開いてみます。

メモ 図面ファイルが保存されているディスクから図面ファイルをコピーすることはできません、する場合は、図面ファイルとその他のファイルまたはフォルダーとクロスリンク可能性があります。 またはディスクのセクターに、図面ファイルが存在します。この問題を解決するには、方法 7 の手順を実行します。

方法 7: 検出および修復、ハード ディスクのエラー

Microsoft Windows Server 2003、Microsoft Windows XP、Microsoft Windows 2000、または Microsoft Windows NT 4.0 を実行している場合は、ファイル システム エラーまたはハード_ディスク上の不良セクターを検出するチェック ディスク ツールを使用します。

詳細について、マイクロソフト サポート技術記事を表示するには、次の資料番号をクリックしてください。
315265 Windows XP で、ディスクのエラー チェックを実行する方法
156571 Windows のスキャン ディスクを実行する方法

Microsoft Windows me または Windows 98 を実行している場合は、ファイル システム エラーまたはハード_ディスク上の不良セクターを検出するには、スキャン ディスク ツールを使用します。

詳細については、以下の資料番号をクリックして、マイクロソフト サポート技術情報資料を参照してください。
186365 Windows 98 (Scandskw.exe) を Windows のスキャン ディスクの説明と私

メモ チェック ディスク ツールまたはスキャン ディスク ツールを検出し、ファイル システムのエラーや、ハード ディスク上の不良セクターを修復、Visio がまだできませんを開くか、ファイルを読み取る。

Windows Vista を実行している場合の詳細については、次のマイクロソフト Web サイトを参照してください。
http://windowshelp.microsoft.com/Windows/en-US/Help/bc1393cf-9f9c-79c7-0f91-9337c2c41f811033.mspx
方法 8: 前「シャドウ コピー」の以前のバージョン] タブを使用して開くには


1. Visio ファイルを右クリックします。
2. [プロパティ] を選択します。
3. 以前のバージョン] タブを選択して、リストを作成する時間を与える
4. ファイルの古いバージョンを選択します。
5. [開く] をクリックします。
6. ファイルが正常に開く、ファイル] メニューの [名前を付けて保存] をクリックし、ファイルのコピーを保存



図面を開くことができる場合に試す方法

方法 1: ファイルを XML 図面として保存します。

図面を XML 図面 (.vdx ファイル) として保存し、XML 図面を図面 (.vsd ファイル) として保存します。これを行うには、以下を実行します。
  1. Visio を起動し、図面を開きます。
  2. [ファイル] メニューで、名前を付けて保存] をクリックします。
  3. [名前を付けて保存] ダイアログ ボックスをクリックしてXML 図面 (*.vdx) を入力し、[ファイル名] ボックスにファイル名、ファイルの種類] ボックスでします。図面ファイルを保存する場所を指定し、[保存] をクリックします。
  4. 現在開いているすべての図面を閉じます。
  5. [ファイル] メニューの [開く] をクリックします。
  6. 手順 3 で保存した XML 図面 (.vdx) を見つけて、[開く] をクリックします。
  7. [ファイル] メニューで、名前を付けて保存] をクリックします。
  8. [名前を付けて保存] ダイアログ ボックスをクリックして図面 (*.vsd) を入力し、[ファイル名] ボックスにファイル名、ファイルの種類] ボックスでします。図面ファイルを保存する場所を指定し、[保存] をクリックします。
  9. 図面を閉じます。
  10. [ファイル] メニューで、[開く] をクリックします
  11. 手順 8 で保存した図面 (.vsd ファイル) を見つけて、[開く] をクリックします。

方法 2: 図面を新しい空白の図面を挿入します。

図面を新しい空白の図面に挿入します。これを行うには、以下を実行します。

Visio 2013 と Visio 2010 の: を
  1. Visio を起動します。
  2. ファイル ] タブの [新規空白の図面を選択] をクリック、作成 ボタン。
  3. 上の挿入 ] タブで、[オブジェクト] をクリックします。
  4. ファイルから作成] をクリックし、[参照] をクリックします。
  5. 図面を選択 [開く] をクリックし、[ OK] をクリックします。
  6. 図面ファイルが破損しているかどうか、特定の状況に応じて、別の問題があるかどうか。
    • 受信した場合、"エラー: #3400"エラー メッセージ、図面ファイルが破損している可能性があります。図面を修復してください、この資料に記載されているメソッドを使用します。
    • ない場合は、"エラー: #3400"エラー メッセージを妨げる可能性がある Visio 図面を開いてから、別の問題がある可能性があります。たとえば、Visio の図面を開くことを防止する、コンピューター上の特定のコンポーネントの間で競合が発生しています。
Visio 2007 および Visio 2003: の
  1. Visio を起動します。
  2. [ファイル] メニューの新規作成] をポイントし、[新しい図面] をクリックします。
  3. [挿入] メニューの [オブジェクト] をクリックします。
  4. ファイルから作成] をクリックし、[参照] をクリックします。
  5. 図面、[開く] をクリックを [ OK] をクリックします。
  6. 図面ファイルが破損しているかどうか、特定の状況に応じて、別の問題があるかどうか。
    • 受信した場合、"エラー: #3400"エラー メッセージ、図面ファイルが破損している可能性があります。図面を修復してください、この資料に記載されているメソッドを使用します。
    • ない場合は、"エラー: #3400"エラー メッセージを妨げる可能性がある Visio 図面を開いてから、別の問題がある可能性があります。たとえば、Visio の図面を開くことを防止する、コンピューター上の特定のコンポーネントの間で競合が発生しています。
    S

図面に損傷を防止しようとする方法

ファイルで発生する可能性があるすべての破損を防ぐことはできません。ハード_ディスクの摩耗、電源の故障、その他の予測できない出来事ファイルが破損する原因となることがあります。以下のヒントおよび提案は、visio およびその他のプログラムで発生する破損ファイルの数を減らすことができます。

Visio で自動バックアップ設定を最適化します。

有効な値を [自動] を設定します。場合は、コンピューターが停止する応答か、電源が突然落ちたかどうか、次回プログラムを起動するに Visio 自動バックアップ ファイルを開きます。自動バックアップ ファイルには、それ以外の場合に、元の図面ファイルから失われる未保存の情報があります。元の図面ファイルが破損している場合は、自動バックアップ ファイルから情報を復元することができます。

Visio で自動バックアップを設定: する
  1. Visio を起動します。
  2. [ツール] メニューの [オプション] をクリックします。
  3. [保存] タブまたは [保存/開く] タブをクリックします。
  4. 選択して、の自動保存をすべてチェック ボックスをオンし、時間を分単位で指定します。既定では、自動バックアップの設定は 10 分間に設定されます。
  5. [Ok]をクリックします。

パワー ・ サプライが一貫性のあるであるかどうかを確認します。

パワー ・ サプライが矛盾しているいない電源を紛失した場合でも、ファイルへの損害可能性があります。電源スパイクやが十分でないことの読み取り処理および書き込み処理には、コンピューターに影響を与えることができ、破損が発生する可能性があります。お住まいの地域内のパワー サプライが一定でない場合は、サージ プロテクターを使用します。サージ プロテクターは電源スパイクが発生した場合は、コンピューター上の破損を防止するために役立ちます。また、無停電電源装置 (UPS) の使用を検討してください。Ups は電源障害がある場合でも、コンピューターに電源を供給します。これらの装置の入手方法の詳細については、ハードウェアの製造元に問い合わせてください。

データをバックアップします。

定期的にデータをバックアップすることを確認します。たとえば、ハード_ディスク上の別のボリュームに、図面のバックアップ コピーを保存します。または、コンピューターに、別のバックアップまたはその他のフォールト トレラント ソリューションを実装の要件に応じて、お客様の環境にします。一部のフォールト トレラント ソリューションなど冗長アレイの独立したディスク (RAID) は、通常の大規模なネットワークで実用的なのみです。その他のバックアップ オプションは次のとおりです。
  • テープ ・ バックアップ
  • CD のバックアップ
  • ミラー ボリューム
  • Raid-5 ボリューム
  • 外付けハード ディスク ドライブ
  • (Flash) を USB ドライブ

データをローカルで作業します。

ネットワーク環境で作業する場合、破損が頻繁に発生するファイルを開く前に、やファイルを変更する前に、ローカル コンピューターにファイルをコピーすることがあります。マイ コンピューターまたは Windows エクスプ ローラーを使用して、ファイルをデスクトップにコピーします。ローカル コンピューターに格納されているファイルで作業するには、読み取りの問題を防止または書き込みの問題を次のネットワーク接続の問題が考えられます。
  • 低速ネットワーク接続
  • ネットワーク接続の切断
  • ネットワーク トラフィックのスパイク
ハード ディスクから、フロッピー ディスクや ZIP ドライブなどのリムーバブル メディアから動作していないことを検討することも。メディアや保存に関連するデバイス ドライバーが多いほど、ファイルが破損する可能性が高く、操作します。

関連情報

Visio の詳細については、次のマイクロソフト web サイトを参照してください。

プロパティ

文書番号: 826418 - 最終更新日: 2014年2月8日 - リビジョン: 4.0
この資料は以下の製品について記述したものです。
  • Microsoft Visio Professional 2013
  • Microsoft Visio Standard 2013
  • Microsoft Visio Premium 2010
  • Microsoft Visio Professional 2010
  • Microsoft Visio Standard 2010
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
キーワード:?
kbPubTypeKC kbopenfile kberrmsg kbdisplay kbhowtomaster kbtshoot kbprb kbmt KB826418 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:826418
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com