Como resolver problemas de desenhos danificados no Visio

Traduções de Artigos Traduções de Artigos
Artigo: 826418 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sumário

Este artigo explica como resolver problemas relacionados com desenhos danificados no 2013 do Microsoft Office Visio, o Visio 2010, o Visio 2007, o Microsoft Office Visio 2003 e o Microsoft Visio 2002. Este artigo descreve alguns sintomas que poderão indicar que o desenho que está a trabalhar no Visio está danificado.

Além disso, este artigo lista alguns métodos de recuperação que pode utilizar no desenho danificado. Estas incluem métodos de resolução de problemas gerais, métodos para tentar se pode ou não é possível abrir o desenho e métodos para ajudar a impedir danos que poderão ocorrer desenhos.

INTRODUÇÃO

Descrição geral

Se detectar um comportamento inesperado quando trabalhar com um desenho do Visio, o desenho do Visio pode estar danificado. Poderá receber as seguintes mensagens de erro se tiver um desenho danificado:
  • "Erro de página inválida", "Erro de protecção geral" ou "Instrução ilegal" mensagens de erro
  • Mensagens de erro que são semelhantes a um dos seguintes quando abre um desenho:

    Ocorreu um erro (100) durante a acção abrir

    O Visio não consegue abrir o ficheiro porque não se trata de um ficheiro do Visio ou está danificado.
  • "Memória insuficiente" mensagens de erro ou mensagens de erro que indiquem poucos recursos do sistema
Nota Estas mensagens de erro não sempre significam que o desenho está danificado. No entanto, se repetidamente detectar um ou mais destas mensagens de erro quando trabalha com um determinado desenho, esse desenho pode estar danificado.

Este artigo lista alguns métodos que pode utilizar para tentar recuperar o desenho danificado. Os métodos descritos neste artigo não garantem a recuperação com êxito de um desenho danificado. Por vezes, dependendo do tipo de danos, não poderá recuperar quaisquer dados. Poderá ter de recriar o desenho ou repor o desenho a partir dos seus ficheiros de cópia de segurança.

Métodos de resolução de problemas gerais

Iniciar o Visio sem eventos de automatização e sem o Microsoft Visual Basic for Applications

Inicie o Visio sem eventos de automatização e sem o Visual Basic for Applications. Para tal, utilize um dos seguintes métodos:

Método 1: Microsoft Office Visio 2013 e Visio 2010
  1. Inicie o Visio.
  2. Sobre o ficheiro , clique em Opçõese, em seguida, clique o Centro de fidedignidade.
  3. Clique em definições do Centro de fidedignidadee, em seguida, clique em Desactivar todas as macros sem notificação.
  4. Clique em suplementos.
  5. Clique para seleccionar a Desactivar todos os suplementos aplicação caixa de verificação.
  6. Clique em OK.
  7. Saia do Visio e, em seguida, reiniciar o Visio.

Método 2: Microsoft Office Visio 2007
  1. Inicie o Visio normalmente.
  2. No menu Ferramentas , clique em Centro de fidedignidade.
  3. Clique em Definições de Macroe, em seguida, clique em Desactivar todas as macros sem notificação.
  4. Clique em suplementos.
  5. Clique para seleccionar a caixa de verificação Desactivar todos os suplementos aplicação .
  6. Clique em OK.
  7. Saia do Visio e, em seguida, reiniciar o Visio.
Método 3: Microsoft Office Visio 2003 e versões anteriores do Visio
  1. Inicie o Visio normalmente.
  2. Utilize um dos seguintes procedimentos, dependendo da versão do Visio que está a executar:
    • Se estiver a executar o Visio 2003, clique em Opções no menu Ferramentas e, em seguida, clique no separador segurança .
    • Se estiver a executar o Visio 2002, clique em Opções no menu Ferramentas e, em seguida, clique no separador Avançadas .
  3. Efectue o seguinte:
    • Clique para desmarcar a caixa de verificação Activar o Microsoft Visual Basic para aplicações .

      Nota Depois de clicar para desmarcar a caixa de verificação Activar o Microsoft Visual Basic para aplicações , a caixa de verificação Activar o Microsoft Visual Basic para aplicações de criação do projecto e a caixa de verificação de carga Microsoft projecto Visual Basic for Applications do texto fica indisponível.
    • Clique para desmarcar a caixa de verificação Activar suplementos .
    • Clique para desmarcar a caixa de verificação Activar eventos de automatização .
  4. Clique em OKe, em seguida, saia do Visio.
  5. Reinicie o Visio.
Método 4: Utilize o comando 'Copiar Desenho' para copiar cada página para uma página num desenho novo.
Para o Visio 2013 e Visio 2010:
  1. Certifique-se de que nada no desenho está seleccionado.
  2. No casa separador, na área de transferência de grupo, clique em Copiar.
  3. Abra o documento em que pretende incorporar o desenho e, em seguida, no separadorbase , no grupo de área de transferência , clique em Colar.
Para o Visio 2007 e do Visio 2003:
  1. Desenho do Microsoft Office Visio, certifique-se de que nada está seleccionado.
  2. No menu Editar , clique em Copiar Desenho. Nota Este comando copia todo o desenho, incluindo formas noutras páginas do desenho e fundos. Quando incorpora um desenho do Visio de várias páginas, a página visível será aquele que está activa quando clicar em Copiar Desenho.
  3. Abra o documento no qual pretende incorporar o desenho e, em seguida, sobre o Editar menu, clique em Colar (ou o comando equivalente).
    Origem: Ajuda do Visio 2007 e procedimentoshttp://Office.microsoft.com/en-us/Visio/HP012314701033.aspx

Iniciar o Windows no modo de segurança

Inicie o Windows em modo de segurança. Para tal:

Nota Dado existirem várias versões do Microsoft Windows, os seguintes passos podem ser diferentes no seu computador. Se forem, consulte a documentação do produto para concluir estes passos.
  1. Encerre e reinicie o computador.
  2. Quando vir a mensagem "Seleccione o sistema operativo para iniciar", prima F8.
  3. Sobre o Opções avançadas do Windows<b00> </b00> menu, utilize as teclas de seta para seleccionar o Modo de segurançae, em seguida, prima ENTER.
  4. Se tiver um computador com arranque duplo ou arranque múltiplo, seleccione o sistema operativo adequado na lista que aparece e, em seguida, prima ENTER.
  5. Inicie o Visio e, em seguida, tente abrir o desenho.
Para mais informações sobre o modo de segurança, clique nos números de artigo seguinte para visualizar os artigos na Microsoft Knowledge Base:
315222 Uma descrição das opções de arranque de modo de segurança no Windows XP
202485 Descrição do modo de arranque de segurança no Windows 2000
180902 Como iniciar um computador baseado no Windows 98 em modo de segurança

Métodos para tentar se não conseguir abrir um desenho

Método 1: Arrastar o ficheiro de desenho para o ícone do ficheiro Visio.exe

Arraste o ficheiro de desenho para o ícone que representa o ficheiro Visio.exe. Para o fazer: Se estiver a executar o Visio 2010, o ficheiro Visio.exe exe está localizado na seguinte pasta: unidade: \Programas\Microsoft Office\Office14, * se instalou o Visio 32 bits no Windows de 64 bits na pasta programas terão uma (x86) atrás o nome da pasta. Visio 2010 tem agora uma versão de 64 bits nativa.
  1. Sair do Visio.
  2. Inicie o Microsoft Windows Explorer e, em seguida, localize o ficheiro de Visio.exe no disco rígido. Se tiver instalado o Visio para a localização predefinida, o ficheiro Visio.exe está localizado das seguintes pastas, dependendo da versão do Visio que está a executar:
    • Se estiver a executar o Visio de 2013, o ficheiro Visio.exe exe está localizado na seguinte pasta:
      Unidade: \Programas\Microsoft Office\Office15
      NotaSe instalou uma versão de 32 bits do Visio numa versão de 64 bits do Windows, a pasta programas terão uma (x86) atrás o nome da pasta. Visio 2013 tem agora uma versão de 64 bits nativa.
    • Se estiver a executar o Visio 2010, o ficheiro Visio.exe exe está localizado na seguinte pasta: unidade: \Programas\Microsoft Office\Office14 Nota se tiver instalado uma versão de 32 bits do Visio numa versão de 64 bits do Windows, a pasta programas terão uma (x86) atrás o nome da pasta. Visio 2010 tem agora uma versão de 64 bits nativa.


      Se estiver a executar o Visio 2007, o ficheiro Visio.exe exe está localizado na seguinte pasta:
      Unidade: \Programas\Microsoft Office\Office12
      Se estiver a executar o Visio 2003, o ficheiro Visio.exe exe está localizado na seguinte pasta:
      Unidade: \Programas\Microsoft Office\Visio11
    • Se estiver a executar o Visio 2002, o ficheiro Visio.exe exe está localizado na seguinte pasta:
      Unidade: \Programas\Microsoft Office\Visio10
      Nota Se tiver instalado o Visio para uma pasta diferente da localização de instalação predefinido, o caminho do ficheiro Visio.exe é diferente no seu computador.
  3. No Explorador do Windows, localize o ficheiro de desenho que pretende abrir.
  4. Arraste o ficheiro de desenho para o ícone que representa o ficheiro Visio.exe.

Método 2: Faça duplo clique o ficheiro de desenho no Explorador do Windows

Tente abrir o ficheiro de desenho utilizando o Explorador do Windows. Para tal:
  1. Sair do Visio.
  2. Inicie o Explorador do Windows e, em seguida, localize o ficheiro de desenho que pretende abrir.
  3. Faça duplo clique sobre o ficheiro de desenho.

Método 3: Abra a cópia temporária do ficheiro de desenho

Quando modifica um desenho do Visio, é criada uma cópia temporária do ficheiro de desenho. A cópia temporária do ficheiro de desenho com o nome ~ $$Nome de ficheiro. ~ vsd. A cópia temporária do ficheiro de desenho, normalmente, é criada e armazenada na mesma pasta onde se encontra o desenho.

Para abrir a cópia temporária do ficheiro de desenho, efectue o seguinte:
  1. Iniciar o Visio e, em seguida, abra o desenho.
  2. Inicie o Explorador do Windows e, em seguida, localize a pasta onde se encontra o desenho. Procure nesta pasta para a cópia temporária do ficheiro de desenho. A cópia temporária do ficheiro de desenho com o nome ~ $$Nome de ficheiro. ~ vsd.

    Nota Se a cópia temporária do ficheiro de desenho não se encontrar na pasta onde se encontra o desenho, efectue uma pesquisa o disco rígido para a cópia temporária do ficheiro de desenho.

    Para procurar o disco rígido para a cópia temporária do ficheiro de desenho, efectue o seguinte:

    Nota Dado existirem várias versões do Microsoft Windows, os seguintes passos podem ser diferentes no seu computador. Se forem, consulte a documentação do produto para concluir estes passos.
    1. Clique em Iniciare, em seguida, clique em Procurar.
    2. Clique em todos os ficheiros e pastas.
    3. Na caixa totalidade ou parte do nome do ficheiro , escreva ~$$Nome de ficheiro. ~ vsde, em seguida, clique em Procurar.
  3. Altere a extensão da cópia temporária do ficheiro de desenho para. vsd. Para tal:
    1. A cópia temporária do ficheiro de desenho com o botão direito e, em seguida, clique em Mudar o nome.
    2. Altere a extensão da cópia temporária do ficheiro de desenho de ~.vsd para. vsd.
  4. Tente abrir a cópia temporária do ficheiro de desenho cujo nome mudou.

Método 4: Utilizar o Microsoft Office Visio Viewer para abrir o desenho

Instalar o Microsoft Office Visio Viewer 2010 e, em seguida, utilize o Visio Viewer para abrir e ver o desenho. Quando instala o Visio Viewer 2010, pode utilizar o Microsoft Internet Explorer 5.0 ou uma versão posterior do Internet Explorer para visualizar desenhos do Visio e diagramas criados com o Visio 2010, o Visio 2007, o Visio 2003, Visio 2002, Microsoft Visio 2000 ou Microsoft Visio 5. Para mais informações sobre o Visio Viewer 2010, visite o seguinte Web site da Microsoft:

http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&ID=21701

Se conseguir abrir o desenho no Visio Viewer, a instalação do Visio no seu computador pode estar danificada ou o desenho poderá conter um ou mais objectos que possam estar danificados.

Método 5: Copiar o ficheiro de desenho para outro computador

Copie o ficheiro de desenho para outro computador que tenha o Visio instalado no mesmo. Se conseguir abrir o desenho nesse computador, guarde o ficheiro de desenho para uma pasta diferente no disco rígido do computador e, em seguida, copie o ficheiro de desenho para o computador original.

Método 6: Copiar o ficheiro de desenho para outro disco no computador

Windows poderá não conseguir ler o ficheiro de desenho a partir de onde o ficheiro de desenho é actualmente guardado. Copie o ficheiro de desenho para outro disco no computador. Por exemplo, copie o ficheiro de uma disquete para o disco rígido. Depois de copiar o ficheiro de desenho para um disco diferente no seu computador, tente abrir o ficheiro de desenho.

Nota Se não é possível copiar o ficheiro de desenho do disco onde está guardado o ficheiro de desenho, o ficheiro de desenho pode ter ligações cruzado com outros ficheiros ou pastas ou o ficheiro de desenho pode estar localizado num sector danificado do disco. Para resolver este problema, siga os passos no método 7.

Método 7: Detectar e reparar erros no disco rígido

Se estiver a executar o Microsoft Windows Server 2003, Microsoft Windows XP, Microsoft Windows 2000 ou Microsoft Windows NT 4.0, utilize a ferramenta Verificar disco para detectar erros de sistema de ficheiros ou sectores danificados no disco rígido.

Para mais informações, clique nos números de artigo seguinte para visualizar os artigos na Microsoft Knowledge Base:
315265 Como efectuar no Windows XP, a verificação de erros de disco
156571 Como executar o Scandisk no Windows

Se estiver a executar o Microsoft Windows Millennium Edition (Me) ou Microsoft Windows 98, utilize a ferramenta Scandisk para detectar erros de sistema de ficheiros ou sectores danificados no disco rígido.

Para mais informações, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:
186365 Descrição do ScanDisk para Windows (Scandskw.exe) no Windows 98 / Me

Nota Apesar da ferramenta Verificar disco ou a ferramenta ScanDisk pode detectar e reparar erros do sistema de ficheiros ou sectores danificados no disco rígido, o Visio pode não conseguir abrir ou ler o ficheiro.

Se estiver a executar o Windows Vista, visite o seguinte Web site da Microsoft para obter mais informações:
http://windowshelp.microsoft.com/Windows/en-US/Help/bc1393cf-9f9c-79c7-0f91-9337c2c41f811033.mspx
Método 8: Abrir uma "cópia sombra anterior" utilizando o separador versões anteriores


1. Botão direito no ficheiro do Visio
2. Escolha ' Propriedades
3. Seleccione o separador versões anteriores, dar algum tempo para a lista preencher
4. Seleccione uma versão mais antiga do ficheiro
5. Clique em abrir
6. Se o ficheiro é aberto com êxito, a partir do menu Ficheiro clique em Guardar como e guarde uma cópia do ficheiro



Métodos para tentar se conseguir abrir o desenho

Método 1: Guardar o ficheiro como um desenho de XML

Guardar o desenho como um desenho XML (ficheiro. vdx) e, em seguida, guarde o desenho como um desenho (ficheiro. vsd) de XML. Para tal:
  1. Iniciar o Visio e, em seguida, abra o desenho.
  2. No menu ficheiro , clique em Guardar como.
  3. Na caixa de diálogo Guardar como , clique em Desenho XML (*. vdx)<b00> </b00> na caixa Guardar com o tipo e, em seguida, escreva um nome de ficheiro na caixa nome do ficheiro . Especifique uma localização onde pretende guardar o ficheiro de desenho e, em seguida, clique em Guardar.
  4. Feche todos os desenhos que estão actualmente abertos.
  5. No menu ficheiro , clique em Abrir.
  6. Localize o desenho XML (. vdx) que guardou anteriormente no passo 3 e, em seguida, clique em Abrir.
  7. No menu ficheiro , clique em Guardar como.
  8. Na caixa de diálogo Guardar como , clique em Desenho (*. vsd)<b00> </b00> na caixa Guardar com o tipo e, em seguida, escreva um nome de ficheiro na caixa nome do ficheiro . Especifique uma localização onde pretende guardar o ficheiro de desenho e, em seguida, clique em Guardar.
  9. Feche o desenho.
  10. No menu ficheiro , clique em Abrir
  11. Localize o desenho (ficheiro. vsd) que guardou anteriormente no passo 8 e, em seguida, clique em Abrir.

Método 2: Inserir o desenho para um novo desenho em branco

Inserir o desenho para um novo desenho em branco. Para tal:

Para o Visio 2013 e Visio 2010:
  1. Iniciar o Visio
  2. Sob o ficheiro separador, em Novo, seleccione o Desenho em brancoe em seguida, clique ocriar botão.
  3. Sobre o Inserir , clique o objecto.
  4. Clique em criar a partir de ficheiroe, em seguida, clique em Procurar.
  5. Selectthe de desenho, clique emAbrire, em seguida, clique em OK.
  6. Consoante a situação, determinar se o ficheiro de desenho está danificado ou se existe outro problema.
    • Se receber um "erro 3400" mensagem de erro, o ficheiro de desenho pode estar danificado. Utilize os métodos descritos neste artigo para tentar recuperar o desenho.
    • Se não receber um "erro 3400" mensagem de erro, poderá existir outro problema que impeça o Visio de abrir o desenho. Por exemplo, poderá existir um conflito entre determinados componentes no computador que impedem a abrir o desenho do Visio.
Para o Visio 2007 e do Visio 2003:
  1. Inicie o Visio.
  2. No menu ficheiro , aponte para Novoe, em seguida, clique em Novo desenho.
  3. No menu Inserir , clique em objecto.
  4. Clique em criar a partir de ficheiroe, em seguida, clique em Procurar.
  5. Clique no desenho, clique em Abrire, em seguida, clique em OK.
  6. Consoante a situação, determinar se o ficheiro de desenho está danificado ou se existe outro problema.
    • Se receber um "erro 3400" mensagem de erro, o ficheiro de desenho pode estar danificado. Utilize os métodos descritos neste artigo para tentar recuperar o desenho.
    • Se não receber um "erro 3400" mensagem de erro, poderá existir outro problema que impeça o Visio de abrir o desenho. Por exemplo, poderá existir um conflito entre determinados componentes no computador que impedem a abrir o desenho do Visio.
    S

Métodos para ajudar a impedir danos desenhos

Não pode impedir todos os danos que poderão ocorrer a ficheiros. Discos rígidos podem vestir, fontes de alimentação poderão falhar e outros acontecimentos imprevisíveis poderão ocorrer que tornar os ficheiros danificados. As sugestões e as sugestões seguintes podem ajudar a reduzir o número de ficheiros danificados que ocorrem no Visio e noutros programas.

Optimizar a definição de recuperação automática no Visio

Configure a definição de recuperação automática para um valor que mais lhe convenha. Se o computador deixa de responder ou se perder potência inesperadamente, o Visio abre o ficheiro de recuperação automática da próxima vez que iniciar o programa. O ficheiro de recuperação automática poderá conter informações não guardadas que outro modo seriam perdidas do ficheiro de desenho original. Se o ficheiro de desenho original foi danificado, poderá conseguir recuperar informações a partir do ficheiro de recuperação automática.

Para configurar a definição de recuperação automática no Visio:
  1. Inicie o Visio.
  2. No menu Ferramentas , clique em Opções.
  3. Clique no separador Guardar ou Guardar/abrir .
  4. Seleccione o informações de recuperação automática guarde todos os e, em seguida, especifique o tempo em minutos que pretende. Por predefinição, a definição de recuperação automática está definida para 10 minutos.
  5. Clique em OK.

Certifique-se de que a fonte de alimentação é consistente

Uma fonte de alimentação que não é consistente pode causar danos aos ficheiros, mesmo se não ficar sem energia. Uma fonte de alimentação que desportiva ou que não é suficiente pode afectar o processo de leitura e escrita de processos no computador e pode causar danos. Se a fonte de alimentação na sua área estiver inconsistente, utilize um supressor de flutuação. Protecção Cont. pode ajudar a impedir danos no seu computador se ocorrerem picos de energia. Também pode considerar a utilização de uma fonte de alimentação ininterrupta (UPS). Unidades de UPS fornecem o computador com a energia, mesmo se existir uma falha de energia. Contacte o fornecedor de hardware para obter mais informações sobre como obter qualquer um destes dispositivos.

Criar cópia de segurança de dados

Certifique-se de que efectua uma segurança dos dados regularmente. Por exemplo, armazene uma cópia do desenho num volume diferente no disco rígido. Ou, dependendo dos requisitos e no seu ambiente, implementa outras cópias de segurança ou outras soluções de tolerância a falhas no computador. Algumas soluções de tolerância a falhas, tal como RAID matriz redundante de independentes discos (), normalmente, apenas são práticas para redes de maiores dimensões. Outras opções de cópia de segurança incluem o seguinte:
  • Cópia de segurança de banda
  • CD cópia de segurança
  • Volume espelhado (mirrored)
  • Volume RAID-5
  • Unidade de disco rígido externa
  • Unidade USB (Flash)

Trabalhar com os dados localmente

Se trabalhar num ambiente de rede e detectar falhas nos frequentemente, poderá pretender considerar os ficheiros a copiar para o computador local antes de abrir o ficheiro ou antes de modificar o ficheiro. Copie o ficheiro no ambiente de trabalho, utilizando o meu computador ou utilizando o Explorador do Windows. Quando trabalha com ficheiros armazenados no computador local, evitar problemas de leitura ou escrita problemas que podem ser causados por problemas de conectividade de rede, tal como o seguinte:
  • Ligações de rede lentas
  • Ligações de rede ignorados
  • Picos no tráfego de rede
Também poderá considerar a trabalhar a partir do disco rígido e não trabalhar a partir de suportes por exemplo, uma disquete ou uma unidade ZIP. O mais suportes de dados e os controladores de dispositivo mais que participam na guarda o funcionamento, a mais as maiores probabilidades de danos do ficheiro.

Referências

Para mais informações sobre o Visio, visite os seguintes Web sites da Microsoft:

Propriedades

Artigo: 826418 - Última revisão: 29 de outubro de 2013 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Visio Professional 2013
  • Microsoft Visio Standard 2013
  • Microsoft Visio Premium 2010
  • Microsoft Visio Professional 2010
  • Microsoft Visio Standard 2010
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
Palavras-chave: 
kbpubtypekc kbopenfile kberrmsg kbdisplay kbhowtomaster kbtshoot kbprb kbmt KB826418 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 826418

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com