Como solucionar problemas de desenhos danificados no Visio

Traduções deste artigo Traduções deste artigo
ID do artigo: 826418 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

Este artigo descreve como solucionar problemas de desenhos danificados no Microsoft Office Visio 2013, Visio 2010, Visio 2007, Microsoft Office Visio 2003 e Microsoft Visio 2002. Este artigo descreve alguns sintomas que podem indicar que o desenho que você está trabalhando no Visio está danificado.

Além disso, este artigo lista alguns métodos de recuperação que você pode usar no desenho danificado. Eles incluem métodos de solução de problemas gerais, métodos para testar se você pode ou não é possível abrir o desenho e métodos para ajudar a evitar danos que podem ocorrer em desenhos.

INTRODUÇÃO

Visão geral

Se você enfrentar um comportamento inesperado quando você trabalha com um desenho do Visio, o desenho do Visio pode estar danificado. Se você tiver um desenho danificado, você pode receber as seguintes mensagens de erro:
  • "Falha de página inválida", "Falha de proteção geral" ou mensagens de erro de "Instrução ilegal"
  • Mensagens de erro são semelhantes a uma das seguintes opções quando você abre um desenho:

    Ocorreu um erro (100) durante a ação abrir

    Visio não pode abrir o arquivo porque ele não é um arquivo do Visio ou foi corrompido.
  • "Sem memória" mensagens de erro ou mensagens de erro que indicam os recursos do sistema insuficientes
Observação Essas mensagens de erro nem sempre significa que o desenho está danificado. No entanto, se você repetidamente tiver uma ou mais das seguintes mensagens de erro quando você trabalha com um determinado desenho, esse desenho pode estar danificado.

Este artigo lista alguns métodos que você pode usar para tentar recuperar o desenho danificado. Os métodos descritos neste artigo não garantem a recuperação bem-sucedida de um desenho danificado. Às vezes, dependendo do tipo de dano, você não poderá recuperar nenhum dado. Você terá que recriar o desenho ou restaurar o desenho de seus arquivos de backup.

Métodos de solução de problemas gerais

Inicie o Visio sem eventos de automação e sem o Microsoft Visual Basic for Applications

Inicie o Visio sem eventos de automação e de Visual Basic for Applications. Para fazer isso, use um dos seguintes métodos:

Método 1: Microsoft Office Visio 2013 e Visio 2010
  1. Inicie o Visio.
  2. Sobre o arquivo guia, clique em Opçõese, em seguida, clique em Central de confiabilidade.
  3. Clique em configurações da Central de confiabilidadee, em seguida, clique em Desabilitar todas as macros sem notificação.
  4. Clique em suplementos.
  5. Clique para selecionar o Desabilitar todos os complementos do aplicativo caixa de seleção.
  6. Clique em OK.
  7. Sair do Visio e, em seguida, reinicie o Visio.

Método 2: Microsoft Office Visio 2007
  1. Inicie o Visio normalmente.
  2. No menu Ferramentas , clique em Central de confiabilidade.
  3. Clique em Configurações de Macroe, em seguida, clique em Desabilitar todas as macros sem notificação.
  4. Clique em suplementos.
  5. Clique para selecionar a caixa de seleção Desabilitar todos os complementos do aplicativo .
  6. Clique em OK.
  7. Sair do Visio e, em seguida, reinicie o Visio.
Método 3: Microsoft Office Visio 2003 e versões anteriores do Visio
  1. Inicie o Visio normalmente.
  2. Use um dos seguintes procedimentos, dependendo da versão do Visio que você está executando:
    • Se você estiver executando o Visio 2003, clique em Opções no menu Ferramentas e, em seguida, clique na guia segurança .
    • Se você estiver executando o Visio 2002, clique em Opções no menu Ferramentas e, em seguida, clique na guia Avançado .
  3. Faça o seguinte:
    • Clique para desmarcar a caixa de seleção Ativar o Microsoft Visual Basic for Applications .

      Observação Depois que você clicar para desmarcar a caixa de seleção Ativar o Microsoft Visual Basic for Applications , a caixa de seleção Ativar o Microsoft Visual Basic for Applications de criação de projeto e a caixa de seleção carregar o Microsoft Visual Basic for Applications projeto a partir do texto fica indisponível.
    • Clique para desmarcar a caixa de seleção ativar suplementos .
    • Clique para desmarcar a caixa de seleção Permitir eventos de automação .
  4. Clique em OKe, em seguida, feche o Visio.
  5. Reinicie o Visio.
Método 4: Use o comando 'Copiar Desenho' para copiar cada página em uma página em um novo desenho.
Para o Visio 2013 e Visio 2010:
  1. Certifique-se de que nada no desenho está selecionado.
  2. Sobre o Home guia, no área de transferência de grupo, clique em Copiar.
  3. Abra o documento no qual deseja incorporar o desenho e, em seguida, na guiainício , no grupo de área de transferência , clique em Colar.
Para o Visio 2007 e do Visio 2003:
  1. No desenho do Microsoft Office Visio, verifique se nada está selecionado.
  2. No menu Editar , clique em Copiar desenho. Observação Este comando copia o desenho completo, incluindo formas em outras páginas de desenho e em segundo plano. Quando você incorpora um desenho do Visio de várias páginas, a página visível será aquela que estiver ativa quando você clicar em Copiar desenho.
  3. Abra o documento no qual você deseja incorporar o desenho e, em seguida, no Editar menu, clique em Colar (ou comando equivalente).
    Código-fonte: O Visio 2007 ajuda e instruçõeshttp://Office.microsoft.com/en-US/Visio/HP012314701033.aspx

Inicie o Windows no modo de segurança

Inicie o Windows no modo de segurança. Para fazer isso:

Observação Como existem várias versões do Microsoft Windows, as etapas a seguir podem ser diferentes no seu computador. Se isso acontecer, consulte a documentação do produto para concluir estas etapas.
  1. Desligue e reinicie o computador.
  2. Quando você vir a mensagem "Selecione o sistema operacional a ser iniciado", pressione F8.
  3. Sobre o Opções avançadas do Windows<b00> </b00> menu, use as teclas de seta para selecionar Modo de segurançae, em seguida, pressione ENTER.
  4. Se você tiver um computador de dupla inicialização ou inicialização múltipla, selecione o sistema operacional adequado na lista que aparece e pressione ENTER.
  5. Inicie o Visio e, em seguida, tente abrir o desenho.
Para obter mais informações sobre o modo de segurança, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento Microsoft:
315222 Uma descrição das opções de inicialização de modo seguro no Windows XP
202485 Descrição do modo de inicialização segura no Windows 2000
180902 Como iniciar um computador baseado no Windows 98 no modo de segurança

Métodos para testar se você não conseguir abrir um desenho

Método 1: Arraste o arquivo de desenho para o ícone do arquivo Visio.exe

Arraste o arquivo de desenho para o ícone que representa o arquivo Visio.exe. Para fazer isso: se você estiver executando o Visio 2010, o arquivo Visio.exe exe está localizado na seguinte pasta: unidade: \Program Files\Microsoft Office\Office14, * se você instalou o Visio 32 bits no Windows de 64 bits a pasta arquivos de programa terá um (x86) atrás o nome da pasta. Visio 2010 agora tem uma versão de 64 bits nativa.
  1. Encerre o Visio.
  2. Inicie o Microsoft Windows Explorer e localize o arquivo Visio.exe em seu disco rígido. Se você instalou o Visio no local padrão, o arquivo Visio.exe está localizado em uma das seguintes pastas, dependendo da versão do Visio que você está executando:
    • Se você estiver executando o Visio 2013, o arquivo Visio.exe exe está localizado na seguinte pasta:
      Unidade: \Program Files\Microsoft Office\Office15
      ObservaçãoSe você instalou uma versão de 32 bits do Visio em uma versão de 64 bits do Windows, na pasta arquivos de programa terá um (x86) atrás o nome da pasta. Visio 2013 agora tem uma versão de 64 bits nativa.
    • Se você estiver executando o Visio 2010, o arquivo Visio.exe exe está localizado na seguinte pasta: unidade: \Program Files\Microsoft Office\Office14 Observação se você instalou uma versão de 32 bits do Visio em uma versão de 64 bits do Windows, a pasta arquivos de programa terá um (x86) atrás o nome da pasta. Visio 2010 agora tem uma versão de 64 bits nativa.


      Se você estiver executando o Visio 2007, o arquivo Visio.exe exe está localizado na seguinte pasta:
      Unidade: \Program Files\Microsoft Office\Office12
      Se você estiver executando o Visio 2003, o arquivo Visio.exe exe está localizado na seguinte pasta:
      Unidade: \Program Files\Microsoft Office\Visio11
    • Se você estiver executando o Visio 2002, o arquivo Visio.exe exe está localizado na seguinte pasta:
      Unidade: \Program Files\Microsoft Office\Visio10
      Observação Se você instalou o Visio para uma pasta que é diferente do local de instalação padrão, o caminho do arquivo Visio.exe é diferente em seu computador.
  3. No Windows Explorer, localize o arquivo de desenho que você deseja abrir.
  4. Arraste o arquivo de desenho para o ícone que representa o arquivo Visio.exe.

Método 2: Clique duas vezes no arquivo de desenho no Windows Explorer

Tente abrir o arquivo de desenho usando o Windows Explorer. Para fazer isso:
  1. Encerre o Visio.
  2. Inicie o Windows Explorer e localize o arquivo de desenho que você deseja abrir.
  3. Clique duas vezes no arquivo de desenho.

Método 3: Abrir a cópia temporária do arquivo de desenho

Quando você modifica um desenho do Visio, é criada uma cópia temporária do arquivo de desenho. A cópia temporária do arquivo de desenho chamada ~ $$Nome do arquivo. ~ vsd. Normalmente, a cópia temporária do arquivo de desenho é criada e armazenada na mesma pasta onde se encontra o desenho.

Para abrir a cópia temporária do arquivo de desenho, faça o seguinte:
  1. Inicie o Visio e abra seu desenho.
  2. Inicie o Windows Explorer e localize a pasta onde o desenho está armazenado. Procure nesta pasta para a cópia temporária do arquivo de desenho. A cópia temporária do arquivo de desenho chamada ~ $$Nome do arquivo. ~ vsd.

    Observação Se a cópia temporária do arquivo de desenho não estiver localizada na pasta onde está armazenado o desenho, busca no disco rígido para a cópia temporária do arquivo de desenho.

    Para pesquisar o disco rígido para a cópia temporária do arquivo de desenho, faça o seguinte:

    Observação Como existem várias versões do Microsoft Windows, as etapas a seguir podem ser diferentes no seu computador. Se isso acontecer, consulte a documentação do produto para concluir estas etapas.
    1. Clique em Iniciare, em seguida, clique em Pesquisar.
    2. Clique em todos os arquivos e pastas.
    3. Na caixa todo ou parte do nome do arquivo , digite ~$$Nome do arquivo. ~ vsde, em seguida, clique em Pesquisar.
  3. Altere a extensão da cópia temporária do arquivo de desenho para. vsd. Para fazer isso:
    1. Clique com botão direito a cópia temporária do arquivo de desenho e, em seguida, clique em Renomear.
    2. Altere a extensão da cópia temporária do arquivo de desenho de ~.vsd a. vsd.
  4. Tente abrir a cópia temporária do arquivo de desenho que você renomeou.

Método 4: Usar o Visualizador do Microsoft Office Visio para abrir o desenho

Instalar o Microsoft Office Visio Viewer 2010 e usar o Visualizador do Visio para abrir e exibir o seu desenho. Quando você instala o Visio Viewer 2010, você pode usar o Microsoft Internet Explorer 5.0 ou uma versão posterior do Internet Explorer para exibir desenhos e diagramas criados com o Visio 2010, Visio 2007, Visio 2003, Visio 2002, Microsoft Visio 2000 ou Microsoft Visio 5. Para obter mais informações sobre o Visio Viewer 2010, visite o seguinte site da Microsoft:

http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&ID=21701

Se você conseguir abrir o desenho no Visio Viewer, a instalação do Visio em seu computador pode estar danificada ou seu desenho pode conter um ou mais objetos que podem ser danificados.

Método 5: Copiar o arquivo de desenho para outro computador

Copie o arquivo de desenho para outro computador que tenha o Visio instalado. Se abrir o desenho no computador, salve o arquivo de desenho em uma pasta diferente no disco rígido do computador e, em seguida, copie o arquivo de desenho de volta para o computador original.

Método 6: Copiar o arquivo de desenho para outro disco no seu computador

Windows pode não ser capaz de ler o arquivo de desenho onde o arquivo de desenho é salvo no momento. Copie o arquivo de desenho para outro disco no seu computador. Por exemplo, copie o arquivo de um disquete para o disco rígido. Depois de copiar o arquivo de desenho em um disco diferente no seu computador, tente abrir o arquivo de desenho.

Observação Se você não pode copiar o arquivo de desenho do disco em que o arquivo de desenho é salvo, o arquivo de desenho pode estar com referência cruzada com outros arquivos ou pastas ou o arquivo de desenho pode estar localizado em um setor danificado do disco. Para solucionar esse problema, siga as etapas no método 7.

Método 7: Detectar e reparar erros no disco rígido

Se você estiver executando o Microsoft Windows Server 2003, Microsoft Windows XP, Microsoft Windows 2000 ou Microsoft Windows NT 4.0, use a ferramenta Verificar disco para detectar erros de sistema de arquivo ou setores defeituosos no seu disco rígido.

Para obter mais informações, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento Microsoft:
315265 Como executar o disco verificação de erros no Windows XP
156571 Como executar o Scandisk no Windows

Se você estiver executando o Microsoft Windows Millennium Edition (Me) ou Microsoft Windows 98, use a ferramenta Scandisk para detectar erros de sistema de arquivo ou setores defeituosos no seu disco rígido.

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento Microsoft:
186365 Descrição do ScanDisk para o Windows (Scandskw.exe) no Windows 98 / Me

Observação Embora a ferramenta Verificar disco ou a ferramenta ScanDisk pode detectar e reparar erros do sistema de arquivo ou setores defeituosos no disco rígido, o Visio ainda não poderá abrir ou ler o arquivo.

Se você estiver executando o Windows Vista, visite o seguinte site da Microsoft para obter mais informações:
http://windowshelp.microsoft.com/Windows/en-US/help/bc1393cf-9f9c-79c7-0f91-9337c2c41f811033.mspx
Método 8: Abrir uma "cópia de sombra anterior" usando a guia versões anteriores


1. Clique duas vezes no arquivo do Visio
2. Escolha Propriedades
3. Selecione a guia versões anteriores, dar algum tempo para preencher a lista
4. Selecione uma versão mais antiga do arquivo.
5. Clique em Abrir
6. Se o arquivo for aberto com êxito, no menu Arquivo clique em Salvar como e salvar uma cópia do arquivo.



Métodos para testar se você pode abrir o desenho

Método 1: Salvar o arquivo como um desenho XML

Salve o desenho como um desenho XML (arquivo. vdx) e, em seguida, salve o desenho como um desenho (arquivo. vsd) XML. Para fazer isso:
  1. Inicie o Visio e abra seu desenho.
  2. No menu arquivo , clique em Salvar como.
  3. Na caixa de diálogo Salvar como , clique em Desenho XML (*. vdx)<b00> </b00> na caixa Salvar como tipo e digite um nome de arquivo na caixa nome do arquivo . Especifique um local onde você deseja salvar o arquivo de desenho e, em seguida, clique em Salvar.
  4. Feche todos os desenhos abertos no momento.
  5. No menu arquivo , clique em Abrir.
  6. Localize o desenho XML (. vdx) que você salvou anteriormente na etapa 3 e, em seguida, clique em Abrir.
  7. No menu arquivo , clique em Salvar como.
  8. Na caixa de diálogo Salvar como , clique em desenho (*. vsd)<b00> </b00> na caixa Salvar como tipo e digite um nome de arquivo na caixa nome do arquivo . Especifique um local onde você deseja salvar o arquivo de desenho e, em seguida, clique em Salvar.
  9. Feche o desenho.
  10. No menu arquivo , clique em Abrir
  11. Localize o desenho (arquivo. vsd) que você salvou anteriormente na etapa 8 e clique em Abrir.

Método 2: Inserir o desenho para um novo desenho em branco

Inserir o desenho para um novo desenho em branco. Para fazer isso:

Para o Visio 2013 e Visio 2010:
  1. Inicie o Visio
  2. Sob o arquivo guia, em novo, selecione Desenho em brancoe, em seguida, clique nocriar botão.
  3. Sobre o Inserir , clique em objeto.
  4. Clique em Criar do arquivoe, em seguida, clique em Procurar.
  5. Selecione desenhar, clique emAbrire, em seguida, clique em OK.
  6. Dependendo da situação, determinar se o arquivo de desenho está danificado ou se há outro problema.
    • Se você receber um "Erro 3400" mensagem de erro, o arquivo de desenho pode estar danificado. Use os métodos descritos neste artigo para tentar recuperar o desenho.
    • Se você não receber um "Erro 3400" mensagem de erro, pode haver um outro problema que pode estar impedindo que o Visio abrir o desenho. Por exemplo, um conflito pode existir entre certos componentes no computador que impedem que abrir o desenho do Visio.
Para o Visio 2007 e do Visio 2003:
  1. Inicie o Visio.
  2. No menu arquivo , aponte para novoe, em seguida, clique em Novo desenho.
  3. No menu Inserir , clique em objeto.
  4. Clique em Criar do arquivoe, em seguida, clique em Procurar.
  5. Clique no desenho, clique em Abrire, em seguida, clique em OK.
  6. Dependendo da situação, determinar se o arquivo de desenho está danificado ou se há outro problema.
    • Se você receber um "Erro 3400" mensagem de erro, o arquivo de desenho pode estar danificado. Use os métodos descritos neste artigo para tentar recuperar o desenho.
    • Se você não receber um "Erro 3400" mensagem de erro, pode haver um outro problema que pode estar impedindo que o Visio abrir o desenho. Por exemplo, um conflito pode existir entre certos componentes no computador que impedem que abrir o desenho do Visio.
    S

Métodos para ajudar a evitar danos aos desenhos

Você não pode impedir todos os danos que podem ocorrer em arquivos. Talvez devido ao desgaste discos rígidos, fontes de alimentação poderão falhar e outros eventos imprevisíveis podem ocorrer que fazer com que arquivos danificados. As dicas e sugestões a seguir podem ajudar a reduzir o número de ficheiros danificados que ocorrem no Visio e em outros programas.

Otimizar a configuração de AutoRecuperação no Visio

Defina a configuração de AutoRecuperação como um valor que funciona para você. Se seu computador parar de responder ou se você ficar sem energia inesperadamente, o Visio abre o arquivo de AutoRecuperação na próxima vez que você iniciar o programa. O arquivo de AutoRecuperação pode conter informações não salvas que seriam perdidas do arquivo de desenho original. Se o arquivo do desenho original foi danificado, você poderá recuperar as informações do arquivo de AutoRecuperação.

Para definir a configuração de AutoRecuperação no Visio:
  1. Inicie o Visio.
  2. No menu Ferramentas , clique em Opções.
  3. Clique na guia Salvar ou Salvar/abrir .
  4. Selecione o Salvar informações de AutoRecuperação cada caixa de seleção e, em seguida, especifique o tempo em minutos que você deseja. Por padrão, a configuração de AutoRecuperação é definida para 10 minutos.
  5. Clique em OK.

Certifique-se de que a fonte de alimentação está consistente

Uma fonte de alimentação não é consistente pode causar danos aos arquivos, mesmo que você não perca energia. Uma fonte de alimentação picos ou que não é suficiente pode afetar o processo de leitura e gravação processos em seu computador e pode causar danos. Se a fonte de alimentação na sua área é inconsistente, use um protetor contra sobretensão. Protetores contra sobretensão podem ajudar a evitar danos em seu computador se ocorrerem picos de energia. Você também pode considerar o uso de uma fonte de alimentação ininterrupta (UPS). Unidades de no-break fornecem seu computador com energia mesmo se houver uma queda de energia. Entre em contato com o fornecedor do hardware para obter mais informações sobre como obter qualquer um desses dispositivos.

Fazer backup dos dados

Certifique-se de que você faça backup de seus dados regularmente. Por exemplo, armazene uma cópia de backup do seu desenho em um volume diferente no disco rígido. Ou, dependendo das suas necessidades e seu ambiente, implementar outros backups ou outras soluções de tolerância a falhas em seu computador. Algumas soluções de tolerância a falhas, como Redundant Array of Independent discos (RAID), normalmente são apenas práticas para redes maiores. Outras opções de backup incluem o seguinte:
  • Backup em fita
  • CD de backup
  • Volume espelhado
  • Volume RAID-5
  • Unidade de disco rígido externa
  • Unidade USB (Flash)

Trabalhar com os dados localmente

Se você trabalha em um ambiente de rede e você enfrentar problemas com freqüência, convém considerar a copiar os arquivos para o computador local antes de abri-lo ou para modificar o arquivo. Copie o arquivo para sua área de trabalho usando meu computador ou usando o Windows Explorer. Quando você trabalha com arquivos armazenados no computador local, você evitar problemas de leitura ou gravação problemas que podem ser causados por problemas de conectividade de rede, como as seguintes:
  • Conexões de rede lentas
  • Conexões de rede ignorados
  • Picos no tráfego de rede
Também convém considerar trabalhando a partir do disco rígido e não trabalhando a partir de mídia removível como um disquete ou uma unidade ZIP. A mídia mais e mais drivers de dispositivo estão envolvidos em uma operação Salvar operação, a mais a maior possibilidade de danos ao arquivo.

Referências

Para obter mais informações sobre o Visio, visite os seguintes sites da Microsoft:

Propriedades

ID do artigo: 826418 - Última revisão: terça-feira, 29 de outubro de 2013 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Visio Professional 2013
  • Microsoft Visio Standard 2013
  • Microsoft Visio Premium 2010
  • Microsoft Visio Professional 2010
  • Microsoft Visio Standard 2010
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
Palavras-chave: 
kbpubtypekc kbopenfile kberrmsg kbdisplay kbhowtomaster kbtshoot kbprb kbmt KB826418 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido pelo software de tradução automática da Microsoft e eventualmente pode ter sido editado pela Microsoft Community através da tecnologia Community Translation Framework (CTF) ou por um tradutor profissional. A Microsoft oferece artigos traduzidos automaticamente por software, por tradutores profissionais e editados pela comunidade para que você tenha acesso a todos os artigos de nossa Base de Conhecimento em diversos idiomas. No entanto, um artigo traduzido pode conter erros de vocabulário, sintaxe e/ou gramática. A Microsoft não é responsável por qualquer inexatidão, erro ou dano causado por qualquer tradução imprecisa do conteúdo ou por seu uso pelos nossos clientes.
Clique aqui para ver a versão em Inglês deste artigo: 826418

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com