Устранение поврежденных документов в Visio

Переводы статьи Переводы статьи
Код статьи: 826418 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Аннотация

В этой статье описано устранение поврежденных документов в Microsoft Office Visio 2013, Visio 2010, Visio 2007, Microsoft Office Visio 2003 и Microsoft Visio 2002. Данная статья содержит некоторые признаки, которые могут означать, что поврежден рисунок, с которым вы работаете в Visio.

Кроме того в этой статье перечислены некоторые методы, которые можно использовать для восстановления поврежденного документа. Они включают общие способы устранения неполадок, методы, которые можно предпринять, если можно или нельзя открыть рисования и способы предотвращения ущерба, который может возникнуть для рисунков.

ВВЕДЕНИЕ

Обзор

Если при работе с рисунком Visio можно испытать неожиданное поведение, чертеж Visio может быть поврежден. При наличии поврежденного документа может появиться следующие сообщения об ошибках:
  • «Недопустимая страница,» "Общей ошибке защиты" или сообщения об ошибке «Недопустимая инструкция»
  • Сообщения об ошибке, подобное одному из следующих при открытии рисунка:

    При выполнении действия "Открыть" произошла ошибка (100)

    Не удается открыть файл, поскольку он не является файлом Visio или поврежден.
  • "Недостаточно памяти" сообщения об ошибках и сообщений об ошибках, указывающие нехватка системных ресурсов
Примечание Эти сообщения об ошибках не всегда означает что документ поврежден. Тем не менее если постоянно возникают одно или несколько из этих сообщений об ошибке при работе с конкретного документа, этот документ может быть поврежден.

В этой статье перечислены некоторые методы, которые можно использовать для восстановления поврежденного документа. Методы, описанные в этой статье не гарантирует успешное восстановление поврежденного документа. Иногда в зависимости от типа повреждения не можно восстановить все данные. Может потребоваться повторно создать рисунок или восстановление рисунка из архивных файлов.

Общие методы устранения неполадок

Запуск Visio без событий автоматизации и без Microsoft Visual Basic для приложений

Запустите Visio без событий автоматизации и Visual Basic для приложений. Воспользуйтесь для этого одним из указанных ниже способов.

Метод 1. Microsoft Office Visio 2013 и Visio 2010
  1. Запустите Visio.
  2. На файл вкладке, нажмите кнопку Параметрыи выберите Центр управления безопасностью.
  3. Нажмите кнопку Параметры Центра управления безопасностьюи выберите Отключить все макросы без уведомления.
  4. Нажмите кнопку надстройки.
  5. Установите Отключить все надстройки приложений флажок.
  6. Нажмите кнопку ОК.
  7. Выйдите из Visio, а затем перезагрузите Visio.

Метод 2: Microsoft Office Visio 2007
  1. Запустите Visio.
  2. В меню Сервис выберите Центр управления безопасностью.
  3. Щелкните Настройки макросови нажмите кнопку Отключить все макросы без уведомления.
  4. Нажмите кнопку надстройки.
  5. Установите флажок Отключить все надстройки приложений.
  6. Нажмите кнопку ОК.
  7. Выйдите из Visio, а затем перезагрузите Visio.
Способ 3. Microsoft Office Visio 2003 и более ранние версии Visio
  1. Запустите Visio.
  2. Воспользуйтесь одним из следующих процедур в зависимости от версии установленной Visio.
    • При использовании Visio 2003 в меню Сервис выберите команду Параметры и откройте вкладку Безопасность .
    • При запуске Visio 2002, выберите команду Параметры в меню Сервис и перейдите на вкладку Дополнительно .
  3. Выполните следующие действия.
    • Щелкните, чтобы снять флажок Включить Microsoft Visual Basic для приложений .

      Примечание После щелчка снимите флажок Включить Microsoft Visual Basic для приложений , флажок Включить Microsoft Visual Basic для приложений проекта создания и загрузки Microsoft Visual Basic для приложений проекта из текста флажок становится недоступным.
    • Щелкните, чтобы снять флажок Разрешить COM-надстройки .
    • Щелкните, чтобы снять флажок Разрешить события автоматизации .
  4. Нажмите кнопку ОКи выйдите из Visio.
  5. Перезагрузите Visio.
Способ 4: Используйте команды Копировать изображения для копирования каждой страницы на страницу в новый документ.
Visio 2013 и Visio 2010:
  1. Убедитесь, что не в рисунок выделен.
  2. На дома в области буфера обмена группу, нажмите кнопку Копировать.
  3. Откройте документ, в котором вы хотите внедрить рисунок, а затем на вкладкеГлавная в группе буфер обмена нажмите кнопку Вставить.
Для Visio 2007 и Visio 2003:
  1. В документ Microsoft Office Visio, убедитесь, что ничего не выбрано.
  2. В меню Правка выберите пункт Копировать рисунок. Примечание Эта команда копирует весь рисунок, включая фигуры на другие страницы рисунка и фоновые рисунки. При внедрении нескольких страниц чертеж Visio, отображается страница будет той, которая активна при нажатии кнопки Копирования рисунка.
  3. Откройте документ, в который следует внедрить рисунок, а затем на Изменить меню, нажмите кнопку Вставить (или эквивалентную команду).
    Источник: Visio 2007 Справка и инструкцииhttp://Office.Microsoft.com/en-US/Visio/HP012314701033.aspx

Запуск Windows в безопасном режиме

Запуск Windows в безопасном режиме. Для этого:

Примечание Поскольку существует несколько версий Microsoft Windows, следующие действия могут отличаться на вашем компьютере. Если это так, обратитесь к документации продукта для выполнения этих действий.
  1. Завершите работу и перезагрузите компьютер.
  2. При появлении сообщения «Выберите операционную систему для запуска» нажмите клавишу F8.
  3. На дополнительных вариантов загрузки Windows<b00> </b00> меню с помощью клавиш со стрелками выберите Безопасный режими нажмите клавишу ВВОД.
  4. Если у вас есть двойной и множественной загрузкой компьютера, выберите соответствующую операционную систему из списка, который появляется и нажмите клавишу ВВОД.
  5. Запустите Visio и затем попытайтесь открыть документ.
Дополнительные сведения о безопасном режиме щелкните приведенные ниже номера статей базы знаний Майкрософт:
315222 Описание возможных вариантов загрузки в безопасном режиме Windows XP
202485 Описание безопасного режима загрузки Windows 2000
180902 Как запустить компьютер под управлением Windows 98 в безопасном режиме

Методы, которые можно предпринять, если не удается открыть документ

Метод 1: Перетащите графический файл на значок файла Visio.exe

Перетащите графический файл значка, представляющего файл Visio.exe. Для этого: при запуске Visio 2010 файл Visio.exe находится в следующей папке: Office\Office14 диск: \Program Files\Microsoft * при установке Visio 32-разрядной Windows 64-разрядной будет иметь папку Program Files (x 86) за имя папки. Visio 2010 теперь имеет собственный 64-разрядной версии.
  1. Выйдите из Visio.
  2. Запустите проводник Windows и найдите файл Visio.exe на жестком диске. Если приложение Visio установлено в расположение по умолчанию, файл Visio.exe находится в одной из следующих папок, в зависимости от версии установленной Visio:
    • При запуске Visio 2013 файл Visio.exe находится в следующей папке:
      Диск: \Program Files\Microsoft Office\Office15
      ПримечаниеПри установке 32-разрядной версии программы на 64-разрядной версии Windows в папку Program Files будет иметь (x 86) за имя папки. Visio 2013 теперь имеет собственный 64-разрядной версии.
    • При запуске Visio 2010 файл Visio.exe находится в следующей папке: диск: будет иметь \Program Files\Microsoft Office\Office14 Примечание при установке 32-разрядной версии программы на 64-разрядной версии Windows в папке Program Files (x 86) за имя папки. Visio 2010 теперь имеет собственный 64-разрядной версии.


      При запуске Visio 2007 файл Visio.exe находится в следующей папке:
      Диск: \Program Files\Microsoft Office\Office12
      При использовании Visio 2003, файл Visio.exe находится в следующей папке:
      Диск: \Program Files\Microsoft Office\Visio11
    • При запуске Visio 2002 файл Visio.exe находится в следующей папке:
      Диск: \Program Files\Microsoft Office\Visio10
      Примечание Если приложение Visio установлено в папке, отличной от местоположение установки по умолчанию, путь к файлу Visio.exe на каждом компьютере.
  3. В проводнике Windows найдите графический файл, который требуется открыть.
  4. Перетащите графический файл значка, представляющего файл Visio.exe.

Метод 2: Графический файл в проводнике Windows дважды щелкните значок

Попробуйте открыть графический файл с помощью проводника Windows. Для этого:
  1. Выйдите из Visio.
  2. Запустите проводник Windows и найдите файл рисунка, который требуется открыть.
  3. Дважды щелкните файл документа.

Способ 3: Откройте временную копию файла изображения

При изменении документа Visio создается временная копия файла изображения. Временную копию файла документа с именем ~ $$Имя файла. ~ vsd. Временная копия файла изображения обычно создается и хранится в папке, в которой находится рисунок.

Чтобы открыть временную копию графического файла, выполните следующие действия:
  1. Запуск Visio, а затем откройте документ.
  2. Запустите проводник Windows и найдите папку, в которой хранится документ. Откройте временную копию файла изображения в этой папке. Временную копию файла документа с именем ~ $$Имя файла. ~ vsd.

    Примечание Если временную копию файла изображения не находится в папке, в которой хранится рисунок, поиск жесткий диск на временную копию файла изображения.

    Чтобы найти жесткий диск на временную копию графического файла, выполните следующие действия:

    Примечание Поскольку существует несколько версий Microsoft Windows, следующие действия могут отличаться на вашем компьютере. Если это так, обратитесь к документации продукта для выполнения этих действий.
    1. Нажмите кнопку Пуски нажмите кнопку Найти.
    2. Выберите все файлы и папки.
    3. Введите в поле часть имени файла~$$Имя файла. ~ vsdи нажмите кнопку Найти.
  3. Измените расширение временную копию графического файла .vsd. Для этого:
    1. Щелкните правой кнопкой мыши временную копию графического файла и выберите команду Переименовать.
    2. Измените расширение временную копию файла изображения с ~.vsd на .vsd.
  4. Попробуйте открыть временную копию графического файла, который был переименован.

Способ 4: С помощью средства просмотра Microsoft Office Visio для открытия документа

Установите Microsoft Office Visio Viewer 2010, а затем открывать и просматривать документ с помощью средства просмотра Visio. При установке Visio Viewer 2010 можно использовать Microsoft Internet Explorer 5.0 или более поздней версии обозревателя Internet Explorer для просмотра рисунков и диаграмм, созданных с помощью Visio 2010, Visio 2007, Visio 2003, Visio 2002, Microsoft Visio 2000 или Microsoft Visio 5 Visio. Дополнительные сведения о средстве просмотра Visio 2010 посетите следующий веб-узел корпорации Майкрософт:

http://www.Microsoft.com/en-US/Download/Details.aspx?displaylang=en&ID=21701

При открытии документа в Visio Viewer установке Visio на компьютере может быть поврежден или рисунок может содержать один или несколько объектов, которые могут быть повреждены.

Метод 5: Скопируйте графический файл на другой компьютер

Скопируйте графический файл на другой компьютер с установленной на нем Visio. При открытии документа на компьютере сохранить графический файл в другую папку на жестком диске компьютера и скопировать графический файл исходного компьютера.

Способ 6: Скопируйте графический файл на другой диск на компьютере

Windows не сможет прочитать файл рисунка из в настоящее время сохранения файла изображения. Скопируйте графический файл на другой диск на компьютере. Например скопируйте файл с гибкого диска на жесткий диск. После копирования файла изображения на другой диск на вашем компьютере, попробуйте открыть графический файл.

Примечание Если не удается скопировать файл рисунка на диске, где сохранен файл рисунка, графический файл может быть общими кластерами с других файлов или папок или графический файл может находиться в поврежденный сектор диска. Чтобы устранить эту проблему, выполните действия в методе 7.

Метод 7: Обнаружение и исправление ошибок на жестком диске

При запуске Microsoft Windows Server 2003, Microsoft Windows XP, Microsoft Windows 2000 или Microsoft Windows NT 4.0, используйте инструмент «Проверка диска» для обнаружения ошибок файловой системы и поврежденных секторов на жестком диске.

Для получения дополнительных сведений щелкните следующие номера статей базы знаний Майкрософт:
315265 Как выполнить ошибок дисков в Windows XP
156571 Как выполнить Scandisk в Windows

При использовании Microsoft Windows Millennium Edition (Me) или Microsoft Windows 98 с помощью средства Scandisk для обнаружения ошибок файловой системы и поврежденных секторов на жестком диске.

Для получения дополнительных сведений щелкните следующий номер статьи базы знаний Майкрософт:
186365 Описание программы ScanDisk for Windows (Scandskw.exe) в Windows 98/Me

Примечание Несмотря на то, что инструмент «Проверка диска» или средства ScanDisk может обнаружить и устранить ошибки файловой системы и поврежденных секторов на жестком диске, Visio может по-прежнему невозможно открыть или прочитать файл.

Если используется Windows Vista, посетите следующий веб-узел корпорации Майкрософт для получения дополнительных сведений:
http://windowshelp.Microsoft.com/Windows/en-US/Help/bc1393cf-9f9c-79c7-0f91-9337c2c41f811033.mspx
Метод 8: Откройте «теневой копии» на вкладке предыдущие версии


1. Щелкните правой кнопкой мыши файл Visio
2. Выберите пункт Свойства
3. Выберите вкладку «предыдущие версии», дать некоторое время для заполнения списка
4. Установите старую версию файла
5. Нажмите кнопку Открыть
6. Если файл открыт успешно, в меню Файл выберите команду Сохранить как и сохраните копию файла



Способов при открытии документа

Метод 1: Сохранения файла в виде XML-документа

Сохраните документ как документ XML (файл .vdx), а затем сохраните XML документа как рисунок (VSD-файл). Для этого:
  1. Запуск Visio, а затем откройте документ.
  2. В меню файл выберите команду Сохранить как.
  3. В диалоговом окне Сохранить как щелкните XML-документа (*.vdx)<b00> </b00> в поле Тип файла, а затем введите имя файла в поле имя файла . Укажите расположение, где требуется сохранить файл рисунка и нажмите кнопку Сохранить.
  4. Закройте все рисунки, которые открыты в настоящий момент.
  5. В меню Файл выберите команду Открыть.
  6. Найдите документ XML (.vdx), созданный на шаге 3 и нажмите кнопку Открыть.
  7. В меню файл выберите команду Сохранить как.
  8. В диалоговом окне Сохранить как щелкните документа (*.vsd)<b00> </b00> в поле Тип файла, а затем введите имя файла в поле имя файла . Укажите расположение, где требуется сохранить файл рисунка и нажмите кнопку Сохранить.
  9. Закройте документ.
  10. В меню Файл выберите команду Открыть
  11. Найдите документ (VSD-файл), созданный на шаге 8 и нажмите кнопку Открыть.

Метод 2: Вставка рисунка для нового пустого документа

Вставка рисунка для нового пустого документа. Для этого:

Visio 2013 и Visio 2010:
  1. Запуск Visio
  2. В разделе файла вкладку в группе Создатьвыберите Пустой рисуноки нажмите кнопкуСоздание кнопки.
  3. На Вставить , щелкните объект.
  4. Выберите вариант Создать из файлаи нажмите кнопку Обзор.
  5. Выберите рисунок, нажмите кнопкуОткрытьи нажмите кнопку ОК.
  6. В зависимости от ситуации, определить, поврежден ли файл рисунка или является ли другая проблема.
    • Если вы получаете "3400" сообщение об ошибке, графический файл может быть поврежден. С помощью методов, описанных в этой статье, чтобы попытаться восстановить рисунок.
    • Если вы не получите "3400" сообщение об ошибке, может быть другая проблема, которая может препятствовать Открытие документа Visio. Например конфликт может существовать между некоторые компоненты на компьютере предотвратить открытие документа Visio.
Для Visio 2007 и Visio 2003:
  1. Запустите Visio.
  2. В меню файл выделите пункт Создатьи выберите команду Создать рисунок.
  3. В меню Вставка выберите команду объект.
  4. Выберите вариант Создать из файлаи нажмите кнопку Обзор.
  5. Щелкните рисунок, нажмите кнопку Открытьи нажмите кнопку ОК.
  6. В зависимости от ситуации, определить, поврежден ли файл рисунка или является ли другая проблема.
    • Если вы получаете "3400" сообщение об ошибке, графический файл может быть поврежден. С помощью методов, описанных в этой статье, чтобы попытаться восстановить рисунок.
    • Если вы не получите "3400" сообщение об ошибке, может быть другая проблема, которая может препятствовать Открытие документа Visio. Например конфликт может существовать между некоторые компоненты на компьютере предотвратить открытие документа Visio.
    S

Методы, чтобы избежать повреждения рисунков

Невозможно запретить все повреждения, которые могут возникнуть в файлы. Может изнашиваться жесткие диски, может произойти сбой питания и другие непредвиденные события могут происходить, вызывающие повреждения файлов. Следующие советы и рекомендации помогут уменьшить количество поврежденных файлов, которые происходят в Visio и в других программах.

Оптимизация параметров автосохранения в Visio

Настройте каталог данных для автовосстановления для значения, которое работает для вас. Если компьютер перестает отвечать на запросы или если Электричество неожиданно, Visio открывает файл автосохранения при следующей загрузке программы. Файл автосохранения может содержать несохраненные данные, которые в противном случае будут потеряны из исходного файла рисунка. Если исходный графический файл был поврежден, можно восстановить данные из файла автовосстановления.

Чтобы настроить параметры автосохранения в Visio:
  1. Запустите Visio.
  2. В меню Сервис выберите команду Параметры.
  3. Перейдите на вкладку Сохранение или Сохранение и открытие .
  4. Выберите Автосохранение каждые установите флажок и укажите время в минутах, которые требуется. По умолчанию параметр автоматического восстановления имеет значение 10 минут.
  5. Нажмите кнопку ОК.

Убедитесь в том, что блок питания не противоречит

Блок питания, не согласующийся могут повредить файлы, даже если вы не потеряете питания. Блок питания, что пики или недостаточно может повлиять на процесс чтения и записи на компьютере процессов и может привести к повреждению. Если нарушена питания в вашем регионе, используйте сетевой фильтр. Защиты от бросков напряжения может предотвратить повреждение компьютера при возникновении пиков питания. Можно также попытаться использовать источник бесперебойного питания (ИБП). Устройства ИБП питания компьютера с питанием даже в случае сбоя питания. Обратитесь к поставщику оборудования для получения дополнительных сведений о получении любого из этих устройств.

Резервное копирование данных

Убедитесь, что вы резервное копирование данных регулярно. Например можно хранить резервную копию рисунка на другой том на жестком диске. Или в зависимости от требований и среды, реализации других резервных копий или других отказоустойчивых решений на локальном компьютере. Некоторые отказоустойчивые решения, например, избыточные массив из независимых дисков (RAID), подходят обычно только для более крупных сетей. Ниже перечислены другие параметры резервного копирования.
  • Резервного копирования на магнитной ленте
  • Резервное копирование с компакт-диска
  • Зеркальный том
  • Тома RAID-5
  • Внешний жесткий диск
  • Устройство USB (флэш-памяти)

Работа с данными локально

Если при работе в сетевой среде, часто возникать повреждение можно копирование файлов на локальный компьютер, прежде чем открыть файл или перед внесением изменений в файл. Скопируйте файл на рабочий стол с помощью Мой компьютер или в проводнике Windows. При работе с файлами, которые хранятся на локальном компьютере, можно предотвратить проблемы чтения или записи проблемы, которые могут быть вызваны следующие проблемы сетевого подключения:
  • Медленные сетевые подключения
  • Удаленные сетевые подключения
  • Пики сетевого трафика
Можно также рассмотреть работа с жесткого диска и не работает со съемного носителя, например, на дискету или ZIP-диск. Дополнительные носители и дополнительные драйверы устройств, участвующих в сохранения операции, несколько повысить вероятность повреждения файла.

Ссылки

Дополнительные сведения о Visio посетите следующие веб-узлы корпорации Майкрософт:

Свойства

Код статьи: 826418 - Последний отзыв: 7 октября 2013 г. - Revision: 9.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Visio Professional 2013
  • Microsoft Visio Standard 2013
  • Microsoft Visio Premium 2010
  • Microsoft Visio Professional 2010
  • Microsoft Visio Standard 2010
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
Ключевые слова: 
kbPubTypeKC kbopenfile kberrmsg kbdisplay kbhowtomaster kbtshoot kbprb kbmt KB826418 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Данная статья переведена с использованием программного обеспечения Майкрософт для машинного перевода и, возможно, отредактирована посредством технологии Community Translation Framework (CTF). Корпорация Майкрософт предлагает вам статьи, обработанные средствами машинного перевода, отредактированные членами сообщества Майкрософт и переведенные профессиональными переводчиками, чтобы вы могли ознакомиться со всеми статьями нашей базы знаний на нескольких языках. Статьи, переведенные с использованием средств машинного перевода и отредактированные сообществом, могут содержать смысловое, синтаксические и (или) грамматические ошибки. Корпорация Майкрософт не несет ответственности за любые неточности, ошибки или ущерб, вызванные неправильным переводом контента или его использованием нашими клиентами. Подробнее об CTF можно узнать по адресу http://support.microsoft.com/gp/machine-translation-corrections/ru.
Эта статья на английском языке: 826418

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com